Trouble connecting to ownCloud

Ask all your questions on desktop sync clients. Please read the Support Forum Rules
Forum rules
Questions on desktop sync clients only.
You want to report a bug or check for feature requests?
Please visit https://github.com/owncloud/mirall/issues

Re: Trouble connecting to ownCloud

Postby davidc » Wed Oct 10, 2012 2:44 pm

And the browser is running on the same machine on which you're running the WebDAV client? That would be extremely weird - if access via the browser works, there definitely should not be a "timed out" error message via WebDAV client - it's basically the same way of access!


That's what I thought :( It just says "unable to connect to server"
davidc
Newbie
 
Posts: 7
Joined: Tue Oct 09, 2012 5:02 pm

Re: Trouble connecting to ownCloud

Postby RandolphCarter » Wed Oct 10, 2012 2:47 pm

Which client software have you tried? Basically any browser is a basic webdav client as far as I understand it, and since it works with that at least, it might be worth trying a few different ones.
RandolphCarter
Inventory
 
Posts: 4324
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 7.0.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Trouble connecting to ownCloud

Postby davidc » Wed Oct 10, 2012 3:09 pm

I have used the owncloud sync client (Just called owncloud

Also followed the instructions here

http://owncloud.org/support/webdav/

And used the webdav client within the dolphin file manager.
davidc
Newbie
 
Posts: 7
Joined: Tue Oct 09, 2012 5:02 pm

Re: Trouble connecting to ownCloud

Postby kevin.dale.parrish » Tue Oct 30, 2012 7:43 pm

Hi all,

I've ran into the same problem. Server running ubuntu 12.04 and I can access the web interface through http://IPADDRESS/owncloud , but after installing the client on linux mint 12.04 it gives me the error:

Code: Select all
Failed to connect to ownCloud!
Error: Socket operation timed out
Connection to ownCloud could not be established. Please check again.


I have port 80 and 22 forwarded from my router to my server. I'm using apache which is working since I can get to my owncloud site interface and I can ssh and use ftp clients and so forth.
kevin.dale.parrish
Newbie
 
Posts: 2
Joined: Tue Oct 30, 2012 7:37 pm
ownCloud version: 4.5.1

Re: Trouble connecting to ownCloud

Postby kevin.dale.parrish » Tue Oct 30, 2012 9:59 pm

So I found out that it works when you don't use a secure connection. My guess is it's using https (port 443) and I opened my firewall to that port and tried it but it still rejected it.

So does anyone know how to get apache to listen on port 443? I think that might solve the problem.
kevin.dale.parrish
Newbie
 
Posts: 2
Joined: Tue Oct 30, 2012 7:37 pm
ownCloud version: 4.5.1

Re: Trouble connecting to ownCloud

Postby RandolphCarter » Wed Oct 31, 2012 12:02 am

So does anyone know how to get apache to listen on port 443? I think that might solve the problem.

Per default https is done via 443, yes; but setting up SSL requires a bit more than just making apache listen on port 443. Does the web interface work via https already? If it does, your apache is already configured for SSL, and the problem lies somewhere in the connection to the server. If it does not, best search for one of the many guides on how to enable SSL with apache (e.g. this one).
RandolphCarter
Inventory
 
Posts: 4324
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 7.0.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Trouble connecting to ownCloud

Postby orionguru » Tue Nov 06, 2012 9:54 am

Hi everybody!

I think all of us saw a situation when the client is able to connect to owncloud in the LAN (by browser and sync client) and NOT able to connect outside the LAN (forwarded ports) by sync client, bt still can connect via browser.

Looks like Sync Client use exactly port 80 to reach status.php.
If you use another port (forwarded in most cases, for example 1480 fo http and 1443 for https) you can't connect owncloud without proxy ...

How could it be fixed?

Thanks in advance!
orionguru
Newbie
 
Posts: 1
Joined: Tue Nov 06, 2012 9:49 am
ownCloud version: 4.5.0

Re: Trouble connecting to ownCloud

Postby Rancor » Tue Nov 06, 2012 10:03 pm

Hi,

if you don't specify a port then port 80 is used. Thats a normal behavior so just try to specify the port when inserting the URL to your OwnCloud installation like:

http://domain.tld:1480

or

https://domain.tld:1443
*inactive*
Rancor
OwnCloud master
 
Posts: 8247
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 7.0.1
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Trouble connecting to ownCloud

Postby Scarbob » Tue Mar 26, 2013 11:04 am

Hi,
I can only connect via the client on an insecure connection, I get the following in the log-window:
03-26 08:56:34:171 Returning configured owncloud url: "https://192.168.11.64:22/"
03-26 08:56:34:171 Setting up host header: "192.168.11.64"
03-26 08:56:34:172 Setting config handle "032613085634"
03-26 08:56:34:199 ownCloudInfo Network Error: 6
03-26 08:56:34:199 status.php returns: "" 6 Reply: QNetworkReplyImpl(0x107163f10)
03-26 08:56:34:199 No proper answer on "https://192.168.11.64:22/status.php"
03-26 08:56:34:201 OO Custom config file in use: "/Users/xxxxxx/Library/Application Support/ownCloud/owncloud.cfg_032613085634"

I have no trouble connect via ssh on Webmin, CLI, or via a browser.
Sorry, client is on macbook OSX 10.7.5, all software versions are the latest up 25th March 2013.
Scarbob
Newbie
 
Posts: 5
Joined: Tue Mar 26, 2013 8:52 am
Location: Scarborough
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5

Re: Trouble connecting to ownCloud

Postby Rancor » Tue Mar 26, 2013 11:12 am

Hi,

Scarbob wrote:03-26 08:56:34:171 Returning configured owncloud url: "https://192.168.11.64:22/"


the port which you use here is the port for SSH and not for HTTPS. Please read the on the internet available documents like this:

https://help.ubuntu.com/10.04/serverguide/httpd.html

on how to configure your apache for https/ssl. If you don't have some sort of special port configured for the https connection at your webserver you don't have to use an port for the connection.
*inactive*
Rancor
OwnCloud master
 
Posts: 8247
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 7.0.1
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.5.x

PreviousNext

Return to ownCloud desktop sync clients

Who is online

Users browsing this forum: No registered users and 6 guests