OwnCloud is in maintenance mode after upgrade to 5.0

Ask all your questions regarding OC 5.x Please read the Support Forum Rules
Forum rules
Version 5 is not supported anymore! Only security issues are fixed. Please upgrade your ownCloud.
Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting

OwnCloud is in maintenance mode after upgrade to 5.0

Postby th3r3isnospoon » Thu Mar 14, 2013 3:30 pm

Hello All,

I just updated my OwnCloud instance from 4.5.7 to 5.0. I am running Debian squeeze.

I used apt as my installation method and my upgrade method. I got the repository info from here:
http://software.opensuse.org/download/package?project=isv:ownCloud:community&package=owncloud

I just ran apt-get update && apt-get upgrade, and it installed successfully no issues.

After the install finished I opened the web GUI and it says, the upgrade to 5.0 might take a while. I waited about 5 minutes and refreshed the page and am now greeted with 'OwnCloud is in maintenance mode'. I let it sit there for about 15 minutes refreshed the page again, and received the same message. I rebooted the server and am still having getting the same message.


Does anyone know how I can exit maintenance mode?

Also, did I go about something wrong to cause this? My OwnCloud has been working great, just need to get this new version working now :cry:


Thanks,

-th3r3isnospoon
th3r3isnospoon
Newbie
 
Posts: 3
Joined: Thu Mar 14, 2013 3:23 pm
ownCloud version: 5.0.3
Webserver: Apache
Database: SQLite
OS: Linux

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby th3r3isnospoon » Thu Mar 14, 2013 3:51 pm

Alright I figured it out.

I went into my config.php file and put maintenance mode from true to false.

Rebooted apache, refreshed the page and it went through the upgrade procedure again, and boom, good to go :)



Thanks,

-th3r3isnospoon
th3r3isnospoon
Newbie
 
Posts: 3
Joined: Thu Mar 14, 2013 3:23 pm
ownCloud version: 5.0.3
Webserver: Apache
Database: SQLite
OS: Linux

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby stef92 » Thu Mar 14, 2013 4:59 pm

I also upgraded from 4.5.7 to 5.0 and I have the same maintenance message. It has been like this for about 2 hours. I have 100GB of files on it. Does it change by it self? or would I have to go into config.php and change it?

I dont want to touch it if its still "upgrading"

Thanks
stef92
Beginner
 
Posts: 14
Joined: Tue Feb 19, 2013 10:24 pm
ownCloud version: 4.5.6

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby sulliwane » Thu Mar 14, 2013 6:04 pm

I had the same problem,

changed config.php maintenance to true, refreshed the owncloud page, it then upgraded the database...and everything works perfectly now :D

(didn't need to restart apache)

V5 is awsome 8-)
sulliwane
Newbie
 
Posts: 9
Joined: Thu May 31, 2012 10:56 pm

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby nukulaar » Thu Mar 14, 2013 7:42 pm

Hi,

sadly I have the same problem.
If I remove the 'maintanance' flag from the config file manually. The upgrade starts again, but nothing happens.
The config file also has the version following version entry:

Code: Select all
'version' => '4.9.8',


The just creates the following entries:

Code: Select all
{"app":"core","message":"starting upgrade from 4.9.8 to 5.0.0","level":0,"time":1363282418}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1363282418}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1363282418}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1363282439}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1363282439}


The lower messages are repeated everytime I access the site.

I also tried to restart apache.
I'd be glad for some other suggestions.
nukulaar
Newbie
 
Posts: 6
Joined: Fri Jul 27, 2012 4:25 pm
ownCloud version: 4.5.7
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.3-7

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby sveihan » Thu Mar 14, 2013 8:38 pm

I had the same problem when using Firefox:
"Updating ownCloud to version 5.0...." for a long time, then "OwnCloud is in maintenance mode" after a refresh when my patience ran out...

Try this:
Set maintenance to false in config.php
Open owncloud site in Chrome..

The upgrade worked perfect on both my servers after switching from FF to Chrome..

OS: Ubuntu 12.10
Upgrading using apt-get
sveihan
Newbie
 
Posts: 1
Joined: Thu Mar 14, 2013 8:28 pm
Webserver: Apache
Database: MySQL
OS: Linux

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby chillimax » Thu Mar 14, 2013 8:45 pm

similar story here, i ran the upgrade, not sure if it was in IE or Chome first, but it just stuck at maintenance mode. Reset the maintenance mode flag and pointed browser at the site again, this time using a different browser, not sure if it was IE or Chrome and it worked.
chillimax
Beginner
 
Posts: 19
Joined: Thu Mar 14, 2013 6:26 pm
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.10

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby nukulaar » Thu Mar 14, 2013 9:37 pm

I already used chrome :(
nukulaar
Newbie
 
Posts: 6
Joined: Fri Jul 27, 2012 4:25 pm
ownCloud version: 4.5.7
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.3-7

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby Riko11 » Thu Mar 14, 2013 11:06 pm

I had the same issue with upgrading from 4.5.7 to 5.0.0.
I did not use apt-get for installation. For installation I downloaded the tar-File and extracted it to my owncloud-Folder.

After restarting apache he got also stuck in maintenance mode and did not upgrade anything. Setting the flag for maintenance to false didn't help either.

Then i noticed the owner from the file ".htaccess" was set to nobody:nogroup.
So I changed the owner with "chown apache: .htaccess" (or whatever your apache-User ist), set maintenance-mode to false and restarted apache again (to be safe).

And voilá he upgraded everthing fine!
Riko11
Newbie
 
Posts: 1
Joined: Thu Mar 14, 2013 10:52 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.2

Re: OwnCloud is in maintenance mode after upgrade to 5.0

Postby JMLatOwnCloud » Thu Mar 14, 2013 11:36 pm

Same problem here, different setup.

Environment:
- Upgrading OC 4.5.8 -> 5.0.0
- Windows Desktop
- Apache
- Installation method: tar file
- Browser: Firefox

After starting the update process got first the message "Updating ownCloud to version 5.0...." for a long time, then after a manual page refresh "OwnCloud is in maintenance mode".

Workaround that worked for me:
- In config.php set maintenance value to false
- Restart Apache
- Restart Firefox
- Relaunch ownCloud page

After that the update process did restart and completed successfully. Strange, strange...
JMLatOwnCloud
Newbie
 
Posts: 7
Joined: Thu Mar 14, 2013 11:13 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Windows Desktop
PHP version: 5.4.11

Next

Return to ownCloud Community Edition 5.x

Who is online

Users browsing this forum: No registered users and 10 guests