Unable to enable apps

Ask all your questions regarding OC 4.x and older. Please read the Support Forum Rules
Forum rules
Version 4 is not supported anymore! Please upgrade your ownCloud for security and support.
Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting

Unable to enable apps

Postby andraden » Wed Mar 14, 2012 9:40 pm

Hi' I've just installed this wonderful piece of software, and trying to enable some of the apps, already listed, when I installed the software, but nothing happens when I click "Enable". I'm especially interrested in the "mail"-app, since I'm already running roundcube elsewhere.

Can someone please guide me to some info on, how to get the apps to work?

Thanks in advance :-)

Kind regards
Jacob

Some info on my system:

Environment: Own server
Server: Apache/PHP 5.3, CentOS 5.8
Database: mysql
Client: IE/Win7
OC-Version: 3
PHP-Version: 5.3

Passed Tests (8)
  • PHP Version:5.3.3
  • Server Software:(Apache) Apache
  • Apache Mode:mod_php
  • php.ini:upload_max_filesize:300M
  • php.ini:post_max_size:300M
  • php.ini:memory_limit:300M
  • File upload limit:Upload files up to 300 MB
  • Config (Writeable):Config is writeable
Possible Problems (1)
  • File Upload:Please check your settings (see warning below) (I have no clue of the error, I can upload files...)
No Critical Issues.
andraden
Newbie
 
Posts: 2
Joined: Wed Mar 14, 2012 9:26 pm

Re: Unable to enable apps

Postby nagypeterendre » Mon Mar 19, 2012 2:36 pm

That's because some of the apps people developed for owncloud are either not packaged properly (for example xml files missing and all that) or not written properly :)
There's an option to install the through GIT too (For the latter one, try to search how, cause i have no clue how to use git even though I installed it.)
nagypeterendre
Newbie
 
Posts: 5
Joined: Sat Mar 17, 2012 11:52 am

Re: Unable to enable apps

Postby FordPrefect » Mon Mar 19, 2012 11:09 pm

nagypeterendre wrote:That's because some of the apps people developed for owncloud are either not packaged properly (for example xml files missing and all that) or not written properly :)
There's an option to install the through GIT too (For the latter one, try to search how, cause i have no clue how to use git even though I installed it.)


To check this, just view the log file ... pretty sure it says something like
Code: Select all
"App does not provide an info.xml file"
FordPrefect
Helpful Elf
 
Posts: 144
Joined: Tue Feb 28, 2012 12:10 am


Return to ownCloud Community Edition 4.x and older

Who is online

Users browsing this forum: Bing [Bot] and 13 guests