Netdrive cannot connect to owncloud

Ask all your questions regarding OC 4.x and older. Please read the Support Forum Rules
Forum rules
Version 4 is not supported anymore! Please upgrade your ownCloud for security and support.
Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting

Netdrive cannot connect to owncloud

Postby Lunix » Sat Nov 10, 2012 7:42 pm

Hi,

I am using owncloud 4.5.1a and tried to create a network drive with NetDrive over https but it always show me an error msg " Mounting drive Y: failed! Login failed. Please check the internet connection. "

I used the option under Advanced where you have to check the box "Use HTTPS". Encoding is on "System default"
When I am trying over http then it works but thats not what I want!

Any ideas?
Lunix
Newbie
 
Posts: 5
Joined: Sat Nov 10, 2012 6:14 pm
ownCloud version: 4.5.1a

Re: Netdrive cannot connect to owncloud

Postby Debian » Sat Nov 10, 2012 8:51 pm

Why NetDrive? :o
An alternative to NetDrive:
I've realized with a simple batch file.

webdav.bat

Code: Select all
@ echo off

echo WebDAV OwnCloud
 
REM Here please enter the username and your current password

Set usr = YOUR NAME
set pwd = YOUR PASSWORD

REM create the WebDAV drive

if exist Z: goto disconnect
goto connect

: connect
echo The connection to the WebDAV drive is made.
 
Net use Z: https://YOUR DOMAIN/remote.php/webdav / user:%%%% usr / pwd persistent: no
goto end

: disconnect
echo The existing drive is disconnected.
net use Z: / d

: end
 


even easier:

Code: Select all
Set usr = YOUR NAME
set pwd = YOUR PASSWORD

Net use Z: https://YOUR DOMAIN/remote.php/webdav / user:%%%% usr / pwd persistent: no
Mich muss man sich nervlich erst mal leisten können!
User avatar
Debian
Beginner
 
Posts: 10
Joined: Sun Oct 28, 2012 12:18 pm
ownCloud version: 5.0.9
Webserver: nginx
Database: SQLite
OS: Linux
PHP version: 5.3

Re: Netdrive cannot connect to owncloud

Postby Lunix » Sat Nov 10, 2012 9:19 pm

I tried also this before!

Its not working!
The windows network drive option = not working (dont accept the User/Password)
owncloud SyncClient = not working (connection possible but the synchronisation gives an error)

Maybe there is a problem with the server configuration?

I use the latest Debian version with Apache.
Lunix
Newbie
 
Posts: 5
Joined: Sat Nov 10, 2012 6:14 pm
ownCloud version: 4.5.1a

Re: Netdrive cannot connect to owncloud

Postby Debian » Sat Nov 10, 2012 9:31 pm

Windows Regitry changed?

Other Possibilities:

In the event that you can’t change your authentication type you can try going the other way with a registry hack to allow basic authentication. This is for Vista. It may not work for 7. I have not tried it. Got it from here:

To work around this behavior, enable Basic authentication on the client computer. To do this, add the BasicAuthLevel registry entry to the following registry subkey, and then set the entry to a value of 2 or more:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

To enable Basic authentication on the client computer, follow these steps:
Click Start , type regedit in the Start Search box, and then click regedit.exe in the Programs list.
Locate and then click the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

On the Edit menu, point to New, and then click DWORD Value.
Type BasicAuthLevel, and then press ENTER.
On the Edit menu, click Modify.
In the Value data box, type 2, and then click OK.



Note The mapping is as follows:
0 - Basic authentication disabled
1 - Basic authentication enabled for SSL shares only
2 or greater - Basic authentication enabled for SSL shares and for non-SSL shares
Exit Registry Editor, and then restart the computer.
Mich muss man sich nervlich erst mal leisten können!
User avatar
Debian
Beginner
 
Posts: 10
Joined: Sun Oct 28, 2012 12:18 pm
ownCloud version: 5.0.9
Webserver: nginx
Database: SQLite
OS: Linux
PHP version: 5.3

Re: Netdrive cannot connect to owncloud

Postby Lunix » Sat Nov 10, 2012 9:45 pm

I know that and did it but have still that problem!

Its a bit confusing cause on the Android apps its working fine just on my PC and Laptop only over http!

Thats why I thought its maybe a missconfiguration on my Debian server or in Apache.
Lunix
Newbie
 
Posts: 5
Joined: Sat Nov 10, 2012 6:14 pm
ownCloud version: 4.5.1a

Re: Netdrive cannot connect to owncloud

Postby Debian » Sat Nov 10, 2012 9:51 pm

My old config on Debian Squeeze x64, works with NetDrive (now i use Debian and Plesk 11 with mysql db)

Code: Select all
VirtualHost *:80>
   ServerAdmin webmaster@cloud-center.eu
   DocumentRoot /var/www/cloud-center.eu/
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /var/www/cloud-center.eu/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride All
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog ${APACHE_LOG_DIR}/error.log
   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn
   CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:443>
   ServerAdmin webmaster@cloud-center.eu
                SSLEngine On
                SSLCertificateChainFile /var/www/zertifikat/intermediate.crt
                SSLCertificateFile      /var/www/zertifikat/www_cloud-center.eu.crt
                SSLCertificateKeyFile   /var/www/zertifikat/www.cloud-center.eu.key

   DocumentRoot /var/www/cloud-center.eu/
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /var/www/cloud-center.eu/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride All
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog ${APACHE_LOG_DIR}/error.log
   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn
   CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
Mich muss man sich nervlich erst mal leisten können!
User avatar
Debian
Beginner
 
Posts: 10
Joined: Sun Oct 28, 2012 12:18 pm
ownCloud version: 5.0.9
Webserver: nginx
Database: SQLite
OS: Linux
PHP version: 5.3


Return to ownCloud Community Edition 4.x and older

Who is online

Users browsing this forum: No registered users and 15 guests