Lost Password

Ask all your questions regarding OC 5.x Please read the Support Forum Rules
Forum rules
Before you post; make sure you are using at least PHP Version 5.3.x - Also read How To Solve Problems By Yourself

Lost Password

Postby woodlawn » Wed Mar 27, 2013 6:17 pm

I have owncloud set up with the same E-mail settings I had with 4.5.x and Lost password does not work with version 5. I get a blank screen with the URL http://www.XXXXX.com/owncloud/index.php/lostpassword/. The screen just goes white.

Checking the error log I see this entry:

[27-Mar-2013 17:03:52 UTC] PHP Fatal error: Call to undefined method OC_Mail::ValidateAddress() in /XXX/XXX/public_html/owncloud/lib/public/util.php on line 222

Any help would be appreciated, I am stuck.

Thanks
woodlawn
Beginner
 
Posts: 32
Joined: Wed Mar 27, 2013 6:11 pm

Re: Lost Password

Postby Rancor » Wed Mar 27, 2013 6:23 pm

Hi,

which PHP version are you running?
*mostly inactive*
Rancor
OwnCloud master
 
Posts: 7501
Joined: Sat May 26, 2012 2:00 pm
ownCloud version: 6.0.4
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Lost Password

Postby woodlawn » Wed Mar 27, 2013 6:29 pm

I just checked, 5.1.17, I need 5.3.x right, and I added AddHandler application/x-httpd-php53 .php in my htaccess file, but that did not change anything.
woodlawn
Beginner
 
Posts: 32
Joined: Wed Mar 27, 2013 6:11 pm

Re: Lost Password

Postby woodlawn » Wed Mar 27, 2013 6:34 pm

I just upgraded to 5.3.x and no luck, thoughts?
woodlawn
Beginner
 
Posts: 32
Joined: Wed Mar 27, 2013 6:11 pm

Re: Lost Password

Postby Rancor » Wed Mar 27, 2013 6:45 pm

Which one of 5.3.x? You need at last 5.3.4
*mostly inactive*
Rancor
OwnCloud master
 
Posts: 7501
Joined: Sat May 26, 2012 2:00 pm
ownCloud version: 6.0.4
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Lost Password

Postby woodlawn » Wed Mar 27, 2013 6:47 pm

5.3.22. I see that I can move to 5.4, will ownCloud work with that?
woodlawn
Beginner
 
Posts: 32
Joined: Wed Mar 27, 2013 6:11 pm

Re: Lost Password

Postby woodlawn » Wed Mar 27, 2013 9:50 pm

Upgraded to 5.4.x and same thing is happening.
woodlawn
Beginner
 
Posts: 32
Joined: Wed Mar 27, 2013 6:11 pm

Re: Lost Password

Postby RandolphCarter » Wed Mar 27, 2013 11:01 pm

Hm, it doesn't seem to be a general bug, at least for me the lost password reset function works in owncloud 5.
You are sure your ownCloud now runs at least under php 5.3.4? And that all ownCloud files are correctly uploaded to your server?
RandolphCarter
Inventory
 
Posts: 4004
Joined: Wed May 30, 2012 7:42 am
ownCloud version: 6.0.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Lost Password

Postby woodlawn » Wed Mar 27, 2013 11:37 pm

Hi

I have upgraded to php 5.4. and am getting a bit further along. Now I get an error at least on the webpage.

I ran the web setup version, and was a clean install.

In the log I now get this:

{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1364423698}
{"app":"mail","message":"Could not instantiate mail function.","level":3,"time":1364423699}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1364423699}
woodlawn
Beginner
 
Posts: 32
Joined: Wed Mar 27, 2013 6:11 pm

Re: Lost Password

Postby RandolphCarter » Thu Mar 28, 2013 1:18 am

Could you also check the server log (see this FAQ entry) for any related errors?
Do you have safe_mode enabled by any chance?
RandolphCarter
Inventory
 
Posts: 4004
Joined: Wed May 30, 2012 7:42 am
ownCloud version: 6.0.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Next

Return to ownCloud Community Edition 5.x

Who is online

Users browsing this forum: No registered users and 24 guests