Can't connect via webdav witch WinXP SP3

Ask all your questions regarding OC 5.x Please read the Support Forum Rules
Forum rules
Before you post; make sure you are using at least PHP Version 5.3.x - Also read How To Solve Problems By Yourself

Can't connect via webdav witch WinXP SP3

Postby Brokerone » Mon Nov 18, 2013 10:50 pm

Hi everyone!

I'm there again to try to solve my problem.. :D
I've a owncloud perfectly configured and I can enter via http/https from anywhere.
But i have a problem.
I'm trying to add the shared data owncloud folder to Windows XP SP3 via webdav and i receive the next messages:

Code: Select all
C:\Users\Usuario>net use Z: http://192.168.2.139/owncloud/remote.php/webdav /use
r:user pass
System error 67.
Can not find the network name.
-----------------
C:\Users\Usuario>net use Z: \\192.168.2.139@ssl\owncloud\remote.php\webdav /user:user pass
System error 1244.
We did not perform the requested operation because the user has not been authenticated.
-----------------
C:\Users\Usuario>net use Z: \\192.168.2.139\owncloud\remote.php\webdav /user:user pass
System error 53.
Not found the path network.
-----------------
C:\Users\Usuario>net use Z: \\192.168.2.139\remote.php\webdav /user:user pass
System error 53.
Not found the path network.
-----------------
C:\Users\Usuario>net use Z: https://192.168.2.139/remote.php/webdav /user:user pass
System error 1244.
We did not perform the requested operation because the user has not been authenticated.


(sorry, I've translated the error code because my O.S is in Spanish)

And if i try to sync with the assistant to add network place apparently works but Windows ask me an user and password. And when I put the user and password that I use to log via http says that the username is wrong.... :? :?

Image

I've to add a special user to sync with Webdav??

Maybe I can solve my necessity by other way. I only want to acces to my data (owncloud data) by LAN. I've users that access via WAN perfectly and works fine. But I'm searching the best way to acces by local.
I can use owncoud with Windows client but i dont want to have all the data in the local hosts computers because the hard drive are very small (only 80GB) and the data from owncloud are around 200GB.

For this reason I'm trying to connect via Webdav. There are another possibility?
I think that samba doesn't work fine with owncloud folder (adds group permisions problems)

I hope someone can help me!
I solved all my problems on this forum

Thank you again

My Server system is:
Code: Select all
Environment: Debian 6 RootServer
Server: apache
Database: MySQL
OC-Version: the last, 5.0.11
PHP-Version:5.3.3-7+squeeze17


My Client system is:
Code: Select all
Environment: Windows XP SP3 and Windows 7
Brokerone
Beginner
 
Posts: 14
Joined: Fri Sep 27, 2013 11:33 pm
ownCloud version: 5.0.10
Webserver: Apache
Database: MySQL
OS: Linux

Re: Can't connect via webdav witch WinXP SP3

Postby Rancor » Tue Nov 19, 2013 7:15 am

Hi,

have you checked the documentation available here:

http://doc.owncloud.org/server/5.0/user ... ml#windows

especially the box with the exclamation mark?
Rancor
OwnCloud master
 
Posts: 5918
Joined: Sat May 26, 2012 2:00 pm
ownCloud version: 6.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.4.x

Re: Can't connect via webdav witch WinXP SP3

Postby beck » Tue Nov 19, 2013 9:06 am

I use cyberduck for webdav. WinXp built in webdav is not stable.
http://cyberduck.ch/
beck
Beginner
 
Posts: 10
Joined: Wed Oct 17, 2012 7:17 am
ownCloud version: 4.5.5

Re: Can't connect via webdav witch WinXP SP3

Postby Brokerone » Tue Nov 19, 2013 5:49 pm

Hello Rancor,
I've readed it and applied the solution. And the problem is the same... thanks.

Beck now i will try with cyberduck but i need to assign a drive letter to Windows. Does Cyberduck that?

Thank you very much
Brokerone
Beginner
 
Posts: 14
Joined: Fri Sep 27, 2013 11:33 pm
ownCloud version: 5.0.10
Webserver: Apache
Database: MySQL
OS: Linux

Re: Can't connect via webdav witch WinXP SP3

Postby Rancor » Tue Nov 19, 2013 7:28 pm

Hi,

could be also possible that your WebDAV access is broken. Have you checked this FAQ thread:

viewtopic.php?f=17&t=7536

especially the part on how to debug such problems.
Rancor
OwnCloud master
 
Posts: 5918
Joined: Sat May 26, 2012 2:00 pm
ownCloud version: 6.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.4.x

Re: Can't connect via webdav witch WinXP SP3

Postby Brokerone » Tue Nov 19, 2013 9:50 pm

Wow! thank you so much Rancor! I'm going to follow all the steps, I hope have forgotten some of them.
Now I'm going to post how about.

Thanks again
Brokerone
Beginner
 
Posts: 14
Joined: Fri Sep 27, 2013 11:33 pm
ownCloud version: 5.0.10
Webserver: Apache
Database: MySQL
OS: Linux

Re: Can't connect via webdav witch WinXP SP3

Postby Brokerone » Wed Nov 20, 2013 7:35 pm

Hello,
I tried to follow the steps that Rancor describes and the result is the same. I suppose that I'm doing something wrong.

I'm executed a2enmod rewrite and I have RewriteEngine on on my .htaccess file

I think that Webdav in my server is not running.
Because when I put on the Explorer:

Code: Select all
https://192.168.2.139/remote.php/webdav

I found a Error 404

And when I put:

Code: Select all
http://192.168.2.139/owncloud/remote.php/webdav

I found a page with the Owncloud logo on the head and the message: Cloud not found

I installed cadaver to debug what is wrong and I receive the next information:

Code: Select all
root@myserver:/home/user# cadaver localhost
You can access to / (¿have you WebDAV enabled?):
405 Method Not Allowed
Conection with 'localhost' closed.
dav:!>


For this reason I think that WebDav is not running
I'm so sorry because my level on linux is like a junior administrator.

Thank you very much friends!
Brokerone
Beginner
 
Posts: 14
Joined: Fri Sep 27, 2013 11:33 pm
ownCloud version: 5.0.10
Webserver: Apache
Database: MySQL
OS: Linux

Re: Can't connect via webdav witch WinXP SP3

Postby Sphinx » Wed Nov 20, 2013 7:40 pm

In your httpd.conf should have the lines

LoadModule dav_module libexec/libdav.so
DAVLockDB /tmp/DAVLock
DAVMinTimeout 600

and any directory location you want DAV access to just add

DAV On

between the location tags.
Sphinx
Teacher
 
Posts: 340
Joined: Mon Nov 26, 2012 7:45 pm
Location: Silicon Valley
ownCloud version: 5.0.14a
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.4

Re: Can't connect via webdav witch WinXP SP3

Postby Brokerone » Thu Nov 21, 2013 12:06 am

I added this lines in httpd.conf file (/etc/apache2), restart apache and the result was:

With all lines:

Code: Select all
apache2: Syntax error on line 207 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/httpd.conf: Cannot load /etc/apache2/libexec/libdav.so into server: /etc/apache2/libexec/libdav.so: cannot open shared object file: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.


Commenting the first line:

Code: Select all
Syntax error on line 2 of /etc/apache2/httpd.conf:
Invalid command 'DAVLockDB', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.


I don't know what is wrong...

Thanks you very much again
Brokerone
Beginner
 
Posts: 14
Joined: Fri Sep 27, 2013 11:33 pm
ownCloud version: 5.0.10
Webserver: Apache
Database: MySQL
OS: Linux

Re: Can't connect via webdav witch WinXP SP3

Postby Rancor » Thu Nov 21, 2013 8:58 am

Hi,

normally this WebDAV stuff is not needed in your config because ownCloud brings its own WebDAV implementation.

As you can't open both of your URLs it seems that you're just inserting the wrong URLs or the rewrite rules are not working.
Rancor
OwnCloud master
 
Posts: 5918
Joined: Sat May 26, 2012 2:00 pm
ownCloud version: 6.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.4.x

Next

Return to ownCloud Community Edition 5.x

Who is online

Users browsing this forum: Google [Bot] and 14 guests