[Solved] ClientSync not working... ? SSL Cert

Ask all your questions on desktop sync clients. Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
Berndinox
Beginner
Posts: 16
Joined: Wed May 09, 2012 1:02 pm

[Solved] ClientSync not working... ? SSL Cert

Postby Berndinox » Thu May 10, 2012 12:59 pm

ClientSync over https is still not working.

Server: Debian + nginx + php5-fpm (PHP Version 5.3.11-1~dotdeb.0)
Client: Windows 7 x64

The Client always:
The last Sync was OK.
The Remotefolder ownclouds://cloud.xxxxx.de/files/webdav.php/ doesn't exist


When i open the Webdav Adress with Google Chrome i can Browse all folders without problems. But i also can't download files.
For the following Webadress wasn't found an file: https://cloud.xxxx.de/files/webdav.php/ ... 0_xvid.avi - Error 6 (net::ERR_FILE_NOT_FOUND)

When i first add the Owncloud Server in the Client all looks fine:

Code: Select all

Versuche mit ownCloud https://cloud.xx.dezu verbinden...
Erfolgreich verbunden mit https://cloud.xxxx.de: ownCloud Version 2012.0.3

Überprüfe lokales Verzeichnis C:/Users/uxxxxxxd/ownCloud
Lokales Verzeichnis C:/Users/xxxxx/ownCloud existiert schon, wird zur Synchronisation eingerichtet.

Entferntes Verzeichnis clientsync erfolgreich angelegt.
Lokales Synchronisationsverzeichnis C:/Users/uppc78d/ownCloud erfolgreich angelegt!


then he says: "Sync for 1 File startet".

the Folder "clientsync" was created on the Server and i can see them in the webinterface. But then the Error appears....

nginx.conf:

Code: Select all

server {


        listen 443 ssl;

        ssl_certificate    /etc/nginx/ssl/zertifikat.crt;
        ssl_certificate_key    /etc/nginx/ssl/zertifikat.key;

        server_name cloud.sheepit.de;

        access_log /var/log/nginx/cloud.xxxx.de.access_log;
        error_log /var/log/nginx/cloud.xxxxxx.de.error_log;

        root /var/www/cloud.xxxx.de;
        index index.php index.html index.htm default.html default.htm;
       dav_methods PUT DELETE MKCOL COPY MOVE;
       create_full_put_path on;
       dav_access user:rw group:rw all:r;
       location = /favicon.ico {
                log_not_found off;
                access_log off;
                expires max;
       }
       location = /robots.txt {
                allow all;
                log_not_found off;
                access_log off;
       }
       # Deny all attempts to access hidden files such as .htaccess, .htpasswd, .DS_Store (Mac).
       location ~ /\. {
                deny all;
                access_log off;
                log_not_found off;
       }
       location / {
                index index.php;
                try_files $uri $uri/ @webdav;
       }
       location @webdav {
                fastcgi_split_path_info ^(.+.php)(/.+)$;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                include /etc/nginx/fastcgi_params;
 fastcgi_param HTTPS on;
                fastcgi_pass 127.0.0.1:9000;
       }
       location ~ \.php$ {
                try_files $uri =404;
                include /etc/nginx/fastcgi_params;
                fastcgi_pass 127.0.0.1:9000;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_index index.php;
       }
}


over the Webinterface all is working fine.

Maybe someone can helps me out.
Sorry for my bad english.

BR Bernd

EDIT:
When i change the settings to use http over Port 80 it's working pretty fine.... thats strnge
moved to the SyncClient Forum ~ snapr
Last edited by Berndinox on Thu May 10, 2012 10:48 pm, edited 1 time in total.

Berndinox
Beginner
Posts: 16
Joined: Wed May 09, 2012 1:02 pm

Re: ClientSync still not working... ? Pls help

Postby Berndinox » Thu May 10, 2012 10:46 pm

hy, i actually got the solution:

the problem was that there was an error related to the ssl cert.

the problem isn't that it was an self signed cert, but the common name have to include the subdomain.
i only signed the cert with the common name domain.com but my owncloud is running in cloud.domain.com

You have to sign your cert for the subdomain.

hope i could help you.

BR Bernd

kevinsimpson35
Newbie
Posts: 4
Joined: Thu Apr 12, 2012 11:08 am

Re: [Solved] ClientSync not working... ? SSL Cert

Postby kevinsimpson35 » Mon May 14, 2012 1:27 pm

I am also suffering from the same problem.When I try to provision kbox agent to a pc with winows 7 professional(x64) it keeps hanging on client sync. The message waiting does not go away

christophk
Starter
Posts: 72
Joined: Fri May 25, 2012 11:25 pm

Re: ClientSync still not working... ? Pls help

Postby christophk » Wed May 30, 2012 11:47 pm

Berndinox wrote:hy, i actually got the solution:

the problem was that there was an error related to the ssl cert.

the problem isn't that it was an self signed cert, but the common name have to include the subdomain.
i only signed the cert with the common name domain.com but my owncloud is running in cloud.domain.com


BR Bernd


Hi Bernd
I am struggling with the same problem but can't solve it.

Can you tell me what exactly I have to fill into the self generated Cert?

IS the country, hometown and company relevant?

My "domain" is an IP redirection from no-ip.org

So is the domain that I have to write in the cert then

xxx.no-ip.org/owncloud ?

I would really appreciate to get some help on that topic. I manage to get all synced fine without ssl and inside the private network also with ssl.
The last thing seems to be that handshake problem with the cert.

Best regards

Christoph
KR, CK

Owncloud 4.5.10 & 5.0.6
Hosted Webspace (Uberspace)
Apache 2.2.15 (CentOS)
PHP 5.4.4

jack
Newbie
Posts: 9
Joined: Mon May 28, 2012 4:33 pm

Re: [Solved] ClientSync not working... ? SSL Cert

Postby jack » Wed May 30, 2012 11:59 pm

The common name in the certificate has to be the fully qualified hostname used in the url, For example :

In https://www.example.com/, the common name is 'www.example.com'
In https://cloud.example.com/, the common name is 'cloud.example.com'
In https://www.cloud.test.example.com/ it is 'www.cloud.test.example.com'

christophk
Starter
Posts: 72
Joined: Fri May 25, 2012 11:25 pm

Re: [Solved] ClientSync not working... ? SSL Cert

Postby christophk » Fri Jun 01, 2012 12:28 am

Hello everyone.

I got this to work.

My problem was that I didn't give the server a name (ServerName xxx.no-ip.org)

Howto:
http://aslamnajeebdeen.com/blog/how-to- ... -on-ubuntu

I now gave the server the same name as the common name in the certificate and now the handshake works.

Thanks again for every help!

Greetings!

Christoph
KR, CK

Owncloud 4.5.10 & 5.0.6
Hosted Webspace (Uberspace)
Apache 2.2.15 (CentOS)
PHP 5.4.4

SPeedY
Beginner
Posts: 33
Joined: Tue Aug 07, 2012 4:51 pm

Re: [Solved] ClientSync not working... ? SSL Cert

Postby SPeedY » Wed Jan 30, 2013 11:30 pm

Thank you Berndinox. I follow your post and my ssl-handchack issue is now gone.
O.C 7.0.0 on Ubuntu 12.04 amd64 Server under Apache with MySQL

masithe
Newbie
Posts: 2
Joined: Sat Jun 04, 2016 12:09 pm
ownCloud version: 8.2.5
Webserver: Apache
Database: SQLite
OS: Linux
PHP version: 5.6

Re: [Solved] ClientSync not working... ? SSL Cert

Postby masithe » Wed Jun 08, 2016 8:35 pm

How do you sign self-certificate for localhost?
You include `192.168.1.107/owncloud` in the commonname but not sure if it is right.
I cannot get HTTPS work.


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud desktop sync clients”

Who is online

Users browsing this forum: No registered users and 1 guest