OC4 Caldav/Webdav doesnt accept username and password

Ask all your questions on desktop sync clients. Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
markus
Newbie
Posts: 9
Joined: Wed May 30, 2012 9:56 am

OC4 Caldav/Webdav doesnt accept username and password

Postby markus » Fri Jun 01, 2012 11:12 am

Environment SharedHosting
Server Apache2
Database mysql
Client Thunderbird+Lightning, IPod Touch 4th
Versions of OwnCloud and PHP ownCloud 4.0.0 + PHP 5.3.1

Hello iam trying so sync the contacts and the calendar. The web-application works fine.

Iam use Thunderbird and Lightning with the newest version.
The calendar names "privat" and the username is for tests "admin".
the url that i´ve tried is : http://[domain].com/remote.php/caldav/calendars/admin/privat but he doenst accept the username and password!? same on ios (ipod touch)
but the login to the frontend works fine..

same procedure with webdav
http://[domain].com/files/webdav.php
he ask me for username and password on and on..

Code: Select all

<d:error><s:exception>Sabre_DAV_Exception_NotAuthenticated</s:exception><s:message>No basic authentication headers were found</s:message><s:sabredav-version>1.6.2</s:sabredav-version></d:error>


i haved read so many threads for owncloud 3 but they hints doesnt work on OC4.

please help?! :)

Ardeo
Newbie
Posts: 4
Joined: Sat Jun 02, 2012 11:45 am

Re: OC4 Caldav/Webdav doesnt accept username and password

Postby Ardeo » Sat Jun 02, 2012 8:49 pm

Hi,

just having the same problem.
For me the solution of this post works :).

markus
Newbie
Posts: 9
Joined: Wed May 30, 2012 9:56 am

Re: OC4 Caldav/Webdav doesnt accept username and password

Postby markus » Mon Jun 04, 2012 12:05 am

thank you verry much.. that works..
ive doubt by myself :D

rkulp208
Beginner
Posts: 14
Joined: Sun May 20, 2012 2:31 am

Re: OC4 Caldav/Webdav doesnt accept username and password

Postby rkulp208 » Mon Jun 04, 2012 11:23 pm

just having the same problem.
For me the solution of this post works :).


Do you know if this (or its equivalent) works with IIS 7.5?

godfuture
Beginner
Posts: 24
Joined: Sat May 03, 2014 5:45 pm
ownCloud version: 7.0.3
Webserver: IIS
Database: MySQL
OS: Windows Desktop
PHP version: 5.5.15

Re: OC4 Caldav/Webdav doesnt accept username and password

Postby godfuture » Sat May 03, 2014 6:10 pm

rkulp208 wrote:
just having the same problem.
For me the solution of this post works :).


Do you know if this (or its equivalent) works with IIS 7.5?


Exactly my question!
If someone knows to write the equivalent query of apache auth rewrite for IIS, please tell me:
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

I've tried to import this rule in IIS 7.5 rewrite mod, but the converter tells me that the flag env is not supported.

Does this mean (http://www.micronovae.com/ModRewrite/re ... ility.html, see [E=var:val] Set environment variable) that we cant use basic auth with sabeDav hosted on IIS?

rkulp208
Beginner
Posts: 14
Joined: Sun May 20, 2012 2:31 am

Re: OC4 Caldav/Webdav doesnt accept username and password

Postby rkulp208 » Sat May 03, 2014 9:49 pm

I gave up and put OwnCloud on a Linux server.


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud desktop sync clients”

Who is online

Users browsing this forum: No registered users and 2 guests