How to fix CalDAV|CardDAV|WebDAV problems

Here we try to answer typical questions
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
destef1
Newbie
Posts: 3
Joined: Sun Jun 23, 2013 12:31 pm
ownCloud version: 5.0.7
Webserver: Apache
Database: MySQL
OS: Unknown

Re: How to fix if Web interface working but not WebDAV/clien

Postby destef1 » Mon Jun 24, 2013 3:01 am

If you have Mod Security running then try adding this to the first line of you .htacess file

Code: Select all

<Limit GET POST>
order allow,deny
allow from all
</Limit>
<Limit PUT DELETE>
order allow,deny
allow from all
</Limit>


worked for me.

scalvo
Newbie
Posts: 4
Joined: Mon Jun 17, 2013 5:07 pm
ownCloud version: 5.0.7
Webserver: Apache
Database: SQLite
OS: Linux

Re: How to fix if Web interface working but not WebDAV/clien

Postby scalvo » Fri Jun 28, 2013 7:46 pm

Rancor wrote:Hi,

you only need this if you have mod_dav running on your server. Then you have to put this in your apache vhost configuration.


Hi, I don't have acces to the apache conf on my hosting, can I do this via .htacces?

Thank you.

Vincent144
Newbie
Posts: 7
Joined: Sat Jun 29, 2013 12:53 am
ownCloud version: 5.0.7
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 5.4.9

Re: How to fix if Web interface working but not WebDAV/clien

Postby Vincent144 » Mon Jul 01, 2013 12:13 am

Yes scalvo, it shoud be the same thing.

I have a problemwith Nginx, this is a 401 error :

Code: Select all

192.168.0.254 - - [30/Jun/2013:01:51:39 +0200] "PROPFIND /remote.php/caldav/calendars/Commander/personnel/ HTTP/1.1" 401 303 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130623 Thunderbird/17.0.7 Lightning/1.9.1"
192.168.0.254 - Commander [30/Jun/2013:01:52:32 +0200] "PROPFIND /remote.php/caldav/calendars/Commander/personnel/ HTTP/1.1" 401 296 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130623 Thunderbird/17.0.7 Lightning/1.9.1"


All seem good here:

Code: Select all

:/var/lib/php5# ll
total 4
drwx-wx-wt 1 root     root      62 juil.  1 00:09 ./
drwxr-xr-x 1 root     root     666 juin  22 00:36 ../
-rw------- 1 www-data www-data 110 juin  30 23:45 sess_me9ukd1daumekod6t09akditc2


I followed http://doc.owncloud.org/server/5.0/admi ... figuration

I don't understand what kind of problem it could be?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: How to fix if Web interface working but not WebDAV/clien

Postby RealRancor » Mon Jul 01, 2013 9:59 am

Hi,

please don't use a FAQ thread for a specific support and stick on your existing thread about your issue.
*gone*

broozer
Newbie
Posts: 2
Joined: Wed Dec 04, 2013 5:15 pm
ownCloud version: 5.0.12
Webserver: Apache
Database: SQLite
OS: Linux
PHP version: 5.4

Re: How to fix if Web interface working but not WebDAV/clien

Postby broozer » Wed Dec 04, 2013 8:16 pm

I ran into this also. Turns out I did not have the following in httpd.conf :

Code: Select all

DavLockDB /path/writable_by_apache_user/DavLock

Hope this might help someone...

rodmichael
Newbie
Posts: 2
Joined: Wed Jul 23, 2014 1:14 am
ownCloud version: 6.0.3
Database: SQLite
OS: Unknown

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby rodmichael » Thu Jul 24, 2014 1:09 am

Please tell me where to start to look or figure out this problem in my installation.

I am having the problem ["Your web server is not yet properly setup to allow files synchronization because the WebDAV interface seems to be broken. Please double check the installation guides."] as described in this thread.

I am installing on a FreeNAS Mini running FreeNAS 9.2.1.5. My server address is 192.168.1.2. My Client OS is Windows 8.1. I don't know anything about "IIs" although I doubt it's applicable to me.

My ownCloud version is actually 6.0.3 and was installed as a "plugin" provided with FreeNAS 9.2.1.5.

I mostly don't understand a thing in this thread or how it relates to my installation in terms of fixing. This thread and other referenced threads provide reference to "Apache;" "Linux;" and other languages (I guess they're languages or specific servers.)

I have looked for PHP.ini to enable PHP logging (although it seems to be enabled already). I don't know where to look for some of the modules mentioned in this thread.

Thanks!!

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby RandolphCarter » Thu Jul 24, 2014 8:36 am

I mostly don't understand a thing in this thread or how it relates to my installation in terms of fixing. This thread and other referenced threads provide reference to "Apache;" "Linux;" and other languages (I guess they're languages or specific servers.)

Have you considered looking these things up? You should note that a basic understanding of your server infrastructure is vital to most aspects of maintenance, so I'd suggest to read up a bit on it. Also note that you might get more info on your server environment in the FreeNAS community or on FreeNAS informational pages.
Even though people try to support most platforms here, you can't expect us to know everything about your environmnent by simply stating a machine name; your server's environment (That is which webserver software is used (apache, lighttpd, nginx...), which database (mysql, sqlite, ...) ...), operating system (linux, windows,...) is something you have to find out yourself - and should be familiar with if you want to securely run a publicly available server!

I would further recommend to start a new thread; your problems seem to be more basic than explicit problems with what this FAQ describes.

Please tell me where to start to look or figure out this problem in my installation.

I am having the problem ["Your web server is not yet properly setup to allow files synchronization because the WebDAV interface seems to be broken. Please double check the installation guides."] as described in this thread.

It's hard to give any specific advice without more information. You need to check your logs for related messages (as already stated in the initial post).

roymullinsjr0416
Newbie
Posts: 3
Joined: Thu Aug 21, 2014 3:30 am
ownCloud version: 7.0.1
Webserver: IIS
Database: MySQL
OS: Windows Desktop
PHP version: 5.3.29

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby roymullinsjr0416 » Fri Aug 22, 2014 4:05 am

This is what it says under the admin tab of owncloud. I have checked and double checked, if I call WebDAV from the browser I can login and do what I want but nothing else will work.

Warning core isWebDAVWorking: NO - Reason: Method not allowed (Sabre\DAV\Exception\MethodNotAllowed) 2014-08-22T02:00:01+00:00
Warning core isWebDAVWorking: NO - Reason: Method not allowed (Sabre\DAV\Exception\MethodNotAllowed) 2014-08-22T02:00:01+00:00
Warning core isWebDAVWorking: NO - Reason: Resource not found. (Sabre\DAV\Exception\NotFound) 2014-08-22T01:54:54+00:00
Warning core isWebDAVWorking: NO - Reason: Resource not found. (Sabre\DAV\Exception\NotFound

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby RandolphCarter » Fri Sep 12, 2014 10:54 pm

Please don't post specific questions to a FAQ thread. As the "NO - Reason: Method not allowed" suggests, you need to allow the method in your server configuration. As for how to do that, see first post! If you have further issues, open a new one!

tmont
Newbie
Posts: 1
Joined: Fri Nov 14, 2014 11:37 am
ownCloud version: 7.0.4
Webserver: nginx
Database: MySQL
PHP version: 5.5.21

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby tmont » Fri Nov 14, 2014 11:52 am

It may be interesting to add to this FAQ that people using a reverse proxy in front of Owncloud should ensure that their proxy is configured to pass WebDAV queries.

See this forum thread for the case of the Pound reverse proxy: viewtopic.php?t=4949


  • Similar Topics
    Replies
    Views
    Last post

Return to “FAQ”

Who is online

Users browsing this forum: No registered users and 1 guest