How to fix CalDAV|CardDAV|WebDAV problems

Here we try to answer typical questions
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby RandolphCarter » Sun Nov 16, 2014 10:49 am

@tmount thanks for the info, added it to first post.

gamik
Newbie
Posts: 1
Joined: Sat Oct 31, 2015 2:41 pm
ownCloud version: 8.1.3
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.6.14

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby gamik » Sat Oct 31, 2015 2:57 pm

Randolph, I have a similar scenario (Web access ok, OC Client issues http 403), but it is a client incompatibility:

Server and Client OS: Debian 8 (jessie)
OC Server Version: 8.1.3 (from OC Website, not the Debian repository)
OC Client Version: 1.7.0 (from Debian stable proposed-updates)
Other WebDav Clients can connect to the Server (only OC Client gives the 403 error)

I searched the web for similar issues, to no avail. Only an OC Debug session as described here revealed the incompatibility:
...{\"Message\":\"HTTP\\\/1.1 403 Unsupported client version.\"...


The solution in Debian is to install the OC client v2.0.0 from jessie-backports.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby RealRancor » Sat Oct 31, 2015 3:55 pm

Hi,

yes that is known and documented at various places like release notes etc. The debian version is also 1.6.4 which is outdated and unsupported by the oC devs.
*gone*

marcelop
Newbie
Posts: 1
Joined: Thu Dec 24, 2015 6:01 am
ownCloud version: 8.2.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby marcelop » Thu Dec 24, 2015 7:06 am

Hello! Very insightful post, but it wasn't of help to solve my 401 error against the login attempts from the desktop app.
After a lot of trial and error I found that no directives were needed to be added to httpd.conf. Instead, I just had to switch PHP from cgi mode to suphp and automagically the desktop app was able to connect.
No Apache dav modules required. No httpd.conf edition needed.

For the record, I'm running on CentOS 6.7 64b, PHP 5.5.30 with suExec, Apache 2.4.18.

Hope this help others. You can add this small detail about php execution mode to the first post. I bet this is why others have had connection problems on different hosting companies.

Thanks!

alex3137
Newbie
Posts: 2
Joined: Mon Apr 11, 2016 1:47 pm
ownCloud version: 9.0.1
Webserver: Apache
Database: SQLite
OS: Linux
PHP version: 5.6

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby alex3137 » Mon Apr 11, 2016 1:52 pm

Hello

I am unable to get working CardDAV / CalDAV using Mac OS X native clients (it works fine on my iPhone though). I created an issue https://github.com/owncloud/core/issues/23908

and apparently the problem is with my webserver (Apache) configuration.

Can anybody explain what configuration we are supposed to do with Apache to get it working ?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: How to fix CalDAV|CardDAV|WebDAV problems

Postby RealRancor » Mon Apr 11, 2016 2:01 pm

Please work your way through this FAQ as already asked at the github thread. There is not a single "do this to fix your issue" solution available so its not possible to explain what you need to do.

If you can't get it to work by following this FAQ hints please create a new thread filling out the info in the template.
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “FAQ”

Who is online

Users browsing this forum: No registered users and 1 guest