Nach Update nur noch weiße Seite

Ein Forum zur Unterhaltung in deutsch.
Forum rules
Wichtig: Dieses Forum ist jetzt auf https://central.owncloud.org zuhause, welches auf der Foren-Software Discourse basiert. Dieses Forum wird in den Lesemodus versetzt. Mehr Details und Hintergründe zum Umzug gibt es unter unter.

https://daniel.molkentin.net/2016/07/20 ... d-central/

---

Hallo, dieses Forum hat einen sehr kleinen Benutzerkreis, verglichen mit dem englischen Forum.
Bitte schreibt wenn möglich in den englischsprachigen Foren. Dann haben alle was davon. Die Schreiber dort kommen aus vielen Ländern und sind sehr tolerant was die Sprache angeht. Keiner wird wegen nicht perfektem Englisch ignoriert.

WICHTIG: Keine Doppelpostings, sprich das Anliegen NICHT in deutsch UND englisch posten.
patman1607
Beginner
Posts: 11
Joined: Fri Jun 07, 2013 6:33 pm
ownCloud version: 5.0.7
Webserver: Apache
Database: MySQL
OS: Linux

Nach Update nur noch weiße Seite

Postby patman1607 » Tue Jul 16, 2013 2:58 pm

Hallo,

nach dem Update welches ich jetzt via webinterface von 5.06 auf 5.09 durchgeführt habe habe ich nur noch eine weiße Seite

kann jmd helfen was zu tun ist?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Nach Update nur noch weiße Seite

Postby RealRancor » Tue Jul 16, 2013 3:02 pm

Hi,

wirf mal einen Blick auf diese öfters gestellte Frage:

viewtopic.php?f=17&t=8315

und schau wie darin beschrieben in Deine Logdateien ob Du dort Hinweise findest was hier schief läuft. Ohne weitere Infos kann man Dir hier leider kaum weiter helfen.
*gone*

patman1607
Beginner
Posts: 11
Joined: Fri Jun 07, 2013 6:33 pm
ownCloud version: 5.0.7
Webserver: Apache
Database: MySQL
OS: Linux

Re: Nach Update nur noch weiße Seite

Postby patman1607 » Wed Jul 17, 2013 7:38 am

hallo,

also in dem steht
php-errors.log
[17-Jul-2013 06:15:53 UTC] PHP Fatal error: xcache_clear_cache(): xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /var/www/owncloud/lib/util.php on line 853
[17-Jul-2013 06:15:58 UTC] PHP Fatal error: xcache_clear_cache(): xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /var/www/owncloud/lib/util.php on line 853


und im apache error.log
[Wed Jul 17 07:54:06 2013] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error: xcache_clear_cache(): xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /var/www/owncloud/lib/util.php on line 853
[Wed Jul 17 07:54:09 2013] [error] [client xxx.xxx.xxx.xxx] File does not exist: /var/www/favicon.ico, referer: https://test.domain.com/owncloud/
[Wed Jul 17 07:55:03 2013] [error] [client 127.0.0.1] File does not exist: /etc/apache2/htdocs
[Wed Jul 17 08:00:03 2013] [error] [client 127.0.0.1] File does not exist: /etc/apache2/htdocs
[Wed Jul 17 08:04:37 2013] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error: xcache_clear_cache(): xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /var/www/owncloud/lib/util.php on line 853
[Wed Jul 17 08:05:02 2013] [error] [client 127.0.0.1] File does not exist: /etc/apache2/htdocs
[Wed Jul 17 08:10:02 2013] [error] [client 127.0.0.1] File does not exist: /etc/apache2/htdocs
[Wed Jul 17 08:12:44 2013] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error: xcache_clear_cache(): xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /var/www/owncloud/lib/util.php on line 853
[Wed Jul 17 08:15:02 2013] [error] [client 127.0.0.1] File does not exist: /etc/apache2/htdocs


evtl. kann mir jemand sagen was zu tun ist

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Nach Update nur noch weiße Seite

Postby RealRancor » Wed Jul 17, 2013 8:26 am

Hi,

jupp das ist einfach in Deiner PHP Konfiguration zu fixen da die "Fatal" Meldung ja eigentlich schon sagt was Du zu tun hast. Du musst nur einen Admin für das PHP Addon XCache konfigurieren:

http://xcache.lighttpd.net/wiki/Install ... thpassword

Siehe auch hier:

https://github.com/owncloud/core/issues/3417
*gone*

patman1607
Beginner
Posts: 11
Joined: Fri Jun 07, 2013 6:33 pm
ownCloud version: 5.0.7
Webserver: Apache
Database: MySQL
OS: Linux

Re: Nach Update nur noch weiße Seite

Postby patman1607 » Wed Jul 17, 2013 12:48 pm

THX,
nur leider hab ich null Ahnung was ich da genau machen soll.
Habs mir durchgelesen und leider nix gecheckt.
Was wo und wie muss ich (am besten step by step) machen?
wie stelle ich ein PW u Username ein?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Nach Update nur noch weiße Seite

Postby RealRancor » Wed Jul 17, 2013 5:07 pm

Hi,

hört sich jetzt vielleicht blöd an und ich hoffe das kommt nicht falsch rüber:

Vielleicht macht das jemand anderes aber ich werde definitiv keine Schritt für Schritt-Anleitung für eine existierende Schritt für Schritt-Anleitung schreiben noch Übersetzer spielen.

Du musst einfach nur befolgen was unter "1.2 Generating your auth password" beschrieben steht und schon sollte das funktionieren. Notfalls gibt es auch sicher noch einmal ein ausführlicheres Tutorial irgendwo im Internet welche die Schritte noch mal genauer beschreiben.
*gone*

patman1607
Beginner
Posts: 11
Joined: Fri Jun 07, 2013 6:33 pm
ownCloud version: 5.0.7
Webserver: Apache
Database: MySQL
OS: Linux

Re: Nach Update nur noch weiße Seite

Postby patman1607 » Wed Jul 17, 2013 6:49 pm

hmnja, ich denke ich hab es jetzt hin bekommen.
als erstes habe ich xcache ins www verzeichniss gelinkt.

cd /var/www
ln -s /usr/share/xcache/admin xcache


restart apache

die Webseite aufgerufen und ein falsches passwort eingegeben
im anschluss kam generate ein md5 PW. > pw eingegeben und ein md5 hash erstellen lassen diesen kopiert und in die xcache.php unter /usr/share/xcache/admin eingetragen.

; configuration for php Xcache module

[xcache-common]
;; install as zend extension (recommended), normally "$extension_dir/xcache.so"
zend_extension = /usr/lib/php5/20090626+lfs/xcache.so

[xcache.admin]
xcache.admin.enable_auth = On
; Configure this to use admin pages
xcache.admin.user = "mOo" das semikolion entfernen
xcache.admin.pass = hier md5 eintragen und das semikolion entfernen
; xcache.admin.pass = ""

[xcache]
; ini only settings, all the values here is default unless explained

; select low level shm/allocator scheme implemenation
xcache.shm_scheme = "mmap"
; to disable: xcache.size=0
; to enable : xcache.size=64M etc (any size > 0) and your system mmap allows
xcache.size = 128M
; set to cpu count (cat /proc/cpuinfo |grep -c processor)
xcache.count = 1


restart apache2

wieder auf die webpage von xcache und eingeloggt. siehe da funktioniert
wier auf owncloud und voilia GEHT :D

OC Lädt um einiges schneller als vorher
DANKE
muss jetzt noch irgendwas in der /var/www/owncloud/config/config.php angebpasst werden?

Wilhelm.T
Beginner
Posts: 14
Joined: Fri Jul 26, 2013 1:14 pm

Re: Nach Update nur noch weiße Seite

Postby Wilhelm.T » Sun Aug 09, 2015 12:04 pm

Wie macht man das, wenn man keine Kommandozeilenbefehle eingeben kann?
Habe doch nur FTP-Zugang.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Nach Update nur noch weiße Seite

Postby RealRancor » Sun Aug 09, 2015 1:10 pm

Hi,

ich glaube es wäre sinnvoll wenn Du einen neuen Thread erstellen würdest anstatt einen zwei Jahre alten Thread zu pushen der ggf. gar nichts mit Deinem Problem zu tun hat. Eine weiße Seite bedeutet nämlich nur, dass es ein Problem gibt, die Ursachen davon sind meistens sehr unterschiedlich.

Stelle in Deinem neuen Thread bitte weitere Infos wie z.B. oC, webserver und php version sowie ggf. Fehler aus Deiner data/owncloud.log
*gone*

stone1978
Newbie
Posts: 5
Joined: Sat May 25, 2013 5:40 pm
ownCloud version: 5.0.6
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.0.3

Re: Nach Update nur noch weiße Seite

Postby stone1978 » Tue Aug 11, 2015 11:36 pm

Hallo

Habe das gleiche Problem nach dem Update von 8.0.5 auf 8.1.1

Beim Starten der Page = http://stone-server.dyndns.org:8081/stonescloud/

Kommt eine weiße Seite

Habe versucht das alte Backup einzuspielen hat aber keinen Erfolg gebracht.

LOG File im Anhang

Ich hoffe auf HILFE bin schon ein wenig ratlos

lg
Attachments
owncloud.zip
(18.5 KiB) Downloaded 24 times


  • Similar Topics
    Replies
    Views
    Last post

Return to “Deutsch”

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests