Update auf 8.1.1 schlägt fehl

Ein Forum zur Unterhaltung in deutsch.
Forum rules
Wichtig: Dieses Forum ist jetzt auf https://central.owncloud.org zuhause, welches auf der Foren-Software Discourse basiert. Dieses Forum wird in den Lesemodus versetzt. Mehr Details und Hintergründe zum Umzug gibt es unter unter.

https://daniel.molkentin.net/2016/07/20 ... d-central/

---

Hallo, dieses Forum hat einen sehr kleinen Benutzerkreis, verglichen mit dem englischen Forum.
Bitte schreibt wenn möglich in den englischsprachigen Foren. Dann haben alle was davon. Die Schreiber dort kommen aus vielen Ländern und sind sehr tolerant was die Sprache angeht. Keiner wird wegen nicht perfektem Englisch ignoriert.

WICHTIG: Keine Doppelpostings, sprich das Anliegen NICHT in deutsch UND englisch posten.
cloudless
Newbie
Posts: 7
Joined: Tue Aug 18, 2015 3:53 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
PHP version: 5.5.x

Re: Update auf 8.1.1 schlägt fehl

Postby cloudless » Tue Aug 18, 2015 4:18 pm

RealRancor wrote:Hier wurden mal ein paar Schritte geposted die dies ggf. lösen könnten:

https://github.com/owncloud/core/issues ... -124259332


Wow das war eine schnelle Antwort, vielen Dank! Auf dem Shared Server habe ich vermutlich keine Möglichkeit die Konsole zu benutzen oder liege ich da falsch? Also wird im Vorschlag die Version des Updaters auf 6.1 geändert und die Updater App aktiviert? Habe mit den Befehlen leider noch keine Erfahrungen.

Notfalls muss ich eben alles umziehen und in eine neue owncloud installation überführen :|

Habe in der htaccess noch etwas zu SSL geändert und mal php 5.4 via cgi, nun kommt auch eine bekannte Fehlermeldung statt des Update Loop:

Code: Select all

Warning: flock() expects parameter 1 to be resource, boolean given in /[DIR]/lib/private/config.php on line 201
Hätte ich bloß das Update nicht gemacht, nun schon locker 10 Stunden dran gesessen...
Last edited by cloudless on Tue Aug 18, 2015 4:45 pm, edited 1 time in total.

sam_hh
Beginner
Posts: 20
Joined: Wed Dec 25, 2013 1:51 pm
ownCloud version: 8.0.2
Webserver: Apache
Database: MySQL
OS: Linux Hosting Package
PHP version: 5.6

Re: Update auf 8.1.1 schlägt fehl

Postby sam_hh » Tue Aug 18, 2015 4:37 pm

Hallo, auch bei mir das gleiche Problem, seit Stunden hing die Installation im Wartungsmodus ... Ich habe jetzt die App-Ordner allesamt per ftp gelöscht und seit neuestem eine weiße Seite.

Ich hoffe, da lässt sich noch etwas machen?! Denn gefühlt scheint bei jedem zweiten Update etwas schief zu gehen. Oder bin ich mit diesem Eindruck alleine?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Update auf 8.1.1 schlägt fehl

Postby RealRancor » Tue Aug 18, 2015 4:51 pm

@cloudless Du kannst die Änderungen in den Dateien auch manuell per FTP etc. machen.

@sam_hh So lange Du keine Update-Schleife hast (Maintenance Mode ist etwas anderes) erstelle einen neuen Thread
*gone*

sam_hh
Beginner
Posts: 20
Joined: Wed Dec 25, 2013 1:51 pm
ownCloud version: 8.0.2
Webserver: Apache
Database: MySQL
OS: Linux Hosting Package
PHP version: 5.6

Re: Update auf 8.1.1 schlägt fehl

Postby sam_hh » Tue Aug 18, 2015 4:58 pm

Das scheidet leider aus:

zsh: command not found: sudo

Ich habe nur ein managed hosting Angebot ...

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Update auf 8.1.1 schlägt fehl

Postby RealRancor » Tue Aug 18, 2015 5:00 pm

Bekommst Du die Update-Schleife oder hängt Deine Installation nur im Maintenance Mode?
*gone*

cloudless
Newbie
Posts: 7
Joined: Tue Aug 18, 2015 3:53 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
PHP version: 5.5.x

Re: Update auf 8.1.1 schlägt fehl

Postby cloudless » Tue Aug 18, 2015 5:04 pm

RealRancor wrote:@cloudless Du kannst die Änderungen in den Dateien auch manuell per FTP etc. machen.


Ok, interpretiere ich die Codes richtig, dass die Versionen entsprechend geändert werden? Bei mir sind die Versionen wie in dem Code 0.4 bzw. 0.6.1. Allerdings weiß ich nicht wie ich die Apps via FTP aktivieren kann. In MySQL werden sie unter appconfig nicht angezeigt, soll ich sie manuell einfügen? Benötige ich ein Script? Google hilft auf die schnelle nicht weiter...

EDIT: Ich habe gerade aus Verzweiflung das Update nochmals per Internet Explorer statt FF40 probiert und dort bleibt das Update nach folgendem stehen:

Code: Select all

ownCloud wird auf Version 8.1.1 aktualisiert. Das könnte eine Weile dauern.

Wartungsmodus eingeschaltet
Datenbankschema-Aktualisierung überprüft
Datenbankschema-Aktualisierung für Apps überprüft
Datenbank aktualisiert
Last edited by cloudless on Tue Aug 18, 2015 5:37 pm, edited 1 time in total.

sam_hh
Beginner
Posts: 20
Joined: Wed Dec 25, 2013 1:51 pm
ownCloud version: 8.0.2
Webserver: Apache
Database: MySQL
OS: Linux Hosting Package
PHP version: 5.6

Re: Update auf 8.1.1 schlägt fehl

Postby sam_hh » Tue Aug 18, 2015 5:08 pm

RealRancor wrote:Bekommst Du die Update-Schleife oder hängt Deine Installation nur im Maintenance Mode?


Ich hatte dem blauen Bildschirm mit dem Hinweis Wartungsmodus, die Website aktualisiert sich automatisch. Leider keinen Screenshot gemacht.

Nach dem Löschen der Apps habe ich nur noch einen weißen Bildschirm.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Update auf 8.1.1 schlägt fehl

Postby RealRancor » Tue Aug 18, 2015 5:26 pm

Dann erstell bitte einen neuen Thread und wirf vorher einen Blick in Deine Logdateien (siehe FAQ forum).
*gone*

cloudless
Newbie
Posts: 7
Joined: Tue Aug 18, 2015 3:53 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
PHP version: 5.5.x

Re: Update auf 8.1.1 schlägt fehl

Postby cloudless » Tue Aug 18, 2015 7:33 pm

PROBLEM GELÖST!!! Habe vieles ausprobiert und am Ende war es eine dieser beiden Lösungen:

1. einen Statistik Ordner mit anderen chown Rechten gelöscht

2. Einfach direkt alle apps im Ordner apps gelöscht und die aus der 8.1.1 zip hochgeladen. (vermutlich die Lösung)

Problem erstmal gelöst. Es gibt nun folgende Meldung in der Administration:
- Dieser Server hat keine funktionierende Internetverbindung. Dies bedeutet, dass einige Funktionen wie das Einhängen externen Speicherplatzes, Update-Benachrichtigungen oder die Installation von Drittanbieter-Apps nicht funktionieren werden. Der Fernzugriff auf Dateien und der Versand von E-Mail-Benachrichtigungen kann ebenfalls nicht funktionieren. Es wird empfohlen, die Internetverbindung dieses Servers zu aktivieren, wenn Du alle Funktionen nutzen möchtest.

- Es wurde kein PHP Memory Cache konfiguriert. Konfiguriere zur Erhöhung der Leistungsfähigkeit, soweit verfügbar, einen Memory Cache. Weitere Informationen finden Sie in unserer Dokumentation.

- Der „Strict-Transport-Security“-HTTP-Header ist nicht auf mindestens „15768000“ Sekunden eingestellt. Für umfassende Sicherheit wird das Aktivieren von HSTS empfohlen, wie es in unseren Sicherheitshinweisen erläutert ist.


Davon habe ich schon gehört und es lässt sich sicher eine Lösung finden. Wollte es nur hier posten damit evtl Zusammenhänge deutlich werden.

Vielen Dank nochmal an RealRancor!!! :D

EDIT: Ein fast schon lustige Situation ergab sich nun, nachdem ich - aufgrund des Internet-Fehlers - die Apps Calendar, Contacts, Tasks und Documents manuel installieren wollte. Nach dem Upload als Admin zuerst Calendar aktiviert (wird als experimentelle App angezeigt) und danach Contacts (dabei aber Aktivierung fehlgeschalgen). Nun mal auf das owncloud Hauptverzeichnis gegangen um Calendar zu überprüfen und ZACK:
Update installation von 8.1.1 "willkommen zurück zum loop"... echt freaky langsam...
Dann muss ich scheinbar erstmal ohne Kalender, Kontakte und Aufgaben auskomen. Nochmal würde ich nicht Updaten :evil:
Last edited by cloudless on Tue Aug 18, 2015 8:43 pm, edited 2 times in total.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Update auf 8.1.1 schlägt fehl

Postby RealRancor » Tue Aug 18, 2015 8:26 pm

Hi,

für die Warnungen bekommst Du hier die benötigte infos:

https://doc.owncloud.org/server/8.1/adm ... nings.html
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “Deutsch”

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests