UPC Router - external IP Owncloud nicht erreichbar

Ein Forum zur Unterhaltung in deutsch.
Forum rules
Wichtig: Dieses Forum ist jetzt auf https://central.owncloud.org zuhause, welches auf der Foren-Software Discourse basiert. Dieses Forum wird in den Lesemodus versetzt. Mehr Details und Hintergründe zum Umzug gibt es unter unter.

https://daniel.molkentin.net/2016/07/20 ... d-central/

---

Hallo, dieses Forum hat einen sehr kleinen Benutzerkreis, verglichen mit dem englischen Forum.
Bitte schreibt wenn möglich in den englischsprachigen Foren. Dann haben alle was davon. Die Schreiber dort kommen aus vielen Ländern und sind sehr tolerant was die Sprache angeht. Keiner wird wegen nicht perfektem Englisch ignoriert.

WICHTIG: Keine Doppelpostings, sprich das Anliegen NICHT in deutsch UND englisch posten.
delikt
Newbie
Posts: 2
Joined: Wed Dec 02, 2015 9:39 pm
ownCloud version: 8.0.3
Webserver: Apache
Database: PostgreSQL
OS: Linux
PHP version: 5

UPC Router - external IP Owncloud nicht erreichbar

Postby delikt » Wed Dec 02, 2015 10:36 pm

Hallo Leute,

wie soll ich sagen ich bin schon ziemlich grantig wie man in Österreich sagen würde. Ich habe von meinen Internetanbieter UPC, den Router "Ubee EVW3226" - dahinter steht ein kleiner feiner bananapi platinencomputer mit bananian also einen Linux Debian Betriebssystem. Darauf befindet sich meine mittlerweile veraltete Owncloud 8.0.3 (seit dem versuche ich immer wieder mal sporadisch mein Problem in den Griff zu bekommen :!: )

Zum Problem: Ich kann außerhalb meines Heimnetzwerks nicht auf Owncloud zugreifen.

Einige Eckdaten:

Port Forwarding wurde gesetzt: IP: 192.168.0.X Port Range ist In:443-443 / out: 443-443
Ich kann den Router von meinen Handy aus anpingen - 64bytes in 100-140ms (handynetzwerk natürlich)
Der Port Checker von Portforward.com signalisiert. das der Port 443 auf einen anderen Gerät (Bananapi) geöffnet ist (Portcheck wurde von einen anderen Windows Rechner durchgeführt).
Allerdings sagt mir ein Portscan von meinen Server an meinen Router:
__________________________________________________________
root@bananapi ~ # nmap -sT 192.168.0.1

Starting Nmap 6.00 ( http://nmap.org ) at 2015-12-02 21:00 CET
Nmap scan report for 192.168.0.1
Host is up (0.018s latency).
Not shown: 997 closed ports
PORT STATE SERVICE
53/tcp open domain
80/tcp open http
49152/tcp open unknown
MAC Address: 00:0B:00:00:AD:D0 (Fujian Start Computer Equipment Co.)

Nmap done: 1 IP address (1 host up) scanned in 1.94 seconds
____________________________________________________________

http://www.dnstools.ch/ behauptet mein 443 Port is offen

Ich habe auch die Routerfirewall daraufhin umgestellt, dass IPv4 anfragen nicht geblockt werden. (Ob das Notwendig ist bin ich mir aber jetzt nicht sicher - ist ein Test)

Ich habe außerdem versucht mit einer DNS Weiterleitung via Noip.com zustande zu bekommen - das bereitgestellte Ip Aktualisierungstool meint es ist alles ok.

Also mein Verdacht zieht sich jetzt auf die Serverkonfiguration...

Hat jemand einen heißen Tip? Ich weiß echt nicht mehr weiter...vielleicht seh ich den Wald vor lauter bäumen nicht...

Hier noch ein paar config Auszüge aus den Server:


___________________________________________

config.php:

GNU nano 2.2.6 File: config.php

<?php
$CONFIG = array (
'instanceid' => 'XXGehtdienixanXX',
'passwordsalt' => 'XXGehtdienixanXX',
'secret' => 'XXGehtdienixanXXXXGehtdienixanXXXXGehtdienixanXX',
'trusted_domains' =>
array (
0 => '192.168.0.4',
1 => '178.115.128.70',
),
'datadirectory' => '/media/usb0/owndata',
'overwrite.cli.url' => 'http://192.168.0.4:443',
'dbtype' => 'mysql',
'version' => '8.0.3.4',
'dbname' => 'owncloud',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'dbuser' => 'oc_root',
'dbpassword' => 'XXGehtdienixanXXXXGehtdienixanXX',
'installed' => true,
'forcessl' => true,
'theme' => '',
'maintenance' => false,
);

________________________________________________

Apache2 ports.conf:


# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
# If you add NameVirtualHost *:443 here, you will also have to change
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl
# to <VirtualHost *:443>
# Server Name Indication for SSL named virtual hosts is currently not
# supported by MSIE on Windows XP.
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>

_______________________________________________________

# /etc/apache2/sites-enabled/000-default

<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/owncloud
<Directory />
Options FollowSymLinks
AllowOverride ALL
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

_______________________________________________________
php5.ini:

http://pastebin.com/UHgEgTGg

_______________________________________________________

Ich habe bei der installation sicher noch andere files bearbeitet die mir aber jetzt entfallen sind - es sind doch schon 8 Monate :(


Hoffe hier kann mir jemand helfen

Danke!

mitpro
Beginner
Posts: 33
Joined: Fri Jun 19, 2015 11:27 am
ownCloud version: 8.2.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.9

Re: UPC Router - external IP Owncloud nicht erreichbar

Postby mitpro » Thu Dec 03, 2015 2:04 pm

Moin moin,
die Konfigurationen sehen etwas unvollständig aus.
Benutzt zu SSL - auch Intern oder nur über Port 80 mit HTTP im Heimnetz?
Die ports.conf sieht bei mir ähnlich aus.. sollte eigentlich passen.
Allerdings habe ich noch einen virtuellen Host definiert (000-default)

Code: Select all

<VirtualHost *:44444>
        ServerAdmin XXXXXXX
        ServerName XXXXXXX (DynDNS-Adresse)
        Header always set Strict-Transport-Security "max-age=31536000; includeS$
        DocumentRoot /var/www
        SSLEngine on
        SSLCertificateFile      /etc/apache2/ZZZZZZZ
        SSLCertificateKeyFile /etc/apache2/ZZZZZZZZ
</VirtualHost>


Möglicherweise ist die Konfiguration auch in einer anderen Datei enthalten.. siehe ordner sites-enabled.

Für SSL brauchst du immer Zertifikate, für die Domain, über welche sie aufgerufen wird. Also einmal Intern und Extern mit dyndns. Ist das vorhanden?
Ansonsten mal gucken nach selbstsignierten Zertifikaten, CA etc.

Ein weiterer Untschied zu meiner Konfiguration ist, dass ich die Directory nicht im VirtualHost definiere sondern in der apache.conf

Code: Select all

<Directory /var/www/owncloud/>
   Options Indexes FollowSymLinks MultiViews
   AllowOverride All
   Order allow,deny
   allow from all
</Directory>


In vielen Beschreibungen wird das so realisiert - somit ist die Directory nicht nur in einem Host definiert.

Was mir noch aufgefallen ist, das in der owncloud config deine öffentliche IP-Adresse angegeben ist - diese ändert sich aber wenn du einen "normalen" DSLer hast. Somit wird die IP als nicht trusted angesehen.
Wenn deine IP statisch ist, geht das natürlich auch so..

Vielleicht einfach mal ausprobieren und gucken, ob das verbesserung bringt.
Viele Tutorials lesen und ansehen... Nachvollziehen und gucken wo die unterschiede sind.

Viel Erfolg

delikt
Newbie
Posts: 2
Joined: Wed Dec 02, 2015 9:39 pm
ownCloud version: 8.0.3
Webserver: Apache
Database: PostgreSQL
OS: Linux
PHP version: 5

Re: UPC Router - external IP Owncloud nicht erreichbar

Postby delikt » Thu Dec 03, 2015 8:10 pm

Hi,

mitpro wrote:Moin moin,
die Konfigurationen sehen etwas unvollständig aus.
Benutzt zu SSL - auch Intern oder nur über Port 80 mit HTTP im Heimnetz?
Die ports.conf sieht bei mir ähnlich aus.. sollte eigentlich passen.
Allerdings habe ich noch einen virtuellen Host definiert (000-default)

Code: Select all

<VirtualHost *:44444>
        ServerAdmin XXXXXXX
        ServerName XXXXXXX (DynDNS-Adresse)
        Header always set Strict-Transport-Security "max-age=31536000; includeS$
        DocumentRoot /var/www
        SSLEngine on
        SSLCertificateFile      /etc/apache2/ZZZZZZZ
        SSLCertificateKeyFile /etc/apache2/ZZZZZZZZ
</VirtualHost>



Also ich benutz SSL auch intern und habe sogar eine automatische "weiterleitung" eingerichtet die SSL erzwingt selbst wenn der Server per http angesteuert wird.

Intern sagt er mir ganz wie erwartet, dass ich die zertifikate runterladen muss und diese nicht sicher sind usw. es funktioniert im Heimnetz bestens.

Also du hast einen VirtuellenHost in die 000-default datei geschrieben und ich nehme an du steuerst deinen Server über den Port 44444 an?

Im Ordner sites-enabled habe ich eine SSL Datei "ssl@"

Code: Select all



tc/apache2/sites-enabled # ls
000-default@  ssl@

  GNU nano 2.2.6                 File: ssl

<VirtualHost *:443>
        ServerAdmin webmaster@localhost


      SSLEngine On
      SSLCertificateFile /etc/apache2/ssl/apache.pem



        DocumentRoot /var/www/owncloud
        <Directory />
                Options FollowSymLinks
                AllowOverride ALL
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>



Den folgenden Eintrag habe ich bei mir nicht gefunden, also auch nicht in der ssl datei wie von owncloud verwiesen?:

Code: Select all

<VirtualHost *:44444>
        ServerAdmin XXXXXXX
        ServerName XXXXXXX (DynDNS-Adresse)
        Header always set Strict-Transport-Security "max-age=31536000; includeS$
        DocumentRoot /var/www
        SSLEngine on
        SSLCertificateFile      /etc/apache2/ZZZZZZZ
        SSLCertificateKeyFile /etc/apache2/ZZZZZZZZ
</VirtualHost>


Ich benötige externe Zertifikate? kannst du das etwas erläutern? Ich wüsste nämlich nicht das ih solche erstellt hätte...?




Für SSL brauchst du immer Zertifikate, für die Domain, über welche sie aufgerufen wird. Also einmal Intern und Extern mit dyndns. Ist das vorhanden? ....... Was mir noch aufgefallen ist, das in der owncloud config deine öffentliche IP-Adresse angegeben ist - diese ändert sich aber wenn du einen "normalen" DSLer hast. Somit wird die IP als nicht trusted angesehen.
Wenn deine IP statisch ist, geht das natürlich auch so..


Wenn du mit dyndns einen service wie noIP meinst dann ja, ich habe auch im Ursprungspost geschrieben das die verbindung mit den ipaktualisierungstool von noip keine Proleme sieht den server zu erreichen. Ich brauche aber noip eigentlich nicht - ich habe zwar eine dynamische ip adresse, diese ändert sich aber ausschließlich erst wenn ich den router resete und mich im netz neu anmelde... (obwohl das auch ein Gerücht ist weil ich owncloud vor fast einen Jahr installiert habe und die eingegebene ip adresse in den konfigurationsdateien ist heute noch immer die selbe trotz mehrmaligen reseten und neu anmelden)


Code: Select all

Ansonsten mal gucken nach selbstsignierten Zertifikaten, CA etc.


Habe ich, zumindest benötige ich diese im Heimnetzwerk um verschlüsselt zu connecten.



Ein weiterer Untschied zu meiner Konfiguration ist, dass ich die Directory nicht im VirtualHost definiere sondern in der apache.conf

Code: Select all

<Directory /var/www/owncloud/>
   Options Indexes FollowSymLinks MultiViews
   AllowOverride All
   Order allow,deny
   allow from all
</Directory>


In vielen Beschreibungen wird das so realisiert - somit ist die Directory nicht nur in einem Host definiert.


Ich weiß jetzt nicht ob es so und so funktiort... aber wenn meine konfiguration im Heimnetzwerk funktioniert... warum sollte diese meine externe verbindung beeinflussen?


Vielleicht einfach mal ausprobieren und gucken, ob das verbesserung bringt.
Viele Tutorials lesen und ansehen... Nachvollziehen und gucken wo die unterschiede sind.

Viel Erfolg


Danke :? :roll:

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: UPC Router - external IP Owncloud nicht erreichbar

Postby tflidd » Fri Dec 04, 2015 12:52 am

Also die selbsterstellten Zertifikate sind schon in Ordnung, man muss halt selbst das Zertifikat prüfen (Prüfsumme). Die Portweiterleitung auf deinem Router müsstest du eigentlich von außerhalb deines Netzwerkes machen. SSllabs.com bietet auch Tests von SSL-Servern an.


  • Similar Topics
    Replies
    Views
    Last post

Return to “Deutsch”

Who is online

Users browsing this forum: No registered users and 5 guests