OwnCloud server extern nicht erreichbar

Ein Forum zur Unterhaltung in deutsch.
Forum rules
Wichtig: Dieses Forum ist jetzt auf https://central.owncloud.org zuhause, welches auf der Foren-Software Discourse basiert. Dieses Forum wird in den Lesemodus versetzt. Mehr Details und Hintergründe zum Umzug gibt es unter unter.

https://daniel.molkentin.net/2016/07/20 ... d-central/

---

Hallo, dieses Forum hat einen sehr kleinen Benutzerkreis, verglichen mit dem englischen Forum.
Bitte schreibt wenn möglich in den englischsprachigen Foren. Dann haben alle was davon. Die Schreiber dort kommen aus vielen Ländern und sind sehr tolerant was die Sprache angeht. Keiner wird wegen nicht perfektem Englisch ignoriert.

WICHTIG: Keine Doppelpostings, sprich das Anliegen NICHT in deutsch UND englisch posten.
keyroi
Newbie
Posts: 2
Joined: Fri Feb 19, 2016 10:21 am
ownCloud version: 8.2.2
Webserver: nginx
Database: MySQL
OS: Linux

OwnCloud server extern nicht erreichbar

Postby keyroi » Fri Feb 19, 2016 10:25 am

Ich habe Zuhause einen OwnCloud Server über einen Raspberry pi 2 laufen.

intern ist dieser erreichbar. Allerdings ist er nach portweiterleitung nicht extern über das Internet erreichbar...

extern eine SSH verbindung herzustellen ist möglich also auf den Raspberry komme ich.. Allerdings komme ich nicht auf die OwnCloud seite...

Ich bin noch ziemlicher Anfänger mit dem ganzen Thema Hilfe währe also nett...

Liebe Grüße
Kevin Müller

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: OwnCloud server extern nicht erreichbar

Postby RealRancor » Fri Feb 19, 2016 11:38 am

Hi,

da dies kein Problem von ownCloud selbst ist (oC ist einfach nur eine Web-Applikation und wird nur von Deinem Webserver bereit gestellt) läuft hier denke ich was bei Deiner Port-Weiterleitung schief.

Ich denke aus User-Sicht ist hier schwierig weiter zu helfen, deswegen könntest Du Dich einfach mal selbst in die Materie einarbeiten und auch Seiten wie z.B.:

http://portforward.com/

anschauen auf denen die Korrekte Port-Weiterleitung beschrieben wird.
*gone*

keyroi
Newbie
Posts: 2
Joined: Fri Feb 19, 2016 10:21 am
ownCloud version: 8.2.2
Webserver: nginx
Database: MySQL
OS: Linux

Re: OwnCloud server extern nicht erreichbar

Postby keyroi » Fri Feb 19, 2016 1:09 pm

Das "Problem" ist das die portweiterleitung ja für die SSH verbindung funktioniert und die online Port Scanner ebenfalls sagen das ich wenn ich mit dem port 8080 verbinde der weiter geleitet wird auf den port 80 der owncloud...

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: OwnCloud server extern nicht erreichbar

Postby RealRancor » Fri Feb 19, 2016 1:12 pm

Wie gesagt, ownCloud ist hierfür nicht zuständig. Ggf. hat auch Dein Provider einfach 80 oder ähnliches geblockt.

Hier kann man leider nur ins blaue raten. Lies Dich also wie schon erwähnt ggf. mal in das Thema NAT, Port-Forwarding und auch in das Thema Webserver in Portscanning ein.
*gone*

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: OwnCloud server extern nicht erreichbar

Postby RealRancor » Fri Feb 19, 2016 1:22 pm

Ahh, gerade noch eingefallen:

Das einzige bei dem ownCloud ggf. eine Weiterleitung zum falschen System machen könnte wäre die trusted_domains setting in Deiner config.php. Hier muss auch die externe IP / der externe Hostname eingetragen sein über den Du die oC Installation erreichst.
*gone*

mitpro
Beginner
Posts: 33
Joined: Fri Jun 19, 2015 11:27 am
ownCloud version: 8.2.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.9

Re: OwnCloud server extern nicht erreichbar

Postby mitpro » Fri Feb 19, 2016 2:20 pm

Wenn die als trusted domain dein dyndns eingetragen ist und der port weitergeleitet ist sollte es klappen.
Überprüfe nochmal deine URL.. Da musst Protokoll und Port (da es nicht der Standard-Port ist) übereinstimmen z.B. http://meindns.de:8080/owncloud
Solltes du keinen dyndns haben wird es frickelig, weil du jedes mal bei einem IP-Wechsel die neue in die owncloud config.php eintragen müsstest - nicht wirklich praktikabel.
Da du mit Port-Weiterleitung arbeitest würde ich dir dazu raten SSL zu benutzen und es gar nichts erst mit reinem HTTP probieren - hierfür ist auch eine dyndns empfehlenswert, da er an die domain (oder ip) gebunden ist.
Eine mögliche Fehlerquelle könnte noch sein, dass in deiner Konfiguration nur HTTPS erlaubt ist - ich meine er versucht einen redirect, der natürlich nur ins leere geht.


  • Similar Topics
    Replies
    Views
    Last post

Return to “Deutsch”

Who is online

Users browsing this forum: No registered users and 2 guests