"don't have permission" on local mounted shares

Ask all your questions regarding OC 7.x Please read the Support Forum Rules
Forum rules
ownCloud 7.x will be end of life soon. See maintenance and release schedule for more details.

Time to upgrade!

Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting
oneseventeen
Newbie
Posts: 5
Joined: Wed Nov 06, 2013 5:22 pm
ownCloud version: 5.0.9
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.4.6

"don't have permission" on local mounted shares

Postby oneseventeen » Tue Aug 12, 2014 7:29 pm

I use the "External Storage" app to add Local storage for each user individually, so for Luke, it looks like this:

  • Folder Name: SyncData-Luke
  • External Storage: Local
  • Configuration: /mnt/luke
  • Available for: Luke Skywalker

/mnt/luke is a cifs mounted volume.

This worked beautifully until I attempted using fstab to manage my cifs mounts. I still use the uid=www-data and gid=www-data, so /mnt/luke has the following permissions:

Code: Select all

drwxr-xr-x 2 www-data www-data    0 Aug  8 08:25 luke


When logged in as root, I can traverse these folders, create files, etc. without issue. Via owncloud, I cannot view or edit the data. I see the following at the top of my screen:
Owncloud Error wrote:You don't have permission to upload or create files here


What confuses me, is I have unmounted, rebooted, then mounted again using the exact same cifs mount command that worked beautifully before. The only differences are:
  1. I mounted the volume after the local storage was created
  2. I have cifs-utils installed, where I previously did not

I have attempted uninstalling cifs-utils, removing the External Storage config from the OwnCloud admin settings, mounting the way I had previously, and re-adding it via the OwnCloud admin settings, and still I receive the same results.

Any thoughts?

One final test:
  1. I unmounted /mnt/luke
  2. I changed the permissions to 777 on /mnt/luke
  3. I refreshed my owncloud page only to see the same permissions error

Perhaps I need to force owncloud to refresh permissions data?

oneseventeen
Newbie
Posts: 5
Joined: Wed Nov 06, 2013 5:22 pm
ownCloud version: 5.0.9
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.4.6

Re: "don't have permission" on local mounted shares

Postby oneseventeen » Tue Aug 12, 2014 8:34 pm

Wow, I'm such a noob!

Permissions were updated after I unmounted the volume in owncloud, so all I needed to do was rescan the filesystem based on the instructions on this page:
http://sharadchhetri.com/2013/11/14/how ... wncloud-5/

The specific solution for me (because I don't have billions of records in my file cache table yet) was:

Code: Select all

php /var/www/owncloud/console.php files:scan --all


All is well!

Also, because all of my shared folders begin with Users or Share, I likely could have just deleted all lines from the oc_filecache table that begin with Users or Share.

Thanks for taking the time to read, I hope my solution helps someone else out!

jeroen94704
Newbie
Posts: 1
Joined: Wed Jan 21, 2015 5:00 pm
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: "don't have permission" on local mounted shares

Postby jeroen94704 » Wed Jan 21, 2015 5:02 pm

oneseventeen wrote:I hope my solution helps someone else out!


It did. Thank you :)

Jeroen


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 7.x”

Who is online

Users browsing this forum: No registered users and 1 guest