Check dependencies / recommendations for current install

Ask all your questions regarding OC 7.x Please read the Support Forum Rules
Forum rules
ownCloud 7.x will be end of life soon. See maintenance and release schedule for more details.

Time to upgrade!

Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting
erm67
Beginner
Posts: 35
Joined: Sat Jun 21, 2014 2:45 pm
ownCloud version: 9.0.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: PHP/5.6.x

Re: Check dependencies / recommendations for current install

Postby erm67 » Fri Sep 05, 2014 12:37 pm

PHP module zlib not installed.
Please ask your server administrator to install the module.

I am also getting this from the cron job, but maybe it is required by the news app

Amplificator
Beginner
Posts: 18
Joined: Thu Feb 27, 2014 8:24 am

Re: Check dependencies / recommendations for current install

Postby Amplificator » Sat Sep 06, 2014 6:46 am

I've been using OpCache for some time now with no problems at all.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Check dependencies / recommendations for current install

Postby RealRancor » Sun Sep 07, 2014 8:08 pm

Hi,

just added the check for the PHP OPcache.
*gone*

Tamsy
Starter
Posts: 55
Joined: Thu May 24, 2012 8:32 am
ownCloud version: 8.1.3
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.6

Re: Check dependencies / recommendations for current install

Postby Tamsy » Mon Sep 08, 2014 4:28 am

Rancor wrote:just added the check for the PHP OPcache.


... which works just great:
opcache.jpg
opcache.jpg (12.73 KiB) Viewed 3454 times


Thank you, Rancor

sloniupl
Newbie
Posts: 1
Joined: Mon Sep 08, 2014 10:51 am
ownCloud version: 7.0.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.4.4

Re: Check dependencies / recommendations for current install

Postby sloniupl » Mon Sep 08, 2014 10:57 am

Very usefull tool, thanks.
i were finally able to determinate why i can't upload files bigger then 2GB.
Thanks again :D

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Check dependencies / recommendations for current install

Postby RandolphCarter » Tue Sep 09, 2014 9:52 am

Absolutely awesome! Thanks Rancor, you're truly the ownCloud master around here 8-) !

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Check dependencies / recommendations for current install

Postby RealRancor » Wed Sep 10, 2014 4:13 pm

Hi,

and thanks.

If some dependency checks are missing (especially for 3rdparty apps) please let me know so i can include it.

*Edit*

Just have added a check for the "clamscan" binary needed by the files_antivirus app.
*gone*

erm67
Beginner
Posts: 35
Joined: Sat Jun 21, 2014 2:45 pm
ownCloud version: 9.0.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: PHP/5.6.x

Re: Check dependencies / recommendations for current install

Postby erm67 » Fri Sep 12, 2014 9:32 pm

Just because I decided that the xmlwriter & xmlreader modules were not need :-)


{"reqId":"5413494920ba1","app":"PHP","message":"Call to undefined function xmlwriter_open_memory() at \/usr\/local\/www\/htdocs\/owncloud\/lib\/private\/ocs.php#137","level":3,"time":"2014-09-12T19:28:09+00:00","method":"GET","url":"\/ocs\/v1.php\/apps\/files_sharing\/api\/v1\/shares?path=%2F&reshares=false&subfiles=true"}

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Check dependencies / recommendations for current install

Postby RealRancor » Fri Sep 12, 2014 10:23 pm

Hi,

the XMLWriter is enabled as a default in PHP:

http://php.net/manual/en/xmlwriter.installation.php

It's not really possible to catch every needed module so please don't disable standard-modules if you're not absolutely sure what you're doing. :)
*gone*

erm67
Beginner
Posts: 35
Joined: Sat Jun 21, 2014 2:45 pm
ownCloud version: 9.0.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: PHP/5.6.x

Re: Check dependencies / recommendations for current install

Postby erm67 » Fri Sep 12, 2014 10:48 pm

Gentoo users: emerge does not compile dev-lang/php with --enable-xmlwriter by default. To enable this option, add the flag xmlwriter to your USE variable and recompile php.
add a note

The same is valid for *BSD ports ...

I was just trying to reduce memory usage to a minimum but ended up enabling most modules ...


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 7.x”

Who is online

Users browsing this forum: No registered users and 2 guests