Cannot write to "apps" directory. Please help!

Ask all your questions regarding OC 7.x Please read the Support Forum Rules
Forum rules
ownCloud 7.x will be end of life soon. See maintenance and release schedule for more details.

Time to upgrade!

Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting
streetbikeford
Newbie
Posts: 3
Joined: Thu Dec 11, 2014 10:36 pm
ownCloud version: 7.0.3
Webserver: IIS
Database: MySQL
OS: Windows Server
PHP version: 5.5.19

Cannot write to "apps" directory. Please help!

Postby streetbikeford » Thu Dec 11, 2014 10:48 pm

I had a working Owncloud solution configured on Ubuntu 14.04 about a month ago, but Ubuntu kept acting up and giving me issues.

Today I wiped my machine and installed Windows Server 2012. I'm running:

PHP - 5.5.19
MySQL - 5.6
IIS 8
Owncloud - 7.03

I have followed many tutorials, rebuilt my set up over and over again multiple ways.

After it's all said and done I get the same error when I log into http://localhost/owncloud

Cannot write into "apps" directory.

This can usually be fixed by giving the webserver write access to the apps directory or disabling the appstore in the config file.


I received the same error with the "config" file. All I had to do was give my user full control over the folder and the error stopped, to be replaced by this one. I've given access to this folder to everyone, myself, Administrator...everything account I can think of but nothing works.

Would appreciate any help I can get.

Thanks,

Zach

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Cannot write to "apps" directory. Please help!

Postby RandolphCarter » Fri Dec 12, 2014 12:33 am

You need to give write access to the user running php scripts on your system. On IIS that is usually IUSR or something like that I believe.

streetbikeford
Newbie
Posts: 3
Joined: Thu Dec 11, 2014 10:36 pm
ownCloud version: 7.0.3
Webserver: IIS
Database: MySQL
OS: Windows Server
PHP version: 5.5.19

Re: Cannot write to "apps" directory. Please help!

Postby streetbikeford » Fri Dec 12, 2014 7:19 pm

RandolphCarter wrote:You need to give write access to the user running php scripts on your system. On IIS that is usually IUSR or something like that I believe.


I've done that. I've given full control to Everyone, IUSR, Administrator, etc. I've given Full control over the actual "apps" folder and over the config folder. No dice.

shaun866
Newbie
Posts: 1
Joined: Wed Feb 25, 2015 2:06 pm
Webserver: Apache
Database: SQLite
OS: Linux

Re: Cannot write to "apps" directory. Please help!

Postby shaun866 » Wed Feb 25, 2015 2:12 pm

This worked for me (below). I installed a copy of Ubuntu 14.04, installed owncloud with the image downloaded directly from the internet, followed a very basic and straight forward installation process and then gave the apps folder master permissons of 777 (i know not secure but it got it going), you can work back from 777 to work out the level of rights you want for security.

I got this error as soon as i finished the installation and went to http://ipaddressofserver/owncloud

Cannot write into "apps" directory
This can usually be fixed by giving the webserver write access to the apps directory or disabling the appstore in the config file.

If you follow this you can't go wrong:

root@owncloud#cd /var/www/owncloud
root@owncloud#chmod 777 apps

Then try access owncloud again and you should be on your way.

buki.
Newbie
Posts: 1
Joined: Sat May 16, 2015 8:50 pm
ownCloud version: 8.0.2
Webserver: IIS
Database: MSSQL
OS: Windows Server
PHP version: 5.6

Re: Cannot write to "apps" directory. Please help!

Postby buki. » Sat May 16, 2015 9:03 pm

Hi forum

In my case, I have used the sample config php for my first installation.
changed apps_paths, replaced /var/www/owncloud/apps with ./apps did the trick.

Good luck.
buki.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Cannot write to "apps" directory. Please help!

Postby RealRancor » Sat May 16, 2015 9:31 pm

Hi,

using the config.sample.php is not supported and is breaking your installation like seen here:

* DO NOT COMPLETELY BASE YOUR CONFIGURATION FILE ON THIS SAMPLE. THIS MAY BREAK
* YOUR INSTANCE. Instead, manually copy configuration switches that you
* consider important for your instance to your working ``config.php``, and
* apply configuration options that are pertinent for your instance.


from https://github.com/owncloud/core/blob/v ... sample.php

If you're using the supported way and don't use the config.sample.php you won't see this issue and also don't need to edit stuff manually like this.
*gone*

eamestoy
Newbie
Posts: 1
Joined: Wed Jul 20, 2016 4:01 pm
ownCloud version: 8.2.5
Webserver: Apache
Database: PostgreSQL
OS: Linux
PHP version: 5.4

Re: Cannot write to "apps" directory. Please help!

Postby eamestoy » Wed Jul 20, 2016 4:04 pm

shaun866 wrote:This worked for me (below).

root@owncloud#cd /var/www/owncloud
root@owncloud#chmod 777 apps

Then try access owncloud again and you should be on your way.


I believe that is more convenient not chmod 777. Make propietary of php scripts all the permission to the directory. Something like this:

# chown www-data:www-data /var/www/owncloud/apps -R


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 7.x”

Who is online

Users browsing this forum: No registered users and 3 guests