Contacts won't load / show after Update to 7.0.4

Ask all your questions regarding OC 7.x Please read the Support Forum Rules
Forum rules
ownCloud 7.x will be end of life soon. See maintenance and release schedule for more details.

Time to upgrade!

Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting
schuert
Newbie
Posts: 3
Joined: Thu Mar 05, 2015 4:57 pm
ownCloud version: 7.0.4

Contacts won't load / show after Update to 7.0.4

Postby schuert » Thu Mar 05, 2015 5:12 pm

Hi Guys!

I updated my owncloud (hosted via webhoster) from 7.0.3 to 7.0.4 with the Update-Center yesterday. unfortunately the contacts of my default user won't load anymore. i don't get an error, they just never show up, only the loading circle is visible. the admin user, that didn't have any contacts before the update, works well.

another problem is, that the logout-button doesn't work anymore.

what should is do? install again or are there any possibilities to check the database (mysql). i would prefer to not lose all my contacts :cry: as i use owncloud mainly as caldav and carddav server.

thanks in advance

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Contacts won't load / show after Update to 7.0.4

Postby tflidd » Thu Mar 05, 2015 5:28 pm

Can you switch in your config/config.php the loglevel to 0:

Code: Select all

'loglevel' => '0',


What do you mean with logout-button doesn't work? The Logout option still shows in the menu but nothing happens when you click it?

schuert
Newbie
Posts: 3
Joined: Thu Mar 05, 2015 4:57 pm
ownCloud version: 7.0.4

Re: Contacts won't load / show after Update to 7.0.4

Postby schuert » Thu Mar 05, 2015 7:08 pm

When i click the logout button the browser starts loading, but i will never see the login page again. i have to close the browser / tab and open a new one to be able to login again.

i added the option "loglevel => '0'". i also disabled my roundcubemail app, because it flooded my log with errors.

2 mins later i could see the following log entry:

Code: Select all

Error  PHP  Allowed memory size of 33554432 bytes exhausted (tried to allocate 80 bytes) at /home/netsh100733/html/owncloud/3rdparty/sabre/vobject/lib/Sabre/VObject/Component.php#62  2015-03-05T16:57:09+00:00


the attached jpg shows what i see upon clicking on contacts
Attachments
contacts.jpg
contacts.jpg (43.84 KiB) Viewed 843 times
Last edited by schuert on Thu Mar 05, 2015 7:25 pm, edited 2 times in total.

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Contacts won't load / show after Update to 7.0.4

Postby tflidd » Thu Mar 05, 2015 7:20 pm

Can you increase the memory for php?
During these 2 min, you were on the contacts page?

schuert
Newbie
Posts: 3
Joined: Thu Mar 05, 2015 4:57 pm
ownCloud version: 7.0.4

Re: Contacts won't load / show after Update to 7.0.4

Postby schuert » Thu Mar 05, 2015 7:27 pm

jepp. a little googling shows that the memory error was caused by the picture app in version 5.0.4, dont know if this bug still exists.

i disabled some more apps (documents, activity, pictures...) and tried again. unfortunately it didnt change anything.

in the meantime i got some new logentries:
Debug contacts OCA\Contacts\Backend\Database::getContact, Not found, id: 72553dd0-3892-4ab5-a918-2286db656bc9.vcf 2015-03-05T17:24:17+00:00
Debug contacts OCA\Contacts\Backend\Database::getContact, Not found, id: 72553dd0-3892-4ab5-a918-2286db656bc9.vcf 2015-03-05T17:24:17+00:00
Debug contacts OCA\Contacts\Backend\Database::getContact, Not found, id: 72553dd0-3892-4ab5-a918-2286db656bc9.vcf 2015-03-05T17:24:17+00:00

i checked the database and everything seems to be in place, atleast i can see the contacts in the oc_contacts_cards table.

can you increase the memory for php?


i guess not. im using the webspace and db-server of my webhoster. changing the php config isn't possible i guess. can i possibly delete something to gain more space? i tried to delete old folders with old version of owncloud as well as some picutres in my cloud. no luck

also, the contacts of my adminuser work as far as i can tell. i created a test contact and can see and change it as expected

jgionet76
Newbie
Posts: 3
Joined: Mon Oct 01, 2012 3:21 pm
ownCloud version: 9.0.1
Webserver: Apache
Database: MySQL
OS: Linux Hosting Package
Location: C A N A D A

Re: Contacts won't load / show after Update to 7.0.4

Postby jgionet76 » Mon May 16, 2016 6:00 pm

I'm experiencing the same issue right now with the latest version of OwnCloud.
Every app except the Contacts app will load. The contact app just shows the loading icon.
Image
free picture upload
My memory limit is set to 512MB. I'm assuming that should be enough.
I am on a shared hosting environment.
I have tried disabling the Gallery+ and documents apps with no luck.
I even deleted my user and re-recreated it and it's still the experiencing this issue.

Any help would be greatly appreciated !

Thanks

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Contacts won't load / show after Update to 7.0.4

Postby RealRancor » Mon May 16, 2016 9:45 pm

Hi,

this thread here is about the old contacts app from 7.0.4. Please try to not hijack such older threads and create a new thread filling out the issue template shown (especially the data/owncloud.log hint is important).
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 7.x”

Who is online

Users browsing this forum: No registered users and 3 guests