Can't upload file larger than 50Kb

Ask all your questions regarding OC 7.x Please read the Support Forum Rules
Forum rules
ownCloud 7.x will be end of life soon. See maintenance and release schedule for more details.

Time to upgrade!

Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting
tebe.raspati
Newbie
Posts: 2
Joined: Thu Apr 21, 2016 4:04 am
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Windows Server
PHP version: 5.5.9

Can't upload file larger than 50Kb

Postby tebe.raspati » Thu Apr 21, 2016 4:46 am

Update: Sorry revise for the subject. Actually i can't upload for some files. i am trying to upload a file with 60kb and fails. And another file with 400kb is success uploaded. I can't figure out the problem.

b]Steps to reproduce[/b]
1. remove Rewrite engine, etc
2. change upload max and post max
3. configure rewrite rules

Expected behaviour
Files with more than 50kb should be upload to server.

Actual behaviour
1. upload from client folder, more than 50kb is always fail.
2. error in client folder : unable to write
3. upload and download from browser work's fine.

Server configuration
Operating system: Windows Server 2008 R2
Web server: Apache
Database: MySql
PHP version: 5.5.9
ownCloud version (see ownCloud admin page): 7.0.3
Updated from an older ownCloud or fresh install: fresh
ownCloud log (data/owncloud.log): my log file more than 900mb, i can't open it. <<edit
i rename the file, and the the log file create automatically.

{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 845941 got 0","level":4,"time":"2016-04-21T02:56:11+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 845941 got 0","level":4,"time":"2016-04-21T02:57:10+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 845941 got 0","level":4,"time":"2016-04-21T02:58:12+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 845941 got 0","level":4,"time":"2016-04-21T02:59:12+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 845941 got 0","level":4,"time":"2016-04-21T03:00:10+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 845941 got 0","level":4,"time":"2016-04-21T03:01:13+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 845941 got 0","level":4,"time":"2016-04-21T03:02:22+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 5242880 got 16384","level":4,"time":"2016-04-21T03:08:54+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 242176 got 0","level":4,"time":"2016-04-21T03:09:35+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 242176 got 0","level":4,"time":"2016-04-21T03:10:38+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 5242880 got 0","level":4,"time":"2016-04-21T03:11:12+00:00"}
{"app":"webdav","message":"Sabre\\DAV\\Exception\\BadRequest: expected filesize 5242880 got 0","level":4,"time":"2016-04-21T03:17:12+00:00"}



This is notification from admin account:
Your web server is not yet properly setup to allow files synchronization because the WebDAV interface seems to be broken.
This server has no working internet connection. This means that some of the features like mounting of external storage, notifications about updates or installation of 3rd party apps don´t work. Accessing files from remote and sending of notification emails might also not work. We suggest to enable internet connection for this server if you want to have all features.
Please double check the installation guides.


Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):n):

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Can't upload file larger than 50Kb

Postby RealRancor » Thu Apr 21, 2016 6:08 am

See this two FAQs:

viewtopic.php?f=17&t=7536 ( Your web server is not yet properly message)
viewtopic.php?f=17&t=32517 (expected filesize error)

As oC 7.0.3 is outdated also update to the latest 7.0.x release.
*gone*

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Can't upload file larger than 50Kb

Postby RealRancor » Thu Apr 21, 2016 6:38 am

Forgot to mention that oC7 will reach end-of-life in one week. Unfortunately newer versions of oC are not supporting Windows as operating system so consider to move to a recent oC version running on a Linux based system.
*gone*

tebe.raspati
Newbie
Posts: 2
Joined: Thu Apr 21, 2016 4:04 am
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Windows Server
PHP version: 5.5.9

Re: Can't upload file larger than 50Kb

Postby tebe.raspati » Thu Apr 21, 2016 7:51 am

Thank you for your answer.

I've heard it before, but I am still hesitant to migrate to Linux, there are many who fail to do so.

Do you have any references to migrate to Linux?


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 7.x”

Who is online

Users browsing this forum: No registered users and 3 guests