New attempt, dreamhost, mac + owncloud

Ask all your questions regarding OC 5.x Please read the Support Forum Rules
Forum rules
ownCloud 5.x reached end of life and is officially unsupported. For details see Wiki page.

Please upgrade your ownCloud.
Posts: 14
Joined: Sat Feb 11, 2012 9:52 pm

New attempt, dreamhost, mac + owncloud

Postby hein2 » Tue Mar 27, 2012 11:32 pm

ok - sorry to spam you with this, but maybe it's helpful to someone ...
I'm pretty much a noob, I do SSH but have no clue about server bla, I do know some PHP but can't tell the htaccess from the Php.ini or so - I'm an enduser, trying all the good things ;)

and i have tried owncloud before, but something f****d up my system, so i just do it again. The ultimate goal is to have it all smoothly connected with my Mac, Ical, Address book and so on ...

so, following you'll hopefully find my report, of what i did and what happened, mostly in non-technical terms.

#1 using cyberduck to clear directory (provided by dreamhost)...., nothing left except for /owcloud_bak and /owncloud_bak2, two previous failed installations - no more hidden files.
checker output just before removing it:
Passed Tests (6)
  • PHP Version:5.3.5
  • Server Software:(Apache) Apache
  • php.ini:upload_max_filesize:7M
  • php.ini:post_max_size:7M
  • php.ini:memory_limit:90M
  • File upload limit:Upload files up to 7 MB
Possible Problems (1)
  • File Upload:Please check your settings (see warning below)
Critical Issues (1)
  • Config (Writeable):Config is missing. Writeable: No

#2 Following: ... /webspace/
Using the Mac Terminal with SSH I go into
and execute git clone git://
Results: a few lines "remote" +
Receiving objects: 100% (30096/30096), 10.14 MiB | 314 KiB/s, done.
Resolving deltas: 100% (20663/20663), done.

#3 According to ... /webspace/ again
I use Cyberduck and browse into the directory
I create the directory "/data" and set permissions to 750
I changed permissions on the directory "/config" to 777

Setup instructions tell me to enable .htaccess for my server, honestly I have no clue and assume - based on previous attempts that it works.

#4 I use Firefox to open the page
and enter the required data for a superadmin
admin name and password

#5 everything looks great.
Using Firefox 11.0 I go into Admin > Users and try to create a new user, for myself, not to use the superadmin account - for future options ...
creating user doesn't work on firefox.
neither does upload nor creating anything new (folder or text file) in > Files
Calendar is not displayed
Damn it, why is that?

I log out, with Firefox
#6 I try Safari and log in using my superadmin account
same problems:
uploading and creating anything new (folder or text file) in > Files doesn't work
Calendar is not displayed
I log out again.
Damn it

#7 I try Opera
creating a textile worked
calendar is displayed
contacts show a weird error message
No such file or directory in /home/xxxdir/ on line 498
Failed opening '/home/xxxdir/' for inclusion
actually I haven't checked this on the other browsers
after creating "Miss test User" the error messages are gone.
Creating the User "Flo":worked great
Log out with super user
#8 Log in with Opera, user "Flo"
everything looks great
I now want to connect my OwnCloud system with my Mac
I head over to Admin > Personal
WebDAV: I copy the webDav-address and change into the Finder
great, webdav seems to work perfectly
#9 Calendar: I copy the CalDav address and change into ICal
there I create a new caldav-account, enter my credentials and paste the link from above.
error message: "the account information was not found. the server has not specified a calendar home for account at .....caldav.php/ --". weird
I continue nonetheless, ICal offers this option
doesn't work
I check and add "/principals/USERNAME" to the CalDAV link for setting up the account ....
Error Message - after various attempts: the account information was not found. the host " is not a WebDAV server."
ICal didn't work, yet!

#10 Contacts: I copy the CardDav address and change into the Address Book
there I create a new account in the > Settings > Accounts
that didn't work, will check later
now following the advice on
did everything as described, doesn't work

frustrated I give up, too much time for a noose enduser like me!!
maybe more tomorrow - thanks for your attention - and YES, if you have any great advice, I'll take it

Posts: 14
Joined: Sat Feb 11, 2012 9:52 pm

Re: New attempt, dreamhost, mac + owncloud

Postby hein2 » Wed Mar 28, 2012 6:18 am

Ok, sorry for the rant last night ;)

Trying ICal again
I'm well aware off advices here:
and use this ... ipals/Flo/ as my server address for ICal

Don't know what was the difference to last night, but now it worked!! Great

Posts: 14
Joined: Sat Feb 11, 2012 9:52 pm

Re: New attempt, dreamhost, mac + owncloud

Postby hein2 » Wed Mar 28, 2012 6:35 am

Trying the Address Book again

Using this address: ... ipals/Flo/ and the advices from here:
As it doesn't seem to work, I start over:
#1 making sure there are no wrong sources in the Address Book, I open it, delete old accounts and restart it.
#2 I create an account with wrong details and edit the Configuration.plist from the Finder accordingly.
#3 Restarting the Address Book I enter the password in > Settings, so far seems fine.
#4 Works!!. Great

Why now and not yesterday? ;)

Posts: 14
Joined: Sat Feb 11, 2012 9:52 pm

Re: New attempt, dreamhost, mac + owncloud

Postby hein2 » Wed Mar 28, 2012 7:05 am

Ok - to finalize things:

On Firefox 11.0 everything looks great but I still have a few problems:
- can't upload
- editor won't work
- whenever I click on an uploaded file it will open the download-window, no editing.
- Calendar doesn't display
- Can't select Apps in the Admin > Apps panel

I - as a simple user - don't understand this and honestly it's too much work! Basically on my favourite browser the entire GUI doesn't work - I can only reliably download things.

I hope someone can help me on this.
Thanks for your attention

(can't search for firefox on this forum)

Posts: 14
Joined: Sat Feb 11, 2012 9:52 pm

Re: New attempt, dreamhost, mac + owncloud

Postby hein2 » Mon Apr 02, 2012 12:45 pm

Ok, no help from here, sorry for that ;(

However, I did re-install firefox, that solved all my issues -
can someone explain why?


Posts: 54
Joined: Sat Feb 11, 2012 12:38 am

Re: New attempt, dreamhost, mac + owncloud

Postby Baggypants » Mon Apr 02, 2012 4:36 pm

It's possible Firefox was caching all sorts of old things, a reinstall would have cleared the cache but it's a pretty dramatic way to do it. You don't mention if you cleared you cache after you made changes to the server,

Return to “ownCloud Community Edition 5.x and older”

Who is online

Users browsing this forum: No registered users and 1 guest