[SOLVED]Centos 6 and RHEL 6 - With GUIDE

Ask all your questions regarding OC 5.x Please read the Support Forum Rules
Forum rules
ownCloud 5.x reached end of life and is officially unsupported. For details see Wiki page.

Please upgrade your ownCloud.
abatie
Newbie
Posts: 1
Joined: Tue Mar 26, 2013 10:30 am
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.23

Re: [SOLVED]Centos 6 and RHEL 6 - With GUIDE

Postby abatie » Tue Mar 26, 2013 10:38 am

Permission problems like that sound like selinux at work - centos 6 defaults to enforcing mode. You can test it by running "setenforce 0" and seeing if things start working. If they do, and you don't care about selinux security enforcement, you can make the change permanent in /etc/selinux/config (change "enforcing" to "permissive"). "restorecon" might fix the problem without turning off the protections, depending on what's wrong...

maperk
Newbie
Posts: 1
Joined: Fri Apr 05, 2013 4:18 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.3

Re: [SOLVED]Centos 6 and RHEL 6 - With GUIDE

Postby maperk » Fri Apr 05, 2013 4:25 pm

If you are still getting an Apache Forbidden when you try to access the web files, you might take a look at the SELinux settings on the files. Use the "ls -Z" to check the context of the .HTML files and if they don't have the http content type then use:

chcon -v -R --type=httpd_sys_content_t /var/www/html/owncloud

to ensure SELinux won't block access to the web files.

Maybe give that a try.

fullpadge
Newbie
Posts: 1
Joined: Wed May 15, 2013 9:34 pm
ownCloud version: 5.0.5
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5

Re: [SOLVED]Centos 6 and RHEL 6 - With GUIDE

Postby fullpadge » Wed May 15, 2013 9:37 pm

CENTOS6.4 READ THIS

For Centos 6.4 ----- to satisfy some missing php-dependencies:
-add EPEL repository

rpm - http://download.fedoraproject.org/pub/e ... noarch.rpm

and continue the normal process !


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 5.x and older”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest