Endless Propfind 401 and 207 errors

Ask all your questions regarding OC 5.x Please read the Support Forum Rules
Forum rules
ownCloud 5.x reached end of life and is officially unsupported. For details see Wiki page.

Please upgrade your ownCloud.
mkudro
Newbie
Posts: 6
Joined: Mon Feb 18, 2013 9:25 am
ownCloud version: 4.5.6

Endless Propfind 401 and 207 errors

Postby mkudro » Wed Feb 20, 2013 11:55 am

Could someone help me out here. As soon as i start sync client on my laptop i'm starting to get following errors:

Code: Select all

PROPFIND /files/webdav.php/my_sync_folder HTTP/1.1" 401 291
PROPFIND /remote.php/webdav/my_sync_folder HTTP/1.1" 207 13797

These messages printed simultaneously and repeating every 30 seconds while (linux) sync client (v1.2) is running.
Directory is fully synced and if i place a file in it then it gets synced to the server (lamp) as well.
Could you please tell me what these messages mean.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Endless Propfind 401 and 207 errors

Postby RealRancor » Wed Feb 20, 2013 2:48 pm

Hi,

those are no errors and just http status codes. Have a look at this list:

https://en.wikipedia.org/wiki/List_of_HTTP_status_codes

The sync client is just checking if the files on your server where changed via the Web-GUI to detect changes which can be synced to your client.
*gone*

mkudro
Newbie
Posts: 6
Joined: Mon Feb 18, 2013 9:25 am
ownCloud version: 4.5.6

Re: Endless Propfind 401 and 207 errors

Postby mkudro » Wed Feb 20, 2013 3:19 pm

Thank you Rancor for your response. It definitely looked like "unauthorized" http status code, but i was in doubt. This is why i mentioned in my post explicitly that sync was successful, implying that authorization was not an issue. So i thought, maybe this was a specific, owncloud/sync client, status code. Since it is a http status code allow me rephrase my question then:
Why do i get authorization failure (unauthorized) 401 code while synchronization is taking place. I would assume if sync client is unauthorized it shouldn't be able to complete sync successfully, or check for any changes, right?
Could you please elaborate on that? thnx.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Endless Propfind 401 and 207 errors

Postby RealRancor » Wed Feb 20, 2013 6:06 pm

Hi,

sorry i can't tell you exactly why you're getting this 401 but this:

/files/webdav.php/my_sync_folder

is deprecated and shouldn't be used anymore. You shouldn't get a call like this and the clients should use:

/remote.php/webdav/my_sync_folder

instead. For this you're getting a correct 207 http status code, so check that all of your clients are using:

/remote.php/webdav/my_sync_folder

and not:

/files/webdav.php/my_sync_folder
*gone*

mkudro
Newbie
Posts: 6
Joined: Mon Feb 18, 2013 9:25 am
ownCloud version: 4.5.6

Re: Endless Propfind 401 and 207 errors

Postby mkudro » Wed Feb 20, 2013 8:42 pm

Hi Rancor, you make it sound so obvious that most probably i will look stupid when asking - what do you mean check if clients are using remote.php instead of webdav??? These are official releases of owncloud sync clients for linux (version 1.2) and windows (version 1.02) and i only can hope that they would contain right instructions according to upstream changes.
Am i overseeing something very obvious? Should i bother devs with this on bugzilla?
thx for your time.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Endless Propfind 401 and 207 errors

Postby RealRancor » Wed Feb 20, 2013 11:11 pm

Ah, i thought you're using some 3rd party WebDAV tools for the sync. If you're using the windows version 1.02 you should update this to the current 1.2. This version 1.2 should not open the /files/webdav.php/my_sync_folder at all.

Do you always get this message:

PROPFIND /files/webdav.php/my_sync_folder HTTP/1.1" 401 291

when syncing or only from time to time? When it's only from time to time you should check the source ip of this access, maybe a botnet is trying to gain access to your OC instance.
*gone*

mkudro
Newbie
Posts: 6
Joined: Mon Feb 18, 2013 9:25 am
ownCloud version: 4.5.6

Re: Endless Propfind 401 and 207 errors

Postby mkudro » Wed Feb 27, 2013 2:43 pm

Hi Rancor, thnx fo your answer...it's been a week, haven't had much time to update thread... but i came across similar error messages when i have set up owncloud akonadi resource (KDE).
This supposedly should give me possibility to have my contacts and calendars synced with my desktop (Korganizer en Konact).
And indeed they are sync as expected, but as it was in the case of linux sync-client (v1.2 btw) i still get plenty of 401 291 errors....every 8 minutes or so, each time that Kontac or Korganiser trying to query my caldav/carddav.
And just to put "botnet/hacking" version aside - IPs are legit, just locations that i have worked from in the time of errors.
The very moment i quit sync-client or stop akonadi (Korganise/Kontact daemons) error are gone...
Is this linux related? It is impossible for it to be legit 401 - my contacts and calendars are synced!!!
I think i,m gonnna write this up on owncloud bugzilla.
Thnnx for your time...if i will update this thread when i figure this out.

cjacoby78
Newbie
Posts: 6
Joined: Tue Apr 02, 2013 11:27 am
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux

Re: Endless Propfind 401 and 207 errors

Postby cjacoby78 » Wed Apr 17, 2013 9:29 am

Hi all!

I am observing the same problem, although with the "not deprecated path":

Code: Select all

PROPFIND /remote.php/webdav/clientsync HTTP/1.1" 401 291


All my clients (both Mac and Windows) trigger this error more than 3000 times a day.

I am on ownlcoud 5.0.4, sync clients 1.2.4 - although syncing works fine ...

This shouldn't happen as, 401 is the "unauthorized" access error code. It shows up on my logwatch summary every day.

I am currently considering filing a bug report on github.

Cheers,
CJ

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: Endless Propfind 401 and 207 errors

Postby RandolphCarter » Wed Apr 17, 2013 11:49 am

Have you already checked this FAQ entry: viewtopic.php?f=17&t=7536

401 responses are usually a sign of wrong server configuration. What server software (apache, nginx, ...) do you run ownCloud on? Please also check the access log of your server.

Edit: Just noticed your other post here: viewtopic.php?f=23&t=10539
No double posting please, it's just confusing people trying to help


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 5.x and older”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests