Upgrade to oC 8.1.x (known issues and faq)

Ask all your questions regarding OC 8.0 and 8.1 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
davleema
Beginner
Posts: 47
Joined: Wed Apr 03, 2013 1:35 am
ownCloud version: 8.1.3
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.24
Location: Belgium

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby davleema » Mon Jul 20, 2015 11:26 pm

mehlkopf wrote:One should add that CalDAV seems not to work with Owncloud 8.1, at least for lots of configurations and people! (see for example https://github.com/owncloud/calendar/issues/853 or https://github.com/owncloud/calendar/issues/857) ......
Is there hope for a fix anytime soon? Owncloud without CalDAV is totaly useless to me ... Thank you!

Works just fine here. I upgraded manually from 8.0.4 to 8.1.0.
I was anxious too about Caldav, but my Android phone, and mail client are syncing just fine.
David
Apache 2.4.17 - MariaDB 5.5.x - PHP 5.5.x - Slackware x64

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby RealRancor » Tue Jul 21, 2015 11:17 am

*gone*

gianni999
Newbie
Posts: 7
Joined: Wed Jul 22, 2015 10:09 am
ownCloud version: 8.1.0

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby gianni999 » Sat Jul 25, 2015 10:38 am

I still have a broken encryption since updating from 8.04 to 8.1.
I'm following the instructions in this thread:

RealRancor wrote:
If you already migrated and have a broken installation please see: https://github.com/owncloud/core/issues/17574



After replacing the new files and running "occ encryption:migrate" once again I got the following error:

PHP Fatal error: Class 'OC_Mount_Config' not found in /homepages/4/d97677895/htdocs/cloud/lib/private/encryption/util.php on line 322

Is this a known issue?
What can I do?

Thanks a lot in advance for your support.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby RealRancor » Sat Jul 25, 2015 1:27 pm

Please roll back to your backup and wait until oC 8.1.1 is released.
*gone*

gianni999
Newbie
Posts: 7
Joined: Wed Jul 22, 2015 10:09 am
ownCloud version: 8.1.0

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby gianni999 » Sat Jul 25, 2015 6:25 pm

Unfortunately I forgot to backup my database
(very stupid, I know...), I have only the old installation files,
the keys and the data.
Will 8.1.1 work for me in this case?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby RealRancor » Sat Jul 25, 2015 6:46 pm

Probably the only chance for you to wait until 8.1.1. You could also contact the developers which have more knowledge about the encryption itself.
*gone*

chuckingit
Newbie
Posts: 7
Joined: Tue Mar 04, 2014 10:40 pm
ownCloud version: 6.0.1
Webserver: Apache
Database: MySQL
OS: Linux

SSL Upgrade to oC 8.1

Postby chuckingit » Sun Jul 26, 2015 4:25 am

i too found upgrade to 8.1 with broken SSL but after much labor found this elegant htaccess hack that cured all and forced ownCloud 8.1 to play nice and force https ...

solution was to put the following code into .htaccess file of public root of ownCloud install folder ...

#CS Force SSL
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

the above code was found at this thread -> http://stackoverflow.com/questions/4398 ... od-rewrite

hope this helps ...
cordially, chuck scott

ps - i had posted similar thread in this forum -> viewtopic.php?f=31&t=29433&p=92609#p92609 ... and after fact thought perhaps similar info should be here as my path to update Apache Virtual Directives was bomb with my host but i digress ...

manchot
Newbie
Posts: 1
Joined: Thu Jul 30, 2015 5:07 pm
ownCloud version: 8.1.0
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby manchot » Thu Jul 30, 2015 5:11 pm

gianni999 wrote:After replacing the new files and running "occ encryption:migrate" once again I got the following error:

PHP Fatal error: Class 'OC_Mount_Config' not found in /homepages/4/d97677895/htdocs/cloud/lib/private/encryption/util.php on line 322

Is this a known issue?
What can I do?

Thanks a lot in advance for your support.


Had the same issue. I just disabled the app external storage (sudo -u www-data php occ app:disable files_external) and started the migration process once again. After that I have enabled the app again and it just worked. :)

UncleStark
Newbie
Posts: 1
Joined: Fri Aug 07, 2015 3:11 pm
ownCloud version: 8.1.0
Webserver: Apache
Database: MySQL
PHP version: 5.6.11

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby UncleStark » Fri Aug 07, 2015 3:13 pm

why removed "download from link" feature
and how to return

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby RealRancor » Fri Aug 07, 2015 3:15 pm

*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.0 and 8.1”

Who is online

Users browsing this forum: No registered users and 2 guests