Upgrade to oC 8.1.x (known issues and faq)

Ask all your questions regarding OC 8.0 and 8.1 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
elvenbone
Beginner
Posts: 16
Joined: Fri Aug 08, 2014 1:21 am
ownCloud version: 7.0.4
OS: Linux

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby elvenbone » Fri Aug 14, 2015 12:01 am

I have something to add which I found nothing on the forum for:

Not all contacts are synced to a new device via CardDAV

The bug is known on github as WindowsPhone-specific problem, but I can also confirm it for KDE Kontact:
https://github.com/owncloud/contacts/issues/998

Solution (more of a workaround actually, also described on the bug page in github):
Export all your contacts, make a backup of that file, then open the file in a text editor of your choice, find-and-replace all @yourdomain.xyz or @your.ip.address from the IP lines with anything that does not contain the @-sign.
Remove your adressbook from owncloud, add a new one of the same name, import the edited file and wait until all contacts are in owncloud again. Then try to synchronize your phone addressbook or addressbook application (in my case both WP8.1 and Kontact on Kubuntu) again.

Not affected: The devices you added CalDAV to some time ago (before OC8.1) may still show all the contacts just fine.

best regards
elvenbone

kz6fittycent
Newbie
Posts: 2
Joined: Sat Sep 12, 2015 10:39 pm
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby kz6fittycent » Sat Sep 12, 2015 10:57 pm

davleema wrote:
mehlkopf wrote:One should add that CalDAV seems not to work with Owncloud 8.1, at least for lots of configurations and people! (see for example https://github.com/owncloud/calendar/issues/853 or https://github.com/owncloud/calendar/issues/857) ......
Is there hope for a fix anytime soon? Owncloud without CalDAV is totaly useless to me ... Thank you!

Works just fine here. I upgraded manually from 8.0.4 to 8.1.0.
I was anxious too about Caldav, but my Android phone, and mail client are syncing just fine.



I can confirm that CalDAV works but inviting others via email DOES NOT. The "patch" in github https://github.com/owncloud/calendar/commit/7cadce0f675bf871eb641e70a99b1dc509bdd164 does NOT work. I would assume that it was applied to the 8.1.1 update given it's date but maybe not. In any case, it was a no go.

The oddity in my case is that it WAS working up until the 9th of Sep, and then just stopped. Error logs are standard error logs reported by everyone else. For the curious: Undefined index: userid at /var/www/owncloud/apps/calendar/lib/app.php#46

I can share and sync CalDAV both ways (from OC to Thunderbird/Lightning and vice versa). I cannot share calendar events from Thunderbird/Lightning (anymore).

I am at a loss.

Thing is, it's KILLING me that it's not working! It should be working and given that it was fully functioning and totally radical 3 days ago, I am really torqued.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby RealRancor » Sat Sep 12, 2015 11:00 pm

Please report such issues directly to the developers. Nothing what we users in here can do about this...
*gone*

kz6fittycent
Newbie
Posts: 2
Joined: Sat Sep 12, 2015 10:39 pm
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby kz6fittycent » Sat Sep 12, 2015 11:44 pm

RealRancor wrote:Please report such issues directly to the developers. Nothing what we users in here can do about this...

I'm not sure if you're referring to my post but it has been reported to the devs as an official bug...in APRIL. I am running 8.1.1 and was confirming what someone else is experiencing. If enough people are reading this same post, maybe someone has found a resolution...just sayin.

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby tflidd » Sun Sep 13, 2015 12:10 am

kz6fittycent wrote:
RealRancor wrote:Please report such issues directly to the developers. Nothing what we users in here can do about this...

I'm not sure if you're referring to my post but it has been reported to the devs as an official bug...in APRIL. I am running 8.1.1 and was confirming what someone else is experiencing. If enough people are reading this same post, maybe someone has found a resolution...just sayin.

He meant you. If a bug fix is not working, you must report this to the developers. They won't read it here on the user forum.

stephengraf
Beginner
Posts: 27
Joined: Fri Oct 24, 2014 11:09 pm
ownCloud version: 8.2.2
Webserver: proprietary
Database: MySQL
OS: OpenBSD
PHP version: 5.6
Location: Vancouver, Canada

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby stephengraf » Thu Oct 22, 2015 7:22 am

Re: cURL error 60: SSL certificate problem: unable to get local issuer certificate

I started testing openBSD 5.8 which shipped with ownCloud 8.1.0. When trying to add the store apps I was getting the cURL error 60. After reading the last posts to the GitHub track, https://github.com/owncloud/core/issues/17446, two posters fixed their problems by replacing the ca-bundle that comes with ownCloud with a bundle from some other source. I replaced the ownCloud bundle with one that shipped with the openBSD 5.8 distribution and the problem went away.

After all the posts about SSL bugs, could there just be a problem with the ownCloud ca-bundle? Why does ownCloud even provide a bundle when there is one supplied with the distribution?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby RealRancor » Thu Oct 22, 2015 7:35 am

stephengraf wrote:Why does ownCloud even provide a bundle when there is one supplied with the distribution?


Because those bundles are known to be outdated, especially on such systems like CentOS/RHEL and similar.
*gone*

stephengraf
Beginner
Posts: 27
Joined: Fri Oct 24, 2014 11:09 pm
ownCloud version: 8.2.2
Webserver: proprietary
Database: MySQL
OS: OpenBSD
PHP version: 5.6
Location: Vancouver, Canada

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby stephengraf » Sun Oct 25, 2015 2:51 am

Although the ca bundles on some distributions might be outdated, I suspect that the bundles with those systems would have worked and not created all the problems that introducing another bundle into owncloud did. In my test I was using openBSD 5.8 which was just released and it came with owncloud 8.1, php 5.6, libressl 2.0 and I doubt any of this is out of date. I had no problem using cURL from a command line to get to the app store, which would have used the openBSD supplied bundle. Owncloud 8.1.3 did not complain about a "buggy" ssl vervsion, yet I could not get to the app store from owncloud admin. I tried changing the ca bundle because someone running SUSE 12 was able to resolve the same problem in that way.

The issue is, should owncloud be forcing ca bundles when it seems to be causing problems. Do I even want owncloud to be my source of security certificates? It seems that owncloud just copied the bundle from some other source. How much effort went into verifying the security of the bundle? I use openBSD partly because of its emphasis on security and would much rather depend on openBSD for things like openssl and ca bundles.

I would like to recommend that owncloud make the choice of ca bundle an option in config.php with documentation to indicate that the default supplied with owncloud might not work on all systems.

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby tflidd » Sun Oct 25, 2015 9:16 am

stephengraf wrote:I would like to recommend that owncloud make the choice of ca bundle an option in config.php with documentation to indicate that the default supplied with owncloud might not work on all systems.

The bundles were taken from Mozilla. Unfortunately, we can't discuss the pros and cons of this solution and it wouldn't help because the developers are not listening here. I suggest you move this discussion over to github/mailinglist: viewtopic.php?f=17&t=23696

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade to oC 8.1.x (known issues and faq)

Postby RealRancor » Sun Oct 25, 2015 11:19 am

Just some background info to this:

With oC 8.1 all ownCloud relevant pages like the Appstore (apps.owncloud.com) where switched to SSL. This has caused connection issues as the needed intermediate certificate which got enabled there was missing in various "Enterprise Linux" distros like CentOS and RHEL. This caused failed connections to this pages. Thats why the devs introduced this ca-bundle.crt in https://github.com/owncloud/core/pull/15195

But as tflidd suggested i would move that to the places linked as we users in here can't change anything about this.
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.0 and 8.1”

Who is online

Users browsing this forum: No registered users and 2 guests