404 Error with SSL on /index.php/apps

Ask all your questions regarding OC 8.0 and 8.1 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
KMyers
Newbie
Posts: 8
Joined: Tue Nov 10, 2015 6:57 pm
ownCloud version: 8.1.3
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.9

404 Error with SSL on /index.php/apps

Postby KMyers » Tue Nov 10, 2015 7:12 pm

Good Afternoon,
I have just setup a new OwnCloud instance that will be accessible over the public internet and of course went ahead and setup SSL. I can access everything perfectly while not on SSL but the second I punch in https:// things start going downhill very quickly.

While using SSL, I can hit the OwnCloud Login Page and authentication is working properly however when I get directed to https://xx.xxxx.xxx/index.php/apps/files/, I am greeted with a 404 error.

I have double checked everything I can think of and am unable to isolate the issue. I have included some of the details below in case anyone sees anything I missed.

My Server Details Are
Environment: Ubuntu x64 14.04.03
Server: Apache 2.4.7
Database: MySQL/MariaDB 5.5.46
Client: All (Firefox/Chrome/ETC)
OC-Version: 8.1.4
PHP-Version: 5.5.9
Installation Path: /var/www/owncloud


My Apache sites-enabled (SSL) - Some information has been redacted for security purposes.


<IfModule mod_ssl.c>
<VirtualHost *:443>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request's Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
ServerName cloud.kmyers.me
<IfModule mod_headers.c>
Header always set Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
</IfModule>
ServerAdmin xxxxxxxx@gmail.com
DocumentRoot /var/www/owncloud


# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the loglevel for particular
# modules, e.g.
#LogLevel info ssl:warn

ErrorLog ${APACHE_LOG_DIR}/error-ssl.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

# For most configuration files from conf-available/, which are
# enabled or disabled at a global level, it is possible to
# include a line for only one particular virtual host. For example the
# following line enables the CGI configuration for this host only
# after it has been globally disabled with "a2disconf".
#Include conf-available/serve-cgi-bin.conf
SSLCertificateFile /xxxxx/cert.pem
SSLCertificateKeyFile xxxxxxx/privkey.pem
Include /xxxx/options-ssl-apache.conf
SSLCertificateChainFile /etc/xxxxxxxx/chain.pem
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
</IfModule>


And for fun, my Non-SSL Sites Enabled File
<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request's Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
ServerName cloud.kmyers.me

ServerAdmin keithiokepamyers@gmail.com
DocumentRoot /var/www/owncloud
#Redirect permanent / https://xxx.xxxx.xxx/

# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the loglevel for particular
# modules, e.g.
#LogLevel info ssl:warn

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

# For most configuration files from conf-available/, which are
# enabled or disabled at a global level, it is possible to
# include a line for only one particular virtual host. For example the
# following line enables the CGI configuration for this host only
# after it has been globally disabled with "a2disconf".
#Include conf-available/serve-cgi-bin.conf
#RewriteEngine on
#RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [L,QSA,R=permanent]

</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: 404 Error with SSL on /index.php/apps

Postby RealRancor » Tue Nov 10, 2015 7:19 pm

*gone*

KMyers
Newbie
Posts: 8
Joined: Tue Nov 10, 2015 6:57 pm
ownCloud version: 8.1.3
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.9

Re: 404 Error with SSL on /index.php/apps

Postby KMyers » Tue Nov 10, 2015 8:29 pm


Thanks, that was it.


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.0 and 8.1”

Who is online

Users browsing this forum: No registered users and 4 guests