Owncloud stops responding

Ask all your questions regarding OC 8.0 and 8.1 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
Mark9117
Beginner
Posts: 20
Joined: Sat Mar 17, 2012 8:34 am

Owncloud stops responding

Postby Mark9117 » Sat Nov 28, 2015 10:20 am

Installed on my home server -- I am the web host.

OwnCloud 8.1.3 (stable)
Mageia Linux 3.19.8-desktop-3.mga5 #1 SMP Sat Jun 13 17:05:48 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Installed from repositories via rpm
PHP Version 5.6.13
Server version: Apache/2.4.10 (Unix)

I hope this is the right place to ask this question. There is a possibility that I'm dealing with an Apache issue.

What's happening is that owncloud is failing to allow anyone to log on after it's been up for awhile. "Awhile" meaning a day or so. It also seems that after trying unsuccessfully to log in, Owncloud just stops loading at all. The web page just sits there and churns waiting on Owncloud to send something, anything to the browser.

I've been watching the child processes and at one point I assumed that the two-dozen or so children spawning under apache were somehow stuffing owncloud. Initially, restarting httpd looked like a step in the right direction as that killed off all but about 10 child processes. But I still couldn't log on.

Since restarting httpd didn't resolve the issue, and not knowing what else to restart, I rebooted the system. That made it possible for me to log in, but history shows that it won't last.

The sever responds when called with https://adams-lan.org - there is no page there, so all you get is "It works!" but that's all you're supposed to get. My Dokuwiki installation on the same server (my home server) responds just fine whether I can get into Owncloud or not. This would seem to indicate that the issue is with Owncloud and not Apache.

I can't get into Owncloud with my iPad or my daughter's iPhone regardless, but other devices get in just fine once the system is rebooted and a security exception is made in the browser (I'm using a self-signed certificate).

I've got some links to pertinent log and config files:

vhosts.conf
http://pastebin.com/nNVEKx6v

sites.d
http://pastebin.com/8tDepqMB

httpd.conf
http://pastebin.com/af4TYYCx

ssl_request_log
http://pastebin.com/3kKngkHg

tail-access_log
http://pastebin.com/6JEhUnaW

I'm not claiming any expertise in all this; I just want to get access to my files when I'm not actually at home. If anybody can see anything here that is causing Owncloud to stop responding, or suggest something else I need to look at, please do let me know.

Thank you.

Mark

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Owncloud stops responding

Postby tflidd » Sat Nov 28, 2015 8:44 pm

You have three VirtualHosts for SSL defined. Within a SSL-virtualhost it makes no sense to put this redirection

Code: Select all

Redirect http://adams-lan.org/owncloud "https://adams-lan.org/owncloud"

and the ServerName and ServerAlias only contains the hostname, no URL. Instead of:

Code: Select all

ServerAlias adams-lan.org adams-lan.org/owncloud

this is enough:

Code: Select all

ServerAlias adams-lan.org


It can be a bit confusing with all these configuration files. The apache documentation about virtualHost is quite good and gives some examples:
https://httpd.apache.org/docs/2.4/en/vhosts/

Mark9117
Beginner
Posts: 20
Joined: Sat Mar 17, 2012 8:34 am

Re: Owncloud stops responding

Postby Mark9117 » Sun Nov 29, 2015 10:14 am

Okay, commented out those elements and now I can't get httpd to start.

Code: Select all

# systemctl status httpd
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
   Active: failed (Result: signal) since Sun 2015-11-29 01:12:21 MST; 1min 10s ago
  Process: 3067 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=killed, signal=KILL)
 Main PID: 3067 (code=killed, signal=KILL)

Nov 29 01:10:51 shuttle systemd[1]: httpd.service start operation timed out. Terminating.
Nov 29 01:12:21 shuttle systemd[1]: httpd.service stop-final-sigterm timed out. Killing.
Nov 29 01:12:21 shuttle systemd[1]: httpd.service: main process exited, code=killed, status=9/KILL
Nov 29 01:12:21 shuttle systemd[1]: Failed to start The Apache HTTP Server.
Nov 29 01:12:21 shuttle systemd[1]: Unit httpd.service entered failed state.
Nov 29 01:12:21 shuttle systemd[1]: httpd.service failed.


I rebooted the server and it still won't start:

Code: Select all

# systemctl status httpd
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
   Active: deactivating (final-sigterm) (Result: timeout)
 Main PID: 1365 (httpd)
   CGroup: /system.slice/httpd.service
           └─1365 /usr/sbin/httpd -DFOREGROUND

Nov 29 01:05:36 shuttle systemd[1]: httpd.service start operation timed out. Terminating.


And the logs are not much help. There's really nothing showing up in access_log, errors_log, warning_log or ssl_request_log. I even set the log level in httpd.conf to "debug". No joy.

Mark

Edit: okay this is weird. I commented out the line in httpd.conf that included conf/conf.d then started Apache. It fired right up immediately. I then stopped Apache and looked in conf.d. The only file I found that looked like it might be involved - ssl.conf. I opened it with vi, scrolled through it and closed it immediately. I then fired Apache up and once again, it started immediately.

Owncloud is still slow to load, but it let me log in. I don't know what's going on here, but I don't think I'll be messing with it until I have plenty of free time.

Mark9117
Beginner
Posts: 20
Joined: Sat Mar 17, 2012 8:34 am

Re: Owncloud stops responding

Postby Mark9117 » Sun Nov 29, 2015 11:01 am

As an experiment, I logged into OC and attempted to download a large file. It started downloading the file and failed. I tried 2 more times and failed 2 more times.

I closed that OC tab and attempted to log back into OC and now it won't load again. I've don a "reload-or-restart" on httpd.service twice and no joy. Attempting to open OC causes the page to just sit there and blankly churn.

Log files are not much help:

Error_log

Code: Select all

# tail error_log
[Sun Nov 29 01:50:59.011857 2015] [ssl:info] [pid 5108] [client 192.168.1.1:58326] AH01964: Connection to child 13 established (server localhost:443)
[Sun Nov 29 01:50:59.078544 2015] [:error] [pid 5108] [client 192.168.1.1:58326] {"reqId":"Vlq8cz50l7pbgjpI6Nfr1gAAAA0","remoteAddr":"192.168.1.1","app":"PHP","message":"APM cannot be enabled, '\\/var\\/lib\\/php-apm\\/db' is not directory at Unknown#0","level":3,"time":"2015-11-29T08:50:59+00:00"}
[Sun Nov 29 01:51:04.098665 2015] [ssl:info] [pid 5108] (70007)The timeout specified has expired: [client 192.168.1.1:58326] AH01991: SSL input filter read failed.
[Sun Nov 29 01:51:20.011684 2015] [ssl:info] [pid 5115] [client 192.168.1.1:58328] AH01964: Connection to child 1 established (server localhost:443)
[Sun Nov 29 01:51:25.115037 2015] [ssl:info] [pid 5115] (70007)The timeout specified has expired: [client 192.168.1.1:58328] AH01991: SSL input filter read failed.
[Sun Nov 29 01:51:52.091655 2015] [ssl:info] [pid 5115] [client 192.168.1.1:58330] AH01964: Connection to child 1 established (server localhost:443)
[Sun Nov 29 01:51:57.190946 2015] [ssl:info] [pid 5115] (70007)The timeout specified has expired: [client 192.168.1.1:58330] AH01991: SSL input filter read failed.
[Sun Nov 29 01:51:59.011696 2015] [ssl:info] [pid 5105] [client 192.168.1.1:58332] AH01964: Connection to child 4 established (server localhost:443)
[Sun Nov 29 01:52:04.089665 2015] [ssl:info] [pid 5105] (70007)The timeout specified has expired: [client 192.168.1.1:58332] AH01991: SSL input filter read failed.
[Sun Nov 29 01:52:10.669658 2015] [ssl:info] [pid 5109] (70007)The timeout specified has expired: [client 192.168.1.1:58324] AH01991: SSL input filter read failed.


I have no idea what to make of that.

journalctl

Code: Select all

Nov 29 01:50:16 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:50:26 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:50:29 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:50:30 shuttle mandi[2394]: skipping loopback interface
Nov 29 01:50:30 shuttle sshd[5138]: fatal: Read from socket failed: Connection reset by peer [preauth]
Nov 29 01:50:46 shuttle mandi[2394]: skipping known address: 192.168.1.100
Nov 29 01:50:46 shuttle sshd[5176]: fatal: Read from socket failed: Connection reset by peer [preauth]
Nov 29 01:50:48 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:50:57 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:50:59 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:51:20 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:51:30 shuttle mandi[2394]: skipping known address: 192.168.1.1
Nov 29 01:51:30 shuttle mandi[2394]: skipping loopback interface
Nov 29 01:51:30 shuttle sshd[5201]: fatal: Read from socket failed: Connection reset by peer [preauth]
Nov 29 01:51:47 shuttle mandi[2394]: skipping known address: 192.168.1.100


It looks like the only way to get OwnCloud back is to reboot the server. I can't think of anything else to restart.

Still looking for assistance.

Thanks.

Mark

Mark9117
Beginner
Posts: 20
Joined: Sat Mar 17, 2012 8:34 am

Re: Owncloud stops responding

Postby Mark9117 » Sun Nov 29, 2015 8:20 pm

Closed and reopened Firefox and OC is loading now. I'm going to watch the situation and hope OC doesn't fall over again, but at this point the issue may be resolved.

Thanks for the input and stand down for now.

Mark

Mark9117
Beginner
Posts: 20
Joined: Sat Mar 17, 2012 8:34 am

Re: Owncloud stops responding

Postby Mark9117 » Tue Dec 15, 2015 6:52 am

Update on this. I'm not sure I've "fixed" it, but I did notice that my /tmp directory was filling up with "inclued" files. These files soak up my 2 Gb /tmp directory and it prevents Owncloud from loading somehow.

The inclued files look like these:

Code: Select all

# ll
total 401948
drwx------ 2 root   root       60 Dec 14 00:00 atop.d/
drwx------ 2 madams madams     60 Dec 13 02:34 gpg-Hrd0CG/
-rw-r--r-- 1 root   root        8 Dec 14 21:40 httpd_lua_shm.18543
-rw-r--r-- 1 apache apache 442265 Dec 14 21:40 inclued.18386.1
-rw-r--r-- 1 apache apache 435924 Dec 14 21:40 inclued.18386.2
-rw-r--r-- 1 apache apache 426920 Dec 14 21:39 inclued.18387.1
-rw-r--r-- 1 apache apache 531596 Dec 14 21:39 inclued.18387.2
-rw-r--r-- 1 apache apache 447533 Dec 14 21:40 inclued.18387.3
-rw-r--r-- 1 apache apache 391190 Dec 14 21:40 inclued.18387.4
-rw-r--r-- 1 apache apache 334507 Dec 14 21:40 inclued.18387.5


These files are loaded with information that is not formatted for human eyes. It looks a lot like this:

Code: Select all

a:4:{s:7:"request";a:5:{s:8:"_REQUEST";a:0:{}s:7:"_COOKIE";a:2:{s:20:"oc_sessionPassphrase";s:128:"pHhZ7WdrT1mpFAddSn8LrH7VeSvjVlscyRPPowg94OyuJCy0SzES5rWmK18Lk+4v9jh2ROdY22K+DLpiXfqhL7HSLQ9KEg9FHRTnhzJD4PqiDKt4H/yTiEZm12w1aYq1";s:12:"ocaggqh0b401";s:26:"hinsecjrmi0lm6v7b7mlq6fbd1";}s:15:"SCRIPT_FILENAME";s:30:"/usr/share/owncloud/remote.php";s:11:"REQUEST_URI";s:28:"/owncloud/remote.php/webdav/";s:12:"REQUEST_TIME";i:1450154313;}s:8:"includes";a:503:{i:0;a:6:{s:9:"operation";s:12:"require_once";s:7:"op_type";i:16;s:8:"filename";s:12:"lib/base.php";s:11:"opened_path";s:32:"/usr/share/owncloud/lib/base.php";s:8:"fromfile";s:30:"/usr/share/owncloud/remote.php";s:8:"fromline";i:87;}i:1;a:6:{s:9:"operation";s:12:"require_once";s:7:"op_type";i:16;s:8:"filename";s:20:"public/constants.php";s:11:"opened_path";s:44:"/usr/share/owncloud/lib/public/constants.php";s:8:"fromfile";s:32:"/usr/share/owncloud/lib/base.php";s:8:"fromline";i:55;}i:2;a:7:{s:9:"operation";s:12:"require_once";s:7:"op_type";i:16;s:8:"filename";s:38:"/usr/share/owncloud/lib/autoloader.php";s:11:"opened_path";s:38:"/usr/share/owncloud/lib/autoloader.php";s:8:"fromfile";s:32:"/usr/share/owncloud/lib/base.php";s:8:"fromline";i:481;s:8:"function";s:4:"init";}i:3;a:8


There are obvious references to php in there and some reasons to suspect webdav (which I have attempted to t/s with no real success that I can detect). I've been circling these files for a couple of weeks now and have found no clue as to troubleshooting much less resolving the issue.

For now, I am dealing with it by running a cron job that just deletes the inclued* files every 6 hours. This generally avoids having Owncloud just stop responding, but I often find Owncloud loading so slowly that it times out. You have to reload the page 3 times to get everything to show up.

It's frustrating and I'm still looking for some way to fix it, but everytime I find a resolution for one issue, I see two more crop up.

I'll mark this thread resolved if I ever get this stuff stamped out.

Mark

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Owncloud stops responding

Postby tflidd » Tue Dec 15, 2015 12:01 pm

Looks like a logfile at the wrong place and with a typo ("inclued"), is this php-logging (did you check all the logging paths in /etc/php5)?

Mark9117
Beginner
Posts: 20
Joined: Sat Mar 17, 2012 8:34 am

Re: Owncloud stops responding

Postby Mark9117 » Wed Dec 16, 2015 11:28 am

You'd think that typo would make this easy to find. So far it hasn't.

I have no /etc/php5, but I do have an /etc/php.d. It contains this:

Code: Select all

# ll
total 152
-rw-r--r-- 1 root   root      21 Nov 29 16:19 12_ctype.ini
-rw-r--r-- 1 root   root      20 Nov 29 16:19 13_curl.ini
-rw-r--r-- 1 root   root      19 Nov 29 16:19 18_dom.ini
-rw-r--r-- 1 root   root      23 Nov 29 16:19 21_openssl.ini
-rw-r--r-- 1 root   root      20 Nov 29 16:19 21_zlib.ini
-rw-r--r-- 1 root   root      19 Nov 29 16:19 22_ftp.ini
-rw-r--r-- 1 root   root      23 Nov 29 16:19 24_gettext.ini
-rw-r--r-- 1 root   root      21 Nov 29 16:19 26_iconv.ini
-rw-r--r-- 1 root   root      24 Nov 29 16:19 29_mbstring.ini
-rw-r--r-- 1 root   root      24 Nov 29 16:19 32_fileinfo.ini
-rw-r--r-- 1 root   root      23 Nov 29 16:19 33_mysqlnd.ini
-rw-r--r-- 1 root   root      21 Nov 29 16:19 36_mysql.ini
-rw-r--r-- 1 root   root      21 Nov 29 16:19 43_posix.ini
-rw-r--r-- 1 root   root      53 Nov 29 16:19 47_session.ini
-rw-r--r-- 1 root   root      20 Nov 29 16:19 54_hash.ini
-rw-r--r-- 1 root   root      23 Nov 29 16:19 57_sysvsem.ini
-rw-r--r-- 1 root   root      23 Nov 29 16:19 58_sysvshm.ini
-rw-r--r-- 1 root   root      25 Nov 29 16:19 60_tokenizer.ini
-rw-r--r-- 1 root   root      19 Nov 29 16:19 62_xml.ini
-rw-r--r-- 1 root   root      25 Nov 29 16:19 63_xmlreader.ini
-rw-r--r-- 1 root   root      25 Nov 29 16:19 64_xmlwriter.ini
-rw-r--r-- 1 root   root      22 Nov 29 16:19 66_bcmath.ini
-rw-r--r-- 1 root   root      19 Nov 29 16:19 70_pdo.ini
-rw-r--r-- 1 root   root      22 Nov 29 16:19 81_filter.ini
-rw-r--r-- 1 root   root      20 Nov 29 16:19 82_json.ini
-rw-r--r-- 1 root   root      26 Oct 29 08:21 A60_timezonedb.ini
-rw-r----- 1 apache apache   933 Oct 19  2014 B10_apm.ini
-rw-r--r-- 1 root   root   43806 Jan 31  2015 Z98_suhosin.ini


Grep'ing all those for "inclued" returns nothing:

Code: Select all

[root@spike php.d]# grep inclued *
[root@spike php.d]#


Same result grep'ing /etc/* for "inclued".

I'm still stumped, but thanks for the suggestion.

Mark

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Owncloud stops responding

Postby tflidd » Wed Dec 16, 2015 3:41 pm

I'm not sure if there is anything special about Mageia Linux or if you change a lot of settings before. In the latter case, it can take a lot of time to find the problem.
If it were only for owncloud, I would use a widely-used distribution.

Mark9117
Beginner
Posts: 20
Joined: Sat Mar 17, 2012 8:34 am

Re: Owncloud stops responding

Postby Mark9117 » Wed Dec 16, 2015 10:41 pm

tflidd wrote:I'm not sure if there is anything special about Mageia Linux or if you change a lot of settings before. In the latter case, it can take a lot of time to find the problem.
If it were only for owncloud, I would use a widely-used distribution.


Umm, tflidd, Mageia Linux IS a widely-used distribution. I don't think the whole world needs to be limited to Ubuntu or Mint. There is nothing special about Mageia Linux, and I haven't changed any configuration that involves php logging.

If nobody on the forum knows where this is coming from, that's fine. I will continue to poke around elsewhere to see what I can find.

In the meantime, thank you for the attention.

Mark


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.0 and 8.1”

Who is online

Users browsing this forum: No registered users and 5 guests