Fresh owncloud install, worked for a little then broke

Ask all your questions regarding OC 8.0 and 8.1 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
caffewmilk
Newbie
Posts: 1
Joined: Sat Apr 09, 2016 7:09 pm
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.9

Fresh owncloud install, worked for a little then broke

Postby caffewmilk » Sat Apr 09, 2016 8:42 pm

Hello,

I'm new here and new to using owncloud. I have already looked through the pinned "Known issues" thread.

Here is what happened:
1. I followed some online instructions on installing & configuring owncloud. Everything went well as far as that.
2. Using another computer on my network, I browsed to the owncloud server and was able to create the admin user and enter the database information. Shortly after, I was looking through the owncloud interface. So everything looked and worked great.
3. A few minutes later, after closing the browsing session, I tried to go back in and the only that displays on the browser is black page white page.
4. I rebooted the server thinking that apache service might have stopped running. Tried again and same blank page came up.
5. Interestingly, I tried from a different computer and received the familiar 'Untrusted Connection' in Firefox, added the exception as done on the previous computer, and instead of being greeted by the login screen, the blank page showed up again.

Server configuration
Operating system: Ubuntu 14.04.4 Server 64Bit
Web server: Apache 2
Database: MySQL
PHP version: 5.5.0
ownCloud version (see ownCloud admin page): can't see admin page so I got the version by looking at the installed package name: 8.1.6
Updated from an older ownCloud or fresh install: does not apply
ownCloud log (data/owncloud.log): {"reqId":"rkU36eABxgF4l39NX4ka","remoteAddr":"10.0.0.28","app":"PHP","message":"Undefined offset: 0 at \/var\/www\/owncloud\/lib\/private\/appframework\/http\/request.php#700","level":3,"time":"2016-04-09T02:07:33+00:00"}
{"reqId":"rkU36eABxgF4l39NX4ka","remoteAddr":"10.0.0.28","app":"PHP","message":"fopen(\/var\/www\/owncloud\/config\/config.php): failed to open stream: No such file or directory at \/var\/www\/owncloud\/lib\/private\/config.php#191","level":3,"time":"2016-04-09T02:07:33+00:00"}
{"reqId":"KY\/gCx7cAYuUyVRkCwxM","remoteAddr":"10.0.0.28","app":"PHP","message":"Undefined offset: 0 at \/var\/www\/owncloud\/lib\/private\/appframework\/http\/request.php#700","level":3,"time":"2016-04-09T02:08:56+00:00"}
{"reqId":"p6c+nwz+4ax5Rzb9tAvq","remoteAddr":"10.0.0.28","app":"PHP","message":"Argument 3 passed to OC\\Files\\Utils\\Scanner::__construct() must implement interface OCP\\ILogger, none given, called in \/var\/www\/owncloud\/apps\/files\/ajax\/scan.php on line 49 and defined at \/var\/www\/owncloud\/lib\/private\/files\/utils\/scanner.php#71","level":3,"time":"2016-04-09T02:09:07+00:00"}
{"reqId":"p6c+nwz+4ax5Rzb9tAvq","remoteAddr":"10.0.0.28","app":"PHP","message":"Undefined variable: logger at \/var\/www\/owncloud\/lib\/private\/files\/utils\/scanner.php#72","level":3,"time":"2016-04-09T02:09:07+00:00"}

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): no special config yet

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Fresh owncloud install, worked for a little then broke

Postby tflidd » Sun Apr 10, 2016 2:31 pm

This should not happen. There were some things fixed: https://github.com/owncloud/core/issues/15992
But there is probably not everything fixed, I had some problems connecting to the database: https://github.com/owncloud/core/issues/23744
If you already have a config/config.php, you can try to specify the socket to connect to your database:

Code: Select all

  'dbhost' => 'localhost:/var/run/mysqld/mysqld.sock',


It is possible that the other errors a triggered by this. If not, you can try and track them individually, like https://github.com/owncloud/core/issues/23062

How did you install it? Download zip-file, extract it, ...?


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.0 and 8.1”

Who is online

Users browsing this forum: No registered users and 2 guests