Unable to install ownCloud on my QNAP NAS

Ask all your questions regarding OC 8.0 and 8.1 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
sahilexe
Newbie
Posts: 1
Joined: Sun Jul 17, 2016 10:22 am

Unable to install ownCloud on my QNAP NAS

Postby sahilexe » Sun Jul 17, 2016 10:58 am

I am unable to install owncloud on my QNAP NAS. Every time I go through the first time configuration page, it does not complete. Please help me to troubleshoot so I can install fresh and start using awesome ownCloud on my NAS. By the way, it was working before. I somehow screwed up the installation by overwriting app directory while installing an addon for owncloud so I want to start fresh now, but unable to do so. Thanks in advance

Steps to reproduce
1. Removed the owncloud package completely
2. Deleted the MySQL database for owncloud and any traces of owncloud folder (if any)
3. re-installed the application from scratch - using QNAP App Store
4. Still the same behavior

Expected behavior
Expect to do a clean install of QNAP but it still fails, may be I'm missing something. Please help, i just want to start over and install fresh, but all in vain till now.

Actual behavior
Error in log file : \Web\owncloud\data\owncloud.log
{"reqId":"c62c7c423c63d19728c8aba502c32992","remoteAddr":"192.168.0.145","app":"PHP","message":"touch(): Unable to create file \/share\/MD0_DATA\/.qpkg\/owncloud\/owncloud\/data\/owncloud.log because No such file or directory at \/share\/MD0_DATA\/.qpkg\/owncloud\/owncloud\/lib\/private\/log\/owncloud.php#48","level":3,"time":"2016-07-17T08:07:22+00:00"}
{"reqId":"d6a0420c0a9a7f34f8791e369ce238b2","remoteAddr":"192.168.0.145","app":"core","message":"Login failed: 'admin' (Remote IP: '192.168.0.145', X-Forwarded-For: '')","level":2,"time":"2016-07-17T08:08:44+00:00"}
{"reqId":"d6a0420c0a9a7f34f8791e369ce238b2","remoteAddr":"192.168.0.145","app":"PHP","message":"PHP Startup: Unable to load dynamic library '\/usr\/local\/apache\/modules\/sqlite.so' - \/usr\/local\/apache\/modules\/sqlite.so: cannot open shared object file: No such file or directory at Unknown#0","level":3,"time":"2016-07-17T08:09:18+00:00"}

Out of box Permissions of owncloud folder when it gets installed:
lrwxrwxrwx 1 admin administ 39 Jul 17 13:34 owncloud -> /share/MD0_DATA/.qpkg/owncloud/owncloud/

also tried below commands to ensure permissions are right... but still no go.
chown -R httpdusr:administrators /share/MD0_DATA/Web/owncloud
chmod -R 770 /share/MD0_DATA/Web/owncloud

Server configuration
Note: All OS is what comes as part of QNAP TS212, Web Server also comes embedded. Qmariadb and ownCloud are what I installed as a QPKG available from QNAP AppStore
Operating system: Linux 3.4.6 armv5tel, (root@BuildServer45-1) (gcc version 4.2.1)
Web server: Apache/2.2.31 (Unix)
Database: qmariadb 5.5.44.002
PHP version: phpmyadmin 4.1.13.1
ownCloud version (see ownCloud admin page): v8.0.4
Updated from an older ownCloud or fresh install: NA
ownCloud log (data/owncloud.log): /share/MD0_DATA/Web/owncloud/data/owncloud.log

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
None

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Unable to install ownCloud on my QNAP NAS

Postby tflidd » Sun Jul 17, 2016 1:01 pm

You need the sqlite-module in your php:
PHP Startup: Unable to load dynamic library '\/usr\/local\/apache\/modules\/sqlite.so'

But do you want to install with sqlite or with mariadb? If possible, you should prefer mariadb. On manual installation, you get a screen where you can enter the type of database you want to use, I'm not sure how this works with QNAP-packages.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Unable to install ownCloud on my QNAP NAS

Postby RealRancor » Sun Jul 17, 2016 1:27 pm

Also be aware that oC 8.0.4 is quite outdated (released one year ago) and very likely unsupported. If you want to run the oC 8.0.x branch the current version 8.0.13 is the way to go.

If you still want to stick with the outdated QNAP package you might want to contact a QNAP community. They might have more knowledge about this system and their oC package.
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.0 and 8.1”

Who is online

Users browsing this forum: No registered users and 2 guests