"503 Service Unavailable" when downloading large files

Here we discuss issues with hosting partners regarding environment and special conditions. Pure adds will be removed.
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
eros23
Newbie
Posts: 6
Joined: Wed Nov 12, 2014 9:01 am
ownCloud version: 8.2.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5
Location: Reggio Calabria
Contact:

"503 Service Unavailable" when downloading large files

Postby eros23 » Tue Jul 19, 2016 3:47 pm

Hello, I also have installed owncloud of 1and1. The installation is successful.
everything works fine except when I download large files.
I give me a 503 error.
Sabre\DAV\Exception\ServiceUnavailable Could not open fil

Code: Select all

NetworkError: 503 Service Unavailable - https://www.XXXXX.it/remote.php/webdav/debian-8.5.0-amd64-DVD-1.iso?downloadStartSecret=ccd6jnlydog


Code: Select all

Content Security Policy: Il caricamento di una risorsa su self è stato bloccato dalle impostazioni della pagina (“script-src https://www.XXXXXX.it 'unsafe-eval'”).

onsubmit attribute on DIV element


Code: Select all

{"reqId":"V44stwouFoIAABbKQ04AAAAB","remoteAddr":"XXX.XXX.XXX.XXX","app":"webdav","message":"Exception: {\"Message\":\"HTTP\\\/1.1 503 Could not open file\",\"Exception\":\"Sabre\\\\DAV\\\\Exception\\\\ServiceUnavailable\",\"Code\":0,\"Trace\":\"#0 \\\/homepages\\\/39\\\/d605456248\\\/htdocs\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/CorePlugin.php(83): OCA\\\\DAV\\\\Connector\\\\Sabre\\\\File->get()\\n#1 [internal function]: Sabre\\\\DAV\\\\CorePlugin->httpGet(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#2 \\\/homepages\\\/39\\\/d605456248\\\/htdocs\\\/3rdparty\\\/sabre\\\/event\\\/lib\\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\\n#3 \\\/homepages\\\/39\\\/d605456248\\\/htdocs\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(459): Sabre\\\\Event\\\\EventEmitter->emit('method:GET', Array)\\n#4 \\\/homepages\\\/39\\\/d605456248\\\/htdocs\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(248): Sabre\\\\DAV\\\\Server->invokeMethod(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#5 \\\/homepages\\\/39\\\/d605456248\\\/htdocs\\\/apps\\\/dav\\\/appinfo\\\/v1\\\/webdav.php(55): Sabre\\\\DAV\\\\Server->exec()\\n#6 \\\/homepages\\\/39\\\/d605456248\\\/htdocs\\\/remote.php(138): require_once('\\\/homepages\\\/39\\\/d...')\\n#7 {main}\",\"File\":\"\\\/homepages\\\/39\\\/d605456248\\\/htdocs\\\/apps\\\/dav\\\/lib\\\/connector\\\/sabre\\\/file.php\",\"Line\":306,\"User\":\"admin\"}","level":4,"time":"2016-07-19T13:35:52+00:00","method":"GET","url":"\/remote.php\/webdav\/debian-8.5.0-amd64-DVD-1.iso?downloadStartSecret=ccd6jnlydog","user":"admin"}


this is my config.php

Code: Select all

<?php
$CONFIG = array (
  'instanceid' => 'ocX4evw7sfcq',
  'passwordsalt' => '9psjPSYtva8j2A1qlgxSo3FMUrUrRR',
  'secret' => 'lSLwUJXOMoVu0N2mvd6ebfCw+lu8JQh7Oi9Lu8FRbaMnszht',
  'trusted_domains' =>
  array (
    0 => 'www.XXXXXX.it',
  ),
  'datadirectory' => '/homepages/39/d605456248/htdocs/data',
  'overwrite.cli.url' => 'https://www.XXXXXX.it',
  'dbtype' => 'mysql',
  'version' => '9.0.1.3',
  'dbname' => 'XXXXX',
  'dbhost' => 'XXXXX.db.1and1.com',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'XXXXX',
  'dbpassword' => 'XXXXXX',
  'logtimezone' => 'UTC',
  'installed' => true,
  'loglevel' => 2,
  'mail_from_address' => 'owncloud',
  'mail_smtpmode' => 'php',
  'mail_domain' => 'XXXXXX.it',
  'ldapIgnoreNamingRules' => false,
);
?>


I accept any solution :)

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: "503 Service Unavailable" when downloading large files

Postby RealRancor » Tue Jul 19, 2016 4:55 pm

Please avoid hijacking threads with unrelated issues. Instead create a new thread for it. I've just splitted your post off from the original thread.

Additionally always use the latest available version before posting any issues. You're running 9.0.1 with some known bugs where 9.0.4 (released a few hours ago) is current.
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “Hosting area”

Who is online

Users browsing this forum: No registered users and 1 guest