Error upgrading from 8.1.3 - getLogger

Ask all your questions regarding OC 8.2 Please read the Support Forum Rules
Forum rules
The forums were migrated over to which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost: ... d-central/
Posts: 10
Joined: Fri Nov 20, 2015 10:52 am
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux Hosting Package
PHP version: 5.5.26

Error upgrading from 8.1.3 - getLogger

Postby webwude » Fri Nov 20, 2015 11:03 am

Dear all,

after asking around and still being stuck, I registered to hopefully get this sorted out.

Currently I am running 8.1.3 on a shared server ( hosting). I have no access to command line / to the general (apache) server logs. Since this version everything was fine - even upgrading (mostly with zip extraction and copying existing config file) went through each time.
Data directory is outside of installation directory.

Since 8.2 I failed to upgrade. Steps:
- disabling of third-party apps
- backup of existing owncloud installation directory (8.1.3)
- copying and extraction of 8.2 / 8.2.1 zip
- copying of existing (working) config file to config dir
- opening browser with base url

Each time I get this error right away:
Fatal error: Call to a member function getLogger() on a non-object in /<path of webdir>/owncloud/lib/public/util.php on line 166

I tried it with the installer - it installed fine - but after finish and proceeding I get the same error.

I am running out of ideas... what can I do? Any hint is highly appreciated.
Thx and best regards

ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Error upgrading from 8.1.3 - getLogger

Postby RealRancor » Fri Nov 20, 2015 11:09 am


seems you need to wait for oC 9.0 to get a fix for this:

Posts: 54
Joined: Thu May 05, 2016 1:38 pm

Re: Error upgrading from 8.1.3 - getLogger

Postby kwoxer » Sun Jun 05, 2016 8:38 am

You need to set the rights correctly.

I had the same issue.

I just did chown www-data. And now works properly.

  • Similar Topics
    Last post

Return to “ownCloud Server 8.2”

Who is online

Users browsing this forum: No registered users and 1 guest