CentOS 7.2 with CPanel: Dependency issues

Ask all your questions regarding OC 8.2 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
mtimyself
Newbie
Posts: 2
Joined: Fri Dec 18, 2015 8:35 pm
ownCloud version: 8.2.1
OS: Linux
PHP version: 5.5.30

CentOS 7.2 with CPanel: Dependency issues

Postby mtimyself » Fri Dec 18, 2015 9:01 pm

apache version: 2.4.16
php version: 5.5.30

I have recently aquired a CentOS 7.2 server and as my first course of action I have installed the latest [WHM 11.52.1 (build 3)] version of CPanel on it.
Now, when I try and install Owncloud in the recommended (OBS repo) fashion I am met with a bunch of dependency issues. I am unfortunately rather new to the entire CPanel thing (and using Linux in general) so I am, even after extensive google'ing, rather stuck.
I will now dump the log of missing dependencies and hope that this can be resolved as I imagine it to be a rather common circumstance (installing Owncloud on a CPanel enabled server).

Code: Select all

# yum install owncloud
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centosmirror.netcup.net
 * epel: mirrors.n-ix.net
 * extras: centosmirror.netcup.net
 * updates: centosmirror.netcup.net
Resolving Dependencies
--> Running transaction check
---> Package owncloud.noarch 0:8.2.1-1.1 will be installed
--> Processing Dependency: owncloud-server = 8.2.1 for package: owncloud-8.2.1-1.1.noarch
--> Processing Dependency: owncloud-config-apache = 8.2.1 for package: owncloud-8.2.1-1.1.noarch
--> Running transaction check
---> Package owncloud-config-apache.noarch 0:8.2.1-1.1 will be installed
--> Processing Dependency: httpd for package: owncloud-config-apache-8.2.1-1.1.noarch
---> Package owncloud-server.noarch 0:8.2.1-1.1 will be installed
--> Processing Dependency: php >= 5.4.0 for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-zip for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-posix for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-gd for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-mbstring for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-pdo for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: policycoreutils-python for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-json for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-ldap for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-xml for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-process for package: owncloud-server-8.2.1-1.1.noarch
--> Running transaction check
---> Package owncloud-config-apache.noarch 0:8.2.1-1.1 will be installed
--> Processing Dependency: httpd for package: owncloud-config-apache-8.2.1-1.1.noarch
---> Package owncloud-server.noarch 0:8.2.1-1.1 will be installed
--> Processing Dependency: php >= 5.4.0 for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-zip for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-posix for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-gd for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-mbstring for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-pdo for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-json for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-ldap for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-xml for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-process for package: owncloud-server-8.2.1-1.1.noarch
---> Package policycoreutils-python.x86_64 0:2.2.5-20.el7 will be installed
--> Processing Dependency: libsemanage-python >= 2.1.10-1 for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: audit-libs-python >= 2.1.3-4 for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: python-IPy for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: libselinux-python for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: libcgroup for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: checkpolicy for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: policycoreutils-python-2.2.5-20.el7.x86_64
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.4.1-5.el7 will be installed
---> Package checkpolicy.x86_64 0:2.1.12-6.el7 will be installed
---> Package libcgroup.x86_64 0:0.41-8.el7 will be installed
---> Package libselinux-python.x86_64 0:2.2.2-6.el7 will be installed
---> Package libsemanage-python.x86_64 0:2.1.10-18.el7 will be installed
---> Package owncloud-config-apache.noarch 0:8.2.1-1.1 will be installed
--> Processing Dependency: httpd for package: owncloud-config-apache-8.2.1-1.1.noarch
---> Package owncloud-server.noarch 0:8.2.1-1.1 will be installed
--> Processing Dependency: php >= 5.4.0 for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-zip for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-posix for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-gd for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-mbstring for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-pdo for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-json for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-ldap for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-xml for package: owncloud-server-8.2.1-1.1.noarch
--> Processing Dependency: php-process for package: owncloud-server-8.2.1-1.1.noarch
---> Package python-IPy.noarch 0:0.75-6.el7 will be installed
---> Package setools-libs.x86_64 0:3.3.7-46.el7 will be installed
--> Finished Dependency Resolution
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-process
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-mbstring
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-zip
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-gd
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-xml
Error: Package: owncloud-config-apache-8.2.1-1.1.noarch (ce_stable)
           Requires: httpd
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-ldap
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-posix
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php >= 5.4.0
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-json
Error: Package: owncloud-server-8.2.1-1.1.noarch (ce_stable)
           Requires: php-pdo
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: CentOS 7.2 with CPanel: Dependency issues

Postby tflidd » Sun Dec 20, 2015 12:16 pm

I'm not sure if using the packages and a administration panel is such a good idea, they will both interact with the webserver configuration. In this case, it's perhaps better to do a manual install.

I can't directly help you with the dependencies, the manager proposes:
You could try using --skip-broken to work around the problem

amadeus
Newbie
Posts: 1
Joined: Wed Jan 27, 2016 10:47 pm
PHP version: 5.5

Re: CentOS 7.2 with CPanel: Dependency issues

Postby amadeus » Wed Jan 27, 2016 10:50 pm

You have to remove php* and httpd* from the exlude-line in /etc/yum.conf.
After that, you can retry the installation.

Code: Select all

vi /etc/yum.conf

goldfish_23
Newbie
Posts: 1
Joined: Wed Feb 10, 2016 3:00 pm
ownCloud version: 8.2.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5

Re: CentOS 7.2 with CPanel: Dependency issues

Postby goldfish_23 » Wed Feb 10, 2016 3:19 pm

Experiencing the same problem.

There may be an influx of new users due to the discontinuation of Copy and CudaDrive services by Barracuda Networks.

I'd intended to experiment with OwnCloud for years but Copy disappearing finally encouraged me to make the jump!

Hello everyone!

The software looks lush. The experience of attempting to install it so far hasn't been. I'm also worried by the suggestion that it won't sit nicely alongside cPanel.


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.2”

Who is online

Users browsing this forum: No registered users and 1 guest