Max upload size at 2MB

Ask all your questions regarding OC 8.2 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
marsden_pete
Beginner
Posts: 15
Joined: Tue Feb 23, 2016 12:09 pm
ownCloud version: 8.1.5
Webserver: Apache
Database: MySQL
OS: Linux

Max upload size at 2MB

Postby marsden_pete » Tue Mar 01, 2016 3:21 pm

im having the same problem except both my setting at 2G, when i change in the admin page it keeps reverting back to 2Mb which i cant seem to change.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Max upload size

Postby RealRancor » Tue Mar 01, 2016 3:23 pm

Please follow the already posted links above.
*gone*

marsden_pete
Beginner
Posts: 15
Joined: Tue Feb 23, 2016 12:09 pm
ownCloud version: 8.1.5
Webserver: Apache
Database: MySQL
OS: Linux

Re: Max upload size

Postby marsden_pete » Tue Mar 01, 2016 3:29 pm

I've just changed the PHP.ini

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 2M

To


;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
; http://php.net/file-uploads
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
; http://php.net/upload-tmp-dir
;upload_tmp_dir =

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 2G

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 20

But still getting exceeds upload limit.

As soon as i log out and back it it resets the limit back to 2MB

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Max upload size

Postby RealRancor » Tue Mar 01, 2016 3:31 pm

Again, please read both documentations. Very unlikely that you have done this in the short amount of time.
*gone*

marsden_pete
Beginner
Posts: 15
Joined: Tue Feb 23, 2016 12:09 pm
ownCloud version: 8.1.5
Webserver: Apache
Database: MySQL
OS: Linux

Re: Max upload size

Postby marsden_pete » Tue Mar 01, 2016 3:33 pm

ive read through both documents several times this morning.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Max upload size

Postby RealRancor » Tue Mar 01, 2016 3:33 pm

Hi,

you definitely havn't done this. The posted config shows that as you only have raised the upload_max_filesize where there are several other config options needs to be upped.
*gone*

marsden_pete
Beginner
Posts: 15
Joined: Tue Feb 23, 2016 12:09 pm
ownCloud version: 8.1.5
Webserver: Apache
Database: MySQL
OS: Linux

Re: Max upload size

Postby marsden_pete » Tue Mar 01, 2016 3:36 pm

im sorry but what should i have changed? sending links and saying follow this isnt really helpful when people are asking for some help, Everyone has different levels of expertise when it comes to linux

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Max upload size

Postby RealRancor » Tue Mar 01, 2016 3:38 pm

post_max_size for example
*gone*

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Max upload size at 2MB

Postby RealRancor » Tue Mar 01, 2016 3:40 pm

Also have splitted your posts off the original thread. Those are two different issues here.
*gone*

marsden_pete
Beginner
Posts: 15
Joined: Tue Feb 23, 2016 12:09 pm
ownCloud version: 8.1.5
Webserver: Apache
Database: MySQL
OS: Linux

Re: Max upload size at 2MB

Postby marsden_pete » Tue Mar 01, 2016 3:51 pm

ok in the .htaccess file i have

<IfModule mod_php5.c>
php_value upload_max_filesize 2G
php_value post_max_size 2G
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value always_populate_raw_post_data -1
php_value default_charset 'UTF-8'
php_value output_buffering 0
<IfModule mod_env.c>
SetEnv htaccessWorking true
</IfModule>

in the .user.ini
upload_max_filesize=2G
post_max_size=2G
memory_limit=512M
mbstring.func_overload=0
always_populate_raw_post_data=-1
default_charset='UTF-8'
output_buffering=0

php.ini

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
; http://php.net/file-uploads
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
; http://php.net/upload-tmp-dir
;upload_tmp_dir =

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 2G

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 20

when i log out and back into the admin control panel it changes back from 2GB to 2MB


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.2”

Who is online

Users browsing this forum: No registered users and 1 guest