Upgrade Issues - Yum Update

Ask all your questions regarding OC 8.2 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
Speedy059
Newbie
Posts: 1
Joined: Mon May 02, 2016 11:09 pm
OS: Linux

Upgrade Issues - Yum Update

Postby Speedy059 » Mon May 02, 2016 11:20 pm

I'm having issues trying to fix this yum error. Any ideas how I can fix the repository? I would like to upgrade owncloud, i'm not sure how these repo errors got here in the first place :(.

Steps to reproduce
yum update

Expected behaviour
It should update the packages.

Actual behaviour
Lots of repo mismatches

Server configuration
Operating system: CentOS release 6.7 (Final)
Web server: Apache 2.4 Worker
Database: MySQL
PHP version: PHP 5.6.19
ownCloud version (see ownCloud admin page): ownCloud 8.2.3 (stable)
Updated from an older ownCloud or fresh install: Trying to update



Here is the yum update error. I apologize if this is long, i'm not sure what the best way is to show this?

Code: Select all

[root@owncloud yum.repos.d]# yum update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.fusioncloud.co
 * epel: mirror.chpc.utah.edu
 * extras: centos.sonn.com
 * remi: mirrors.mediatemple.net
 * remi-php56: mirrors.mediatemple.net
 * remi-safe: mirrors.mediatemple.net
 * updates: mirror.nexcess.net
Resolving Dependencies
--> Running transaction check
---> Package libtalloc.x86_64 0:2.0.7-2.el6 will be updated
---> Package libtalloc.x86_64 0:2.1.5-1.el6_7 will be an update
---> Package libtdb.x86_64 0:1.2.10-1.el6 will be updated
---> Package libtdb.x86_64 0:1.3.8-1.el6_7 will be an update
---> Package libtevent.x86_64 0:0.9.18-3.el6 will be updated
---> Package libtevent.x86_64 0:0.9.26-2.el6_7 will be an update
---> Package mysql.x86_64 0:5.5.48-1.el6.remi will be updated
---> Package mysql.x86_64 0:5.5.49-1.el6.remi will be an update
---> Package mysql-libs.x86_64 0:5.5.48-1.el6.remi will be updated
---> Package mysql-libs.x86_64 0:5.5.49-1.el6.remi will be an update
---> Package mysql-server.x86_64 0:5.5.48-1.el6.remi will be updated
---> Package mysql-server.x86_64 0:5.5.49-1.el6.remi will be an update
---> Package nspr.x86_64 0:4.10.8-2.el6_7 will be updated
---> Package nspr.x86_64 0:4.11.0-0.1.el6_7 will be an update
---> Package nss.x86_64 0:3.19.1-8.el6_7 will be updated
---> Package nss.x86_64 0:3.21.0-0.3.el6_7 will be an update
---> Package nss-sysinit.x86_64 0:3.19.1-8.el6_7 will be updated
---> Package nss-sysinit.x86_64 0:3.21.0-0.3.el6_7 will be an update
---> Package nss-tools.x86_64 0:3.19.1-8.el6_7 will be updated
---> Package nss-tools.x86_64 0:3.21.0-0.3.el6_7 will be an update
---> Package nss-util.x86_64 0:3.19.1-5.el6_7 will be updated
---> Package nss-util.x86_64 0:3.21.0-0.3.el6_7 will be an update
---> Package owncloud.noarch 0:8.2.3-2.1 will be updated
---> Package owncloud.noarch 0:8.2.3-5.el6.remi will be an update
--> Processing Dependency: owncloud-webserver = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
Package owncloud-httpd-8.2.3-5.el6.remi.noarch is obsoleted by owncloud-config-apache-8.2.3-2.1.noarch which is already installed
--> Processing Dependency: owncloud-database = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/yaml) < 3.0.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(sabre/dav) < 2.2 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(pimple/pimple) < 4.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(phpseclib/phpseclib) < 3.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(patchwork/utf8) < 2.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(patchwork/jsqueeze) < 3.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(nikic/php-parser) < 2.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(kriswallsmith/assetic) < 2.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(ircmaxell/random-lib) < 2.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(guzzlehttp/guzzle) < 6.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/dbal) < 2.6 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-pecl(smbclient) >= 0.8.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-opencloud >= 1.9.2 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-google-apiclient >= 1.0.3 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/yaml) >= 2.6.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/routing) >= 2.6.4 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/process) >= 2.6.4 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/event-dispatcher) >= 2.6.4 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/console) >= 2.6.4 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(swiftmailer/swiftmailer) >= 5.4.1 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(sabre/dav) >= 2.1.9 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(punic/punic) >= 1.1.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(pimple/pimple) >= 3.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(phpseclib/phpseclib) >= 2.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(patchwork/utf8) >= 1.1 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(patchwork/jsqueeze) >= 2.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(owncloud/tarstreamer) >= 0.1 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(nikic/php-parser) >= 1.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(natxet/CssMin) >= 3.0.2 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(mcnetic/zipstreamer) >= 0.7 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(league/flysystem) >= 1.0.4 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(kriswallsmith/assetic) >= 1.3 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(jeremeamia/superclosure) >= 2.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(ircmaxell/random-lib) >= 1.1 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(ircmaxell/password-compat) >= 1.0.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(interfasys/lognormalizer) >= 1.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(icewind/streams) >= 0.2 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(icewind/smb) >= 1.0.4 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(guzzlehttp/guzzle) >= 5.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/dbal) >= 2.5.1 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(bantu/ini-get-wrapper) >= 1.0.1 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-aws-sdk >= 2.7.0 for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-pear(pear.dropbox-php.com/Dropbox) for package: owncloud-8.2.3-5.el6.remi.noarch
--> Processing Dependency: php-composer(james-heinrich/getid3) for package: owncloud-8.2.3-5.el6.remi.noarch
---> Package php.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-cli.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-cli.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-common.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-gd.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-gd.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-ldap.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-ldap.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-mbstring.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-mbstring.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-mysqlnd.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-mysqlnd.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-pdo.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-pdo.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-process.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-process.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php-xml.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php56-php-cli.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php56-php-cli.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php56-php-common.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php56-php-common.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php56-php-process.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php56-php-process.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package php56-php-xml.x86_64 0:5.6.19-1.el6.remi will be updated
---> Package php56-php-xml.x86_64 0:5.6.21-1.el6.remi will be an update
---> Package samba.x86_64 0:3.6.23-25.el6_7 will be updated
---> Package samba.x86_64 0:3.6.23-30.el6_7 will be an update
---> Package samba-client.x86_64 0:3.6.23-25.el6_7 will be updated
---> Package samba-client.x86_64 0:3.6.23-30.el6_7 will be an update
---> Package samba-common.x86_64 0:3.6.23-25.el6_7 will be updated
---> Package samba-common.x86_64 0:3.6.23-30.el6_7 will be an update
---> Package samba-winbind.x86_64 0:3.6.23-25.el6_7 will be updated
---> Package samba-winbind.x86_64 0:3.6.23-30.el6_7 will be an update
---> Package samba-winbind-clients.x86_64 0:3.6.23-25.el6_7 will be updated
---> Package samba-winbind-clients.x86_64 0:3.6.23-30.el6_7 will be an update
---> Package tzdata.noarch 0:2016c-1.el6 will be updated
---> Package tzdata.noarch 0:2016d-1.el6 will be an update
---> Package tzdata-java.noarch 0:2016c-1.el6 will be updated
---> Package tzdata-java.noarch 0:2016d-1.el6 will be an update
--> Running transaction check
---> Package owncloud.noarch 0:8.2.3-5.el6.remi will be an update
--> Processing Dependency: owncloud-webserver = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
Package owncloud-httpd-8.2.3-5.el6.remi.noarch is obsoleted by owncloud-config-apache-8.2.3-2.1.noarch which is already installed
---> Package owncloud-mysql.noarch 0:8.2.3-5.el6.remi will be installed
---> Package php-Assetic.noarch 0:1.3.2-3.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/class-loader) for package: php-Assetic-1.3.2-3.el6.remi.noarch
---> Package php-PHPParser.noarch 0:1.4.1-1.el6.remi will be installed
---> Package php-aws-sdk.noarch 0:2.8.29-1.el6.remi will be installed
--> Processing Dependency: php-composer(guzzle/guzzle) < 4.0 for package: php-aws-sdk-2.8.29-1.el6.remi.noarch
--> Processing Dependency: php-composer(guzzle/guzzle) >= 3.9.3 for package: php-aws-sdk-2.8.29-1.el6.remi.noarch
---> Package php-bantu-ini-get-wrapper.noarch 0:1.0.1-1.el6.remi will be installed
---> Package php-doctrine-dbal.noarch 0:2.5.4-1.el6.remi will be installed
--> Processing Dependency: php-composer(doctrine/common) < 2.7 for package: php-doctrine-dbal-2.5.4-1.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/common) >= 2.5.0 for package: php-doctrine-dbal-2.5.4-1.el6.remi.noarch
---> Package php-dropbox-php-Dropbox.noarch 0:1.0.0-4.el6.remi will be installed
--> Processing Dependency: php-pecl(oauth) for package: php-dropbox-php-Dropbox-1.0.0-4.el6.remi.noarch
--> Processing Dependency: php-pear(HTTP_OAuth) for package: php-dropbox-php-Dropbox-1.0.0-4.el6.remi.noarch
--> Processing Dependency: php-channel(pear.dropbox-php.com) for package: php-dropbox-php-Dropbox-1.0.0-4.el6.remi.noarch
---> Package php-getid3.noarch 1:1.9.12-1.el6.remi will be installed
---> Package php-google-apiclient.noarch 0:1.1.5-1.el6.remi will be installed
---> Package php-guzzlehttp-guzzle.noarch 0:5.3.0-4.el6.remi will be installed
--> Processing Dependency: php-composer(guzzlehttp/ringphp) < 2.0 for package: php-guzzlehttp-guzzle-5.3.0-4.el6.remi.noarch
--> Processing Dependency: php-guzzlehttp-ringphp >= 1.1.0-6 for package: php-guzzlehttp-guzzle-5.3.0-4.el6.remi.noarch
---> Package php-icewind-smb.noarch 0:1.0.8-1.el6.remi will be installed
---> Package php-icewind-streams.noarch 0:0.4.0-1.el6.remi will be installed
---> Package php-interfasys-lognormalizer.noarch 0:1.0-1.el6.remi will be installed
---> Package php-ircmaxell-random-lib.noarch 0:1.1.0-3.el6.remi will be installed
--> Processing Dependency: php-ircmaxell-security-lib >= 1.1.0-3 for package: php-ircmaxell-random-lib-1.1.0-3.el6.remi.noarch
--> Processing Dependency: php-composer(ircmaxell/security-lib) >= 1.0 for package: php-ircmaxell-random-lib-1.1.0-3.el6.remi.noarch
---> Package php-jeremeamia-superclosure.noarch 0:2.2.0-1.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/polyfill-php56) < 2 for package: php-jeremeamia-superclosure-2.2.0-1.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/polyfill-php56) >= 1.0 for package: php-jeremeamia-superclosure-2.2.0-1.el6.remi.noarch
---> Package php-league-flysystem.noarch 0:1.0.22-1.el6.remi will be installed
---> Package php-mcnetic-zipstreamer.noarch 1:1.0-1.el6.remi will be installed
--> Processing Dependency: php-pecl(pecl_http) for package: 1:php-mcnetic-zipstreamer-1.0-1.el6.remi.noarch
---> Package php-natxet-cssmin.noarch 0:3.0.4-2.el6.remi will be installed
---> Package php-opencloud.noarch 0:1.12.2-1.el6.remi will be installed
--> Processing Dependency: php-composer(psr/log) < 2.0 for package: php-opencloud-1.12.2-1.el6.remi.noarch
--> Processing Dependency: php-PsrLog >= 1.0.0-8 for package: php-opencloud-1.12.2-1.el6.remi.noarch
---> Package php-owncloud-tarstreamer.noarch 0:0.1.0-1.el6.remi will be installed
---> Package php-password-compat.noarch 0:1.0.4-1.el6.remi will be installed
---> Package php-patchwork-jsqueeze.noarch 0:2.0.3-1.el6.remi will be installed
---> Package php-patchwork-utf8.noarch 0:1.2.5-1.el6.remi will be installed
--> Processing Dependency: php-intl for package: php-patchwork-utf8-1.2.5-1.el6.remi.noarch
---> Package php-phpseclib.noarch 0:2.0.1-1.el6.remi will be installed
--> Processing Dependency: php-gmp for package: php-phpseclib-2.0.1-1.el6.remi.noarch
--> Processing Dependency: php-bcmath for package: php-phpseclib-2.0.1-1.el6.remi.noarch
---> Package php-pimple-lib.noarch 0:3.0.2-1.el6.remi.5.6 will be installed
---> Package php-punic.noarch 0:1.6.3-1.el6.remi will be installed
---> Package php-sabre-dav.noarch 0:2.1.10-1.el6.remi will be installed
--> Processing Dependency: php-composer(sabre/vobject) < 4 for package: php-sabre-dav-2.1.10-1.el6.remi.noarch
--> Processing Dependency: php-composer(sabre/http) < 3.1 for package: php-sabre-dav-2.1.10-1.el6.remi.noarch
--> Processing Dependency: php-composer(sabre/event) < 2.1 for package: php-sabre-dav-2.1.10-1.el6.remi.noarch
--> Processing Dependency: php-composer(sabre/vobject) >= 3.3.4 for package: php-sabre-dav-2.1.10-1.el6.remi.noarch
--> Processing Dependency: php-composer(sabre/http) >= 3.0.0 for package: php-sabre-dav-2.1.10-1.el6.remi.noarch
--> Processing Dependency: php-composer(sabre/event) >= 2.0.0 for package: php-sabre-dav-2.1.10-1.el6.remi.noarch
---> Package php-smbclient.x86_64 0:0.8.0-1.el6.remi.5.6 will be installed
--> Processing Dependency: libsmbclient.so.0()(64bit) for package: php-smbclient-0.8.0-1.el6.remi.5.6.x86_64
---> Package php-swiftmailer.noarch 0:5.4.2-1.el6.remi will be installed
--> Processing Dependency: php-mcrypt for package: php-swiftmailer-5.4.2-1.el6.remi.noarch
---> Package php-symfony-console.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-event-dispatcher.noarch 0:2.7.12-2.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/http-kernel) = 2.7.12 for package: php-symfony-event-dispatcher-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/dependency-injection) = 2.7.12 for package: php-symfony-event-dispatcher-2.7.12-2.el6.remi.noarch
---> Package php-symfony-process.noarch 0:2.7.12-2.el6.remi will be installed
--> Processing Dependency: php-symfony-common = 2.7.12-2.el6.remi for package: php-symfony-process-2.7.12-2.el6.remi.noarch
---> Package php-symfony-routing.noarch 0:2.7.12-2.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/http-foundation) = 2.7.12 for package: php-symfony-routing-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/expression-language) = 2.7.12 for package: php-symfony-routing-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/config) = 2.7.12 for package: php-symfony-routing-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/annotations) < 2.0 for package: php-symfony-routing-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/annotations) >= 1.0 for package: php-symfony-routing-2.7.12-2.el6.remi.noarch
---> Package php-symfony-yaml.noarch 0:2.7.12-2.el6.remi will be installed
--> Running transaction check
---> Package libsmbclient.x86_64 0:3.6.23-30.el6_7 will be installed
---> Package owncloud.noarch 0:8.2.3-5.el6.remi will be an update
--> Processing Dependency: owncloud-webserver = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
Package owncloud-httpd-8.2.3-5.el6.remi.noarch is obsoleted by owncloud-config-apache-8.2.3-2.1.noarch which is already installed
---> Package php-PsrLog.noarch 0:1.0.0-9.el6.remi will be installed
---> Package php-bcmath.x86_64 0:5.6.21-1.el6.remi will be installed
---> Package php-channel-dropbox-php.noarch 0:1.3-3.el6.remi will be installed
---> Package php-doctrine-annotations.noarch 0:1.2.7-1.el6.remi will be installed
--> Processing Dependency: php-composer(doctrine/lexer) < 2.0 for package: php-doctrine-annotations-1.2.7-1.el6.remi.noarch
--> Processing Dependency: php-doctrine-lexer >= 1.0.1-4 for package: php-doctrine-annotations-1.2.7-1.el6.remi.noarch
---> Package php-doctrine-common.noarch 0:2.5.0-1.el6.remi will be installed
--> Processing Dependency: php-composer(doctrine/inflector) < 2.0 for package: php-doctrine-common-2.5.0-1.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/collections) < 2.0 for package: php-doctrine-common-2.5.0-1.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/cache) < 2.0 for package: php-doctrine-common-2.5.0-1.el6.remi.noarch
--> Processing Dependency: php-doctrine-inflector >= 1.0.1-4 for package: php-doctrine-common-2.5.0-1.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/collections) >= 1.3.0 for package: php-doctrine-common-2.5.0-1.el6.remi.noarch
--> Processing Dependency: php-composer(doctrine/cache) >= 1.4.1 for package: php-doctrine-common-2.5.0-1.el6.remi.noarch
---> Package php-gmp.x86_64 0:5.6.21-1.el6.remi will be installed
---> Package php-guzzle-Guzzle.noarch 0:3.9.3-9.el6.remi will be installed
---> Package php-guzzlehttp-ringphp.noarch 0:1.1.0-6.el6.remi will be installed
--> Processing Dependency: php-composer(react/promise) < 3.0 for package: php-guzzlehttp-ringphp-1.1.0-6.el6.remi.noarch
--> Processing Dependency: php-composer(guzzlehttp/streams) < 4.0 for package: php-guzzlehttp-ringphp-1.1.0-6.el6.remi.noarch
--> Processing Dependency: php-react-promise >= 2.2.0-6 for package: php-guzzlehttp-ringphp-1.1.0-6.el6.remi.noarch
--> Processing Dependency: php-guzzlehttp-streams >= 3.0.0-5 for package: php-guzzlehttp-ringphp-1.1.0-6.el6.remi.noarch
---> Package php-intl.x86_64 0:5.6.21-1.el6.remi will be installed
--> Processing Dependency: libicuuc.so.50()(64bit) for package: php-intl-5.6.21-1.el6.remi.x86_64
--> Processing Dependency: libicuio.so.50()(64bit) for package: php-intl-5.6.21-1.el6.remi.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: php-intl-5.6.21-1.el6.remi.x86_64
--> Processing Dependency: libicudata.so.50()(64bit) for package: php-intl-5.6.21-1.el6.remi.x86_64
---> Package php-ircmaxell-security-lib.noarch 0:1.1.0-4.el6.remi will be installed
---> Package php-mcrypt.x86_64 0:5.6.21-1.el6.remi will be installed
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt-5.6.21-1.el6.remi.x86_64
--> Processing Dependency: libltdl.so.7()(64bit) for package: php-mcrypt-5.6.21-1.el6.remi.x86_64
---> Package php-pear-HTTP-OAuth.noarch 0:0.3.2-1.el6.remi will be installed
--> Processing Dependency: php-pear(HTTP_Request2) >= 0.5.1 for package: php-pear-HTTP-OAuth-0.3.2-1.el6.remi.noarch
--> Processing Dependency: php-pear(Log) for package: php-pear-HTTP-OAuth-0.3.2-1.el6.remi.noarch
--> Processing Dependency: php-pear(Cache_Lite) for package: php-pear-HTTP-OAuth-0.3.2-1.el6.remi.noarch
---> Package php-pecl-http.x86_64 0:2.5.6-1.el6.remi.5.6 will be installed
--> Processing Dependency: php-pecl(raphf)(x86-64) >= 1.1.0 for package: php-pecl-http-2.5.6-1.el6.remi.5.6.x86_64
--> Processing Dependency: php-pecl(propro)(x86-64) >= 1.0.0 for package: php-pecl-http-2.5.6-1.el6.remi.5.6.x86_64
--> Processing Dependency: php-pecl(json_post)(x86-64) for package: php-pecl-http-2.5.6-1.el6.remi.5.6.x86_64
--> Processing Dependency: php-pecl(apfd)(x86-64) for package: php-pecl-http-2.5.6-1.el6.remi.5.6.x86_64
--> Processing Dependency: libevent-2.0.so.5()(64bit) for package: php-pecl-http-2.5.6-1.el6.remi.5.6.x86_64
---> Package php-pecl-oauth.x86_64 0:1.2.3-9.el6.remi.5.6 will be installed
---> Package php-sabre-event.noarch 0:2.0.2-1.el6.remi will be installed
---> Package php-sabre-http.noarch 0:3.0.5-1.el6.remi will be installed
---> Package php-sabre-vobject.noarch 0:3.5.2-1.el6.remi will be installed
---> Package php-symfony-class-loader.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-common.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-config.noarch 0:2.7.12-2.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/filesystem) = 2.7.12 for package: php-symfony-config-2.7.12-2.el6.remi.noarch
---> Package php-symfony-dependency-injection.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-expression-language.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-http-foundation.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-http-kernel.noarch 0:2.7.12-2.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/var-dumper) = 2.7.12 for package: php-symfony-http-kernel-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/finder) = 2.7.12 for package: php-symfony-http-kernel-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/debug) = 2.7.12 for package: php-symfony-http-kernel-2.7.12-2.el6.remi.noarch
--> Processing Dependency: php-composer(symfony/browser-kit) = 2.7.12 for package: php-symfony-http-kernel-2.7.12-2.el6.remi.noarch
---> Package php-symfony-polyfill.noarch 0:1.1.1-1.el6.remi will be installed
--> Processing Dependency: php-composer(paragonie/random_compat) for package: php-symfony-polyfill-1.1.1-1.el6.remi.noarch
--> Running transaction check
---> Package libevent-last.x86_64 0:2.0.22-1.el6.remi will be installed
---> Package libicu-last.x86_64 0:50.1.2-11.el6.remi will be installed
---> Package libmcrypt.x86_64 0:2.5.8-9.el6 will be installed
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package owncloud.noarch 0:8.2.3-5.el6.remi will be an update
--> Processing Dependency: owncloud-webserver = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
Package owncloud-httpd-8.2.3-5.el6.remi.noarch is obsoleted by owncloud-config-apache-8.2.3-2.1.noarch which is already installed
---> Package php-doctrine-cache.noarch 0:1.5.4-1.el6.remi will be installed
---> Package php-doctrine-collections.noarch 0:1.3.0-3.el6.remi will be installed
---> Package php-doctrine-inflector.noarch 0:1.1.0-1.el6.remi will be installed
---> Package php-doctrine-lexer.noarch 0:1.0.1-5.el6.remi will be installed
---> Package php-guzzlehttp-streams.noarch 0:3.0.0-6.el6.remi will be installed
---> Package php-paragonie-random-compat.noarch 0:1.4.1-1.el6.remi will be installed
---> Package php-pear-Cache-Lite.noarch 0:1.7.16-1.el6.remi will be installed
---> Package php-pear-HTTP-Request2.noarch 0:2.3.0-1.el6.remi will be installed
--> Processing Dependency: php-pear(Net_URL2) >= 2.2.0 for package: php-pear-HTTP-Request2-2.3.0-1.el6.remi.noarch
---> Package php-pear-Log.noarch 0:1.13.1-1.el6.remi will be installed
--> Processing Dependency: php-pear(DB) >= 1.3 for package: php-pear-Log-1.13.1-1.el6.remi.noarch
--> Processing Dependency: php-pear(Mail) for package: php-pear-Log-1.13.1-1.el6.remi.noarch
---> Package php-pecl-apfd.x86_64 0:1.0.1-1.el6.remi.5.6 will be installed
---> Package php-pecl-json-post.x86_64 0:1.0.1-1.el6.remi.5.6 will be installed
---> Package php-pecl-propro.x86_64 0:1.0.2-1.el6.remi.5.6 will be installed
---> Package php-pecl-raphf.x86_64 0:1.1.2-1.el6.remi.5.6 will be installed
---> Package php-react-promise.noarch 0:2.4.0-1.el6.remi will be installed
---> Package php-symfony-browser-kit.noarch 0:2.7.12-2.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/dom-crawler) = 2.7.12 for package: php-symfony-browser-kit-2.7.12-2.el6.remi.noarch
---> Package php-symfony-debug.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-filesystem.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-finder.noarch 0:2.7.12-2.el6.remi will be installed
---> Package php-symfony-var-dumper.noarch 0:2.7.12-2.el6.remi will be installed
--> Running transaction check
---> Package owncloud.noarch 0:8.2.3-5.el6.remi will be an update
--> Processing Dependency: owncloud-webserver = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
Package owncloud-httpd-8.2.3-5.el6.remi.noarch is obsoleted by owncloud-config-apache-8.2.3-2.1.noarch which is already installed
---> Package php-pear-DB.noarch 0:1.9.2-1.el6.remi will be installed
---> Package php-pear-Mail.noarch 0:1.3.0-1.el6.remi will be installed
--> Processing Dependency: php-pear(Net_SMTP) >= 1.4.1 for package: php-pear-Mail-1.3.0-1.el6.remi.noarch
---> Package php-pear-Net-URL2.noarch 0:2.2.1-1.el6.remi will be installed
---> Package php-symfony-dom-crawler.noarch 0:2.7.12-2.el6.remi will be installed
--> Processing Dependency: php-composer(symfony/css-selector) = 2.7.12 for package: php-symfony-dom-crawler-2.7.12-2.el6.remi.noarch
--> Running transaction check
---> Package owncloud.noarch 0:8.2.3-5.el6.remi will be an update
--> Processing Dependency: owncloud-webserver = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
Package owncloud-httpd-8.2.3-5.el6.remi.noarch is obsoleted by owncloud-config-apache-8.2.3-2.1.noarch which is already installed
---> Package php-pear-Net-SMTP.noarch 0:1.7.1-1.el6.remi will be installed
--> Processing Dependency: php-pear(Net_Socket) for package: php-pear-Net-SMTP-1.7.1-1.el6.remi.noarch
--> Processing Dependency: php-pear(Auth_SASL) for package: php-pear-Net-SMTP-1.7.1-1.el6.remi.noarch
---> Package php-symfony-css-selector.noarch 0:2.7.12-2.el6.remi will be installed
--> Running transaction check
---> Package owncloud.noarch 0:8.2.3-5.el6.remi will be an update
--> Processing Dependency: owncloud-webserver = 8.2.3-5.el6.remi for package: owncloud-8.2.3-5.el6.remi.noarch
Package owncloud-httpd-8.2.3-5.el6.remi.noarch is obsoleted by owncloud-config-apache-8.2.3-2.1.noarch which is already installed
---> Package php-pear-Auth-SASL.noarch 0:1.0.6-1.el6.remi will be installed
---> Package php-pear-Net-Socket.noarch 0:1.0.14-1.el6.remi will be installed
--> Finished Dependency Resolution
Error: Package: owncloud-8.2.3-5.el6.remi.noarch (remi)
           Requires: owncloud-webserver = 8.2.3-5.el6.remi
           Available: owncloud-httpd-7.0.13-1.el6.noarch (epel)
               owncloud-webserver = 7.0.13-1.el6
           Available: owncloud-httpd-8.2.3-4.el6.remi.noarch (remi)
               owncloud-webserver = 8.2.3-4.el6.remi
           Available: owncloud-httpd-8.2.3-5.el6.remi.noarch (remi)
               owncloud-webserver = 8.2.3-5.el6.remi
           Available: owncloud-nginx-7.0.13-1.el6.noarch (epel)
               owncloud-webserver = 7.0.13-1.el6
           Available: owncloud-nginx-8.2.3-4.el6.remi.noarch (remi)
               owncloud-webserver = 8.2.3-4.el6.remi
           Available: owncloud-nginx-8.2.3-5.el6.remi.noarch (remi)
               owncloud-webserver = 8.2.3-5.el6.remi
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upgrade Issues - Yum Update

Postby RealRancor » Mon May 02, 2016 11:25 pm

Hi,

question about dependency issues are often better asked at a forums / community dedicated to your distro. There you can reach more people having the knowledge to solve this kind of issue.

The issue itself is caused by conflicts between the official oC repos and the packages provided by your used "remi" repos. You probably need to see if you can somehow manage to exclude /not use the ownCloud packages provided by that repos.
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.2”

Who is online

Users browsing this forum: No registered users and 2 guests