Upload huge file via web [SOVED]

Ask all your questions regarding OC 8.2 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
sirio81
Beginner
Posts: 40
Joined: Tue Aug 07, 2012 10:56 am

Upload huge file via web [SOVED]

Postby sirio81 » Mon Jul 18, 2016 12:34 pm

I'm trying to setup owncloud in a way that it allows the upload of huge file (i.e. 4G or more).

Steps to reproduce
- Upload a file of 1G

Expected behaviour
- The upload should complete

Actual behaviour
- Web interface shows internal server error
- On onwcloud file list there's not the file I was trying to upload or its size is partial
- On /var/log/apache2/error.log I get

Code: Select all

mod_fcgid: process 51583 graceful kill fail, sending SIGKILL


Server configuration
Operating system: ubuntu 14.04
Web server: apache2
Database: mysql
PHP version: 5.5
ownCloud version (see ownCloud admin page): 8.2.6
Updated from an older ownCloud or fresh install: 8.1.x
ownCloud log (data/owncloud.log): nothing to show

I changed my .user.ini like this:

Code: Select all

upload_max_filesize=10G
post_max_size=10G
memory_limit=512M
mbstring.func_overload=0
always_populate_raw_post_data=-1
default_charset='UTF-8'
output_buffering=off
php_value upload_max_filesize = 10G
php_value post_max_size = 10G
php_value max_input_time -1
php_value max_execution_time -1
Last edited by sirio81 on Mon Jul 18, 2016 3:09 pm, edited 1 time in total.

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upload huge file via web

Postby RealRancor » Mon Jul 18, 2016 12:42 pm

Hi,

try to switch to the only officially supported mod_php and also upgrade to a newer PHP version. The release announcement of PHP 5.6 for example lists:

File uploads larger than 2 gigabytes in size are now accepted.


https://secure.php.net/releases/5_6_0.php

Such upload stuff are handled within PHP and if a fcgid process is failing its a sign that there is something broken or buggy in PHP itself. Normally there is nothing what can be done from oC side except the suggestion to use the sync client.

*Edit*

Ah, and those are wrong and probably ignored by your webserver:

Code: Select all

php_value upload_max_filesize = 10G
php_value post_max_size = 10G
php_value max_input_time -1
php_value max_execution_time -1


The PHP .user.ini has no php_value options appended to the config options.
*gone*

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Upload huge file via web

Postby RealRancor » Mon Jul 18, 2016 1:07 pm

Sorry, forgot to mention (besided the edits above):

You might want to dig deeper into your logfiles (not only the apache log, maybe fcpid is logging different) which could lead to some addition hints about this issue.
*gone*

sirio81
Beginner
Posts: 40
Joined: Tue Aug 07, 2012 10:56 am

Re: Upload huge file via web

Postby sirio81 » Mon Jul 18, 2016 3:08 pm

Thank you very much for the precious advices.
I tested the same owncloud version on my laptop: debian 8 and I was able to upload 10G of file.

A side note that I found interesting: to upload a 10G file you need at least 20G free on your /tmp because owncloud doesn't move the uploaded file but it copies it.
So during the copy it will use 20G.


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.2”

Who is online

Users browsing this forum: No registered users and 1 guest