upgrade to 9.0 and memcached issues

Ask all your questions regarding OC 9.0 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
ruud68
Beginner
Posts: 32
Joined: Wed Mar 06, 2013 5:16 pm
ownCloud version: 4.5.7
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.8

upgrade to 9.0 and memcached issues

Postby ruud68 » Thu Mar 10, 2016 10:34 am

Environment: Apache/2.4.7 (Ubuntu) | apache2handler
Server: ubuntu server 14.04.1
Database: mysql 5.5.47-0ubuntu0.14.04.1
Client: Firefox 44.0.2
OC-Version: ownCloud 9.0.0 (stable)
PHP-Version: 5.5.9-1ubuntu4.14

Hi, yesterday did an upgrade from version 8.2.2 (latest) to version 9.0 via ubuntu apt-get update && at-get upgrade.
The occ upgrade process gave an erro 16 -> memcache error and stopt the upgrade.
I removed all memcached setting form config.php and started the upgade process. This time it went thru without errors and I am currently on version 9.0

When I re-add the memcached settings (the same settings it was for version 8.2.2) I get memcached errors when downloading e.g. files via the webinterface or when trying to download a shared directory (the zip file is only 2.3kb big)

There where no changes to my server / php / memcached / etc. settings.
I cannot find any clues as to what to do to troubleshoot and solve these issues. not using memcache makes my owncloud *very* slow :(

this is the error I get, hope somebody can shed a light on this.

-----------------
Error no app in context Exception: {"Exception":"Exception","Message":"Error 14 interacting with memcached : NOT STORED","Code":0,"Trace":"#0 \/var\/www\/owncloud\/lib\/private\/memcache\/memcached.php(130): OC\\Memcache\\Memcached->verifyReturnCode()\n#1 \/var\/www\/owncloud\/lib\/private\/memcache\/memcached.php(142): OC\\Memcache\\Memcached->add('files\/f514b38fb...', 0)\n#2 \/var\/www\/owncloud\/lib\/private\/lock\/memcachelockingprovider.php(70): OC\\Memcache\\Memcached->inc('files\/f514b38fb...')\n#3 \/var\/www\/owncloud\/lib\/private\/files\/storage\/common.php(663): OC\\Lock\\MemcacheLockingProvider->acquireLock('files\/f514b38fb...', 1)\n#4 \/var\/www\/owncloud\/lib\/private\/files\/storage\/wrapper\/wrapper.php(577): OC\\Files\\Storage\\Common->acquireLock('files\/Notebook\/...', 1, Object(OC\\Lock\\MemcacheLockingProvider))\n#5 \/var\/www\/owncloud\/lib\/private\/files\/view.php(1850): OC\\Files\\Storage\\Wrapper\\Wrapper->acquireLock('files\/Notebook\/...', 1, Object(OC\\Lock\\MemcacheLockingProvider))\n#6 \/var\/www\/owncloud\/lib\/private\/files\/view.php(1952): OC\\Files\\View->lockPath('\/Notebook\/Docum...', 1, false)\n#7 \/var\/www\/owncloud\/lib\/private\/files\/view.php(1045): OC\\Files\\View->lockFile('\/Notebook\/Docum...', 1)\n#8 \/var\/www\/owncloud\/lib\/private\/files\/view.php(905): OC\\Files\\View->basicOperation('fopen', '\/Notebook\/Docum...', Array, 'rb')\n#9 \/var\/www\/owncloud\/lib\/private\/files\/view.php(409): OC\\Files\\View->fopen('\/Notebook\/Docum...', 'rb')\n#10 \/var\/www\/owncloud\/lib\/private\/files.php(184): OC\\Files\\View->readfile('\/Notebook\/Docum...')\n#11 \/var\/www\/owncloud\/lib\/private\/files.php(89): OC_Files::getSingleFile(Object(OC\\Files\\View), '\/Notebook\/Docum...', '20160229 Gemeen...', false)\n#12 \/var\/www\/owncloud\/apps\/files_sharing\/lib\/controllers\/sharecontroller.php(485): OC_Files::get('\/Notebook\/Docum...', Array, false)\n#13 [internal function]: OCA\\Files_Sharing\\Controllers\\ShareController->downloadShare('yHrtfrvVf6qBNrz', '20160229 Gemeen...', '\/', '')\n#14 \/var\/www\/owncloud\/lib\/private\/appframework\/http\/dispatcher.php(159): call_user_func_array(Array, Array)\n#15 \/var\/www\/owncloud\/lib\/private\/appframework\/http\/dispatcher.php(89): OC\\AppFramework\\Http\\Dispatcher->executeController(Object(OCA\\Files_Sharing\\Controllers\\ShareController), 'downloadShare')\n#16 \/var\/www\/owncloud\/lib\/private\/appframework\/app.php(110): OC\\AppFramework\\Http\\Dispatcher->dispatch(Object(OCA\\Files_Sharing\\Controllers\\ShareController), 'downloadShare')\n#17 \/var\/www\/owncloud\/lib\/public\/appframework\/app.php(134): OC\\AppFramework\\App::main('ShareController', 'downloadShare', Object(OC\\AppFramework\\DependencyInjection\\DIContainer))\n#18 \/var\/www\/owncloud\/core\/routes.php(124): OCP\\AppFramework\\App->dispatch('ShareController', 'downloadShare')\n#19 [internal function]: OC\\Route\\Router->{closure}(Array)\n#20 \/var\/www\/owncloud\/lib\/private\/route\/router.php(273): call_user_func(Object(Closure), Array)\n#21 \/var\/www\/owncloud\/lib\/base.php(873): OC\\Route\\Router->match('\/s\/yHrtfrvVf6qB...')\n#22 \/var\/www\/owncloud\/index.php(39): OC::handleRequest()\n#23 {main}","File":"\/var\/www\/owncloud\/lib\/private\/memcache\/memcached.php","Line":174} 2016-03-10T08:23:04+00:00

this is what I have in my config:
------
<?php
$CONFIG = array (
'overwritewebroot' => '/owncloud',
'overwrite.cli.url' => '/owncloud',
'instanceid' => '253542345235234',
'passwordsalt' => '235423553434',
'datadirectory' => '/var/owncloud/data',
'dbtype' => 'mysql',
'version' => '9.0.0.19',
'dbname' => 'owncloud',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'dbuser' => 'owncloud',
'dbpassword' => 'verysecret',
'memcache.local' => '\\OC\\Memcache\\APCu',
'memcache.distributed' => '\\OC\\Memcache\\Memcached',
'memcached_servers' =>
array (
0 =>
array (
0 => 'localhost',
1 => 11211,
),
),
'filelocking.enabled' => 'true',
'memcache.locking' => '\\OC\\Memcache\\Memcached',
'installed' => true,
'ldapIgnoreNamingRules' => false,
'loglevel' => 0,
'maintenance' => false,
'theme' => '',
'trusted_domains' =>
array (
0 => '192.168.1.0',
1 => '192.168.1.201',
2 => 'office.mydomain.nl',
3 => 'office.mydomain.nl',
),
'secret' => '52545443534435',
'forcessl' => true,
'forceSSLforSubdomains' => true,
'mail_from_address' => 'owncloud',
'mail_smtpmode' => 'php',
'mail_domain' => 'mydomain.nl',
'logfile' => '/var/log/owncloud.log',
'asset-pipeline.enabled' => true,
'updatechecker' => false,
);

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: upgrade to 9.0 and memcached issues

Postby RealRancor » Thu Mar 10, 2016 10:51 am

Hi,

its not an solution for the memcache issue itself but have you considered moving to redis which is the recommended way for distributed caching:

https://doc.owncloud.org/server/9.0/adm ... deployment

Furthermore the memcache.distributed is only needed if you have a clustered setup as seen there.
*gone*

ruud68
Beginner
Posts: 32
Joined: Wed Mar 06, 2013 5:16 pm
ownCloud version: 4.5.7
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.8

Re: upgrade to 9.0 and memcached issues

Postby ruud68 » Thu Mar 10, 2016 11:19 am

Hi Thanks for thinking along.
I have now disabled memcached and I am running on apcu only.
Will look into redis, but as I already am using memcached also for other services on the server this needs some digging :)

What is bogging me is that in 8.2.2 it worked but now it doesn't although nothing has changed (other then owncoud version)...

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: upgrade to 9.0 and memcached issues

Postby RealRancor » Thu Mar 10, 2016 11:34 am

Hi,

the "Error 14 interacting with memcached : NOT STORED" message doesn't look right so you can also report that to the developers if that wasn't shown in oC 8.2
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 9.0”

Who is online

Users browsing this forum: No registered users and 2 guests