No more CalDAV, CardDAV, but WebDAV working

Ask all your questions regarding OC 9.0 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
LarryX
Beginner
Posts: 40
Joined: Thu Jul 10, 2014 5:25 am
Webserver: Apache
Database: MySQL
OS: Linux

No more CalDAV, CardDAV, but WebDAV working

Postby LarryX » Wed Mar 16, 2016 2:09 pm

On a fresh install of 9.0, recommended openSuSE packages, I can't get Card/CalDAV clients to work. WebDAV works. OC web GUI works flawlessly, too. OC 8.2 was running fine on this server. Also, no warnings on the admin page.

Clients: All kinds of, Evolution, Akonadi, Android CardDAV-sync, DAVDroid.
Server: Custom port, subfolder installation (had to manually adjust the trusted domains in config.php to get the installation done).

Pointing a web browser to the different potential URLs gives either a 404, or, promising but unfortunately not correct, the text that I should use a DAV client to access this URL.

E.g.:
https://Server:port/ -> DAV Text (because of well-known redirect)
https://Server:port/drawer/remote.php/caldav -> Error (this is the old URL I have configured all my clients to, is this deprecated?!)
https://Server:port/drawer/remote.php/dav -> DAV text

When pointing a DAV client at the seemingly working URLs with the DAV text, only blank lists are returned. That means no entries are found here.

OC gives me only the real long URLs in the GUI for the calendars etc., including "principal" and stuff, but these URLs don't work at all, 404 or 405.

I'm quite at a loss where to look, it seems that the calendars etc. are simply not published via DAV, but why? I know the FAQ here, but the solutions there don't seem to apply (8.2 was working!).

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: No more CalDAV, CardDAV, but WebDAV working

Postby RealRancor » Wed Mar 16, 2016 2:24 pm

Hi,

for such stuff you should check your logfiles on the server. Currently no one can guess why it "just not work".

There are also plenty of issues about CalDAV and CardDAV issues reported at the bugtracker. Try to see if one of the already existing issues are matching your issue.
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 9.0”

Who is online

Users browsing this forum: No registered users and 4 guests