Have to add index.php to URL, or else Internal Server Error

Ask all your questions regarding OC 9.0 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
schnyd
Beginner
Posts: 13
Joined: Fri Mar 18, 2016 11:01 pm
ownCloud version: 9.0.0
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 7

Have to add index.php to URL, or else Internal Server Error

Postby schnyd » Fri Mar 18, 2016 11:11 pm

After using OC 8.2 for a while without problems, I now installed a fresh OC9. But suddenly I have to add the /index.php to reach my site. And after I log out, the site automatically switches to sub.domain.tld instead of the sub.domain.tld/index.php. So there allways is the Internal Server Error after logout.
To make things clear: It is a fresh install, nothing to do with the (still installed and running) OC8 I used untill yesterday (and still am, as long as this index.php error haunts me :lol: )

Steps to reproduce
1. installed fresh OC 9


Expected behaviour
After installing, I would be able to see the login screen using sub.domain.tld

Actual behaviour
After installation there was an Internal Server Error. After adding the /index.php to my URL, everything worked fine. And, wafter logout, Internal Server Error again (I think because of the still missing index.php)

Server configuration
Operating system: Linux
Web server: Apache
Database: MariaDB
PHP version: 7
ownCloud version (see ownCloud admin page): 9
Updated from an older ownCloud or fresh install: fresh
ownCloud log (data/owncloud.log):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): none


Thank you for any help!

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: Have to add index.php to URL, or else Internal Server Error

Postby tflidd » Fri Mar 18, 2016 11:21 pm

The error with the index.php is a problem with the rewriting rules in the .htaccess-file, you can remove this line manually:
https://github.com/owncloud/core/pull/23029/files

If you still have this internal-server error, you need to check the error-logfile of your webserver.

schnyd
Beginner
Posts: 13
Joined: Fri Mar 18, 2016 11:01 pm
ownCloud version: 9.0.0
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 7

Re: Have to add index.php to URL, or else Internal Server Error

Postby schnyd » Fri Mar 18, 2016 11:27 pm

tflidd wrote:The error with the index.php is a problem with the rewriting rules in the .htaccess-file, you can remove this line manually:
https://github.com/owncloud/core/pull/23029/files

If you still have this internal-server error, you need to check the error-logfile of your webserver.


Oh man, thank you very much. I already tried editing the htaccess, but, as it seems, I edited it the wrong way. It works, thanks!

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Have to add index.php to URL, or else Internal Server Error

Postby RealRancor » Sat Mar 19, 2016 12:54 am

This is also listed here as a known issue: viewtopic.php?f=38&t=33274
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 9.0”

Who is online

Users browsing this forum: No registered users and 1 guest