Owncloud HTTPS problem

Ask all your questions regarding OC 9.0 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
mailo95
Newbie
Posts: 3
Joined: Fri Jun 17, 2016 4:31 pm
ownCloud version: 9.0.2
Webserver: Apache
OS: Linux

Owncloud HTTPS problem

Postby mailo95 » Mon Jul 18, 2016 5:49 pm

Please help us by providing the following info. Before posting please also check the pinned "Known issues" thread.

Steps to reproduce
1.I read the owncloud manual
2.and i watched this video https://www.youtube.com/watch?v=fgOTvPSC-rg but no success

Expected behaviour
Access owncloud via https.

Actual behaviour
When ssl is disabled and try to connect via http redirects me to https://http//xxx.xxx.xxx.xxx/owncloud (same when i try only http://xxx.xxx.xxx.xxx without /owncloud)and when i thy via http://xxx.xxx.xxx.xxx/owncloud shows This site can’t be reached.
Before i try to enable the https when i type my ip opens apache page and then try my ip with /owncloud opens owncloud homepage but when i try with https show this side can't be reached.
Server configuration
Operating system:Linux Mint last updates
Web server:Apache
ownCloud version (see ownCloud admin page):
Updated from an older ownCloud or fresh install: Fresh

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Owncloud HTTPS problem

Postby RealRancor » Mon Jul 18, 2016 8:29 pm

Hi,

ownCloud itself is not providing any HTTPS so its the best to ask how to correctly setup your environment at either a Linux Minut forums or a community like http://www.apachelounge.com/
*gone*

mailo95
Newbie
Posts: 3
Joined: Fri Jun 17, 2016 4:31 pm
ownCloud version: 9.0.2
Webserver: Apache
OS: Linux

Re: Owncloud HTTPS problem

Postby mailo95 » Tue Jul 19, 2016 2:22 pm

Why y cant help me here this is owncloud problem i just need to conf https redirection in owncloud ?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Owncloud HTTPS problem

Postby RealRancor » Tue Jul 19, 2016 2:28 pm

You can't redirect to HTTPS in ownCloud. This needs to be configured within your webserver. And for such webserver specific topics its advised to ask at a community like described above.

The reason for this is easy: Most environments have different defaults, config files and setups so they have more knowledge about their specific environments as most people in the ownCloud forums.
*gone*

mcdaniels
Newbie
Posts: 3
Joined: Wed Jul 13, 2016 11:08 am
ownCloud version: 9.0.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.6.22

Re: Owncloud HTTPS problem

Postby mcdaniels » Tue Jul 19, 2016 3:14 pm

@TO: You can find a description of how it can be done here for example:
https://www.digitalocean.com/community/ ... untu-14-04


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 9.0”

Who is online

Users browsing this forum: No registered users and 1 guest