Nginx + php-fpm: "Call to a member function getLogger() on null"

Ask all your questions regarding OC 9.0 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
theced7
Newbie
Posts: 7
Joined: Sat Oct 26, 2013 3:08 pm
ownCloud version: 6.0.2
Webserver: Apache
Database: PostgreSQL
OS: Linux
PHP version: 5.4

Nginx + php-fpm: "Call to a member function getLogger() on null"

Postby theced7 » Tue Jul 19, 2016 6:50 pm

I'm trying to get Owncloud up and running with Nginx after using it for quite some time with Apache. I've used the official config:

Code: Select all

upstream php-handler {
 #  server 127.0.0.1:9000;
    server unix:/var/run/php5-fpm.sock;
}

server {
  listen 80;
  server_name jumpingcrab.com;
  # enforce https
  return 301 https://$server_name$request_uri;
}

server {
  listen 443 ssl;
  server_name jumpingcrab.com;

  ssl_certificate /etc/letsencrypt/live/jumpingcrab.com/fullchain.pem;
  ssl_certificate_key /etc/letsencrypt/live/jumpingcrab.com/privkey.pem;

  # Path to the root of your installation
  root /var/www/html;
  # set max upload size
  client_max_body_size 10G;
  fastcgi_buffers 64 4K;

  # Disable gzip to avoid the removal of the ETag header
  gzip off;

  # Uncomment if your server is build with the ngx_pagespeed module
  # This module is currently not supported.
  #pagespeed off;

  rewrite ^/caldav(.*)$ /remote.php/caldav$1 redirect;
  rewrite ^/carddav(.*)$ /remote.php/carddav$1 redirect;
  rewrite ^/webdav(.*)$ /remote.php/webdav$1 redirect;

  index index.php;
  error_page 403 /core/templates/403.php;
  error_page 404 /core/templates/404.php;

  location = /robots.txt {
    allow all;
    log_not_found off;
    access_log off;
  }

  location ~ ^/(?:\.htaccess|data|config|db_structure\.xml|README){
    deny all;
  }

  location / {
    # The following 2 rules are only needed with webfinger
    rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
    rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json last;

    rewrite ^/.well-known/carddav /remote.php/carddav/ redirect;
    rewrite ^/.well-known/caldav /remote.php/caldav/ redirect;

    rewrite ^(/core/doc/[^\/]+/)$ $1/index.html;

    try_files $uri $uri/ =404;
  }

  location ~ \.php(?:$|/) {
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
    fastcgi_param HTTPS on;
    fastcgi_pass php-handler;
    fastcgi_intercept_errors on;
  }

  # Adding the cache control header for js and css files
  # Make sure it is BELOW the location ~ \.php(?:$|/) { block
  location ~* \.(?:css|js)$ {
    add_header Cache-Control "public, max-age=7200";
    # Add headers to serve security related headers
    add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
    add_header X-Content-Type-Options nosniff;
    add_header X-Frame-Options "SAMEORIGIN";
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    # Optional: Don't log access to assets
    access_log off;
  }

  # Optional: Don't log access to other assets
  location ~* \.(?:jpg|jpeg|gif|bmp|ico|png|swf)$ {
    access_log off;
  }
}


The owncloud directory sits in /var/www/html/owncloud, however, when I'm trying to open mydomain.com/owncloud all I get is a 500 error. Acessing a index.php with <?php phpinfo(); ?> works fine.

Code: Select all

tail /var/log/nginx/error.log
PHP message: PHP Fatal error:  Call to a member function getLogger() on null in /var/www/html/owncloud/lib/public/util.php on line 154" while reading response header from upstream, client: MYIP, server: jumpingcrab.com, request: "GET /owncloud/status.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "jumpingcrab.com"


Any idea what causes this issue? Do I need to do some configuration in php5-fpm?

Server configuration
Operating system: Debian 8.5
Web server: Nginx
Database: MySQL
PHP version: 5.6
Updated from an older ownCloud or fresh install: updated
ownCloud log (data/owncloud.log):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Nginx + php-fpm: "Call to a member function getLogger() on null"

Postby RealRancor » Tue Jul 19, 2016 10:09 pm

Hi,

try the one for oC 9 which is different then the one you're using:

https://doc.owncloud.org/server/9.0/adm ... ud_9x.html

If you still get the same error you can have a search for the error at the bugtracker:

https://github.com/owncloud/core/issues

where you might get additional infos about it.
*gone*

theced7
Newbie
Posts: 7
Joined: Sat Oct 26, 2013 3:08 pm
ownCloud version: 6.0.2
Webserver: Apache
Database: PostgreSQL
OS: Linux
PHP version: 5.4

Re: Nginx + php-fpm: "Call to a member function getLogger() on null"

Postby theced7 » Tue Jul 19, 2016 11:03 pm

Sadly, this doesn't change anything. :(

Any further ideas? I'm sure I'm not the only one running owncloud on nginx?

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Nginx + php-fpm: "Call to a member function getLogger() on null"

Postby RealRancor » Wed Jul 20, 2016 9:28 am

RealRancor wrote:If you still get the same error you can have a search for the error at the bugtracker:

https://github.com/owncloud/core/issues

where you might get additional infos about it.
*gone*


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 9.0”

Who is online

Users browsing this forum: No registered users and 1 guest