Skeleton ignored?

Ask all your questions regarding OC 9.0 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
User avatar
arbor-inc
Newbie
Posts: 1
Joined: Wed Jul 20, 2016 2:04 pm
ownCloud version: 9.0.2
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 7.0.7

Skeleton ignored?

Postby arbor-inc » Wed Jul 20, 2016 4:27 pm

Please help us by providing the following info. Before posting please also check the pinned "Known issues" thread.

Steps to reproduce
1. added 'skeletondirectory' => '/var/www/html/owncloud/core/skeleton', in config.php. I have also tried putting the skeleton directory in a different location ('themes' dir) and reflected that change in config.php
2. created a new user and logged in to see if "documents" and "photos" dirs existed
3. Ran 'strong perms' script as suggested in: https://doc.owncloud.org/server/9.0/admin_manual/installation/installation_wizard.html#strong-perms-label


Expected behaviour
expected to see "my documents" or "documents"; "photos" directories in the "files" view.

Actual behaviour
no "my documents" or "documents"; "photos" directories in the "files" view.

Server configuration
Operating system: CentOS 6.8 (64-bit)
Web server: Apache/2.2.15
Database: 5.5.50-cll-lve MySQL Community Server
PHP version: 7.0.7
ownCloud version (see ownCloud admin page): 9.0.3 stable
Updated from an older ownCloud or fresh install: fresh install, restored data.
ownCloud log (data/owncloud.log):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

The 'data' dir is on /data (right at root), with the following perms:
drwxrwx---. 121 apache apache 12K Jul 20 09:57 data

the new user directory:
drwxr-xr-x 4 apache apache 4.0K Jul 20 09:58 jean.doe
and inside the 'jean.doe' dir:
[*****@cloud9 jean.doe]# ls -lh
total 8.0K
drwxr-xr-x 2 apache apache 4.0K Jul 20 09:58 cache
drwxr-xr-x 3 apache apache 4.0K Jul 20 09:57 files
...and inside 'files':
[*****@cloud9 jean.doe]# ls -lh files/
total 4.0K
drwxr-xr-x 2 apache apache 4.0K Jul 20 09:57 Shared

However,
an existing user (running on oC 6.0.2 'skeleton' seems to be working there)
drwxr-xr-x. 4 apache apache 4.0K Mar 17 2015 tech
...and:
[*****@cloud9 tech]# ls -lh
total 8.0K
drwxr-x--- 2 apache apache 4.0K Mar 30 19:13 cache
drwxr-xr-x. 4 apache apache 4.0K Mar 17 2015 files
...and:
[*****@cloud9 tech]# ls -lh files/
total 8.0K
drwxr-xr-x. 2 apache apache 4.0K Mar 17 2015 My Documents
drwxr-x--- 2 apache apache 4.0K Mar 30 19:13 Shared


no 'my documents' for the new user (jean.doe).

Any idea anyone...?
thx ahead,
/DL

  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 9.0”

Who is online

Users browsing this forum: No registered users and 1 guest