CardDAV & CalDAV not working on Blackberry Z10

You found a bug or you're missing a major feature? Just ask and discuss
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
Duncan Mac Leod
Newbie
Posts: 1
Joined: Sun Mar 17, 2013 4:38 pm
ownCloud version: 4.5.7
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3

CardDAV & CalDAV not working on Blackberry Z10

Postby Duncan Mac Leod » Sun Mar 17, 2013 5:05 pm

The new Blackberry Z10 has built-in CardDAV & CalDAV support.

However, the Authentication procedure with OwnCloud fails. It seems that the Z10 uses an E-Mail Address to authenticate with these Services.

For CardDAV & CalDAV you can provide the following settings:

Description: ...
Username: ...

E-Mail-Address: ...
Password: ...

Server-URL: ...

The field E-Mail-Address MUST HAVE an email-address, so I cannot fill in my Username there :cry: !

Is it possible for your Dev-Team to provide a special URL for Blackberry users, which handles this, like you did for the iPhone users? Maybe, you can use the Owncloud E-Mail address for password recovery to check against during logon, instead of using the Username :mrgreen: ! Okay, it's a workaround, but it will be fine for me. I desperately need CardDAV & CalDAV sync!

Would be great - Thank you in advance!

Regards,
Duncan.

thron
Newbie
Posts: 1
Joined: Sun Mar 31, 2013 12:11 am
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby thron » Sun Mar 31, 2013 12:16 am

Hi,

I was able to get my Z10 to sync with my owncloud server.

For the calendar I used the "Calendar URL" that you can get by looking at the Calendar options.

I used my primary email for this calendar as it is my main calendar.

Regards,

W

Doc Rob
Newbie
Posts: 1
Joined: Sun Mar 31, 2013 10:47 am
ownCloud version: 4.5.8
Webserver: Apache
Database: MySQL
OS: Linux Hosting Package
PHP version: 5.4.9

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby Doc Rob » Sun Mar 31, 2013 10:53 am

Hi all,
can anybody able the CardDAV sync? CalDAV works...

Regards,

Doc

gusch5
Newbie
Posts: 5
Joined: Sun Mar 31, 2013 4:07 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby gusch5 » Sun Mar 31, 2013 4:25 pm

I wasn't able to sync - neither CardDav nor CalDav :(

I tried for calendar

Code: Select all

https://ADDRESS/owncloud/remote.php/caldav/calendars/USERNAME/defaultcalendar
https://ADDRESS/owncloud/apps/calendar/caldav.php/


And for contacts

Code: Select all

https://ADDRESS/owncloud/remote.php/carddav/addressbooks/USERNAME/contacts
https://ADDRESS/owncloud/apps/contacts/carddav.php/


Syncing works for KDE kontcat, my iPad and in OSX.

gusch5
Newbie
Posts: 5
Joined: Sun Mar 31, 2013 4:07 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby gusch5 » Sun Mar 31, 2013 5:54 pm

Meanwhile I upgraded my Z10 to 10.0.10.99 (from 10.0.10.90).

Now at least caldav works using

Code: Select all

https://ADDRESS/owncloud/apps/calendar/caldav.php/


But CardDav still refuses to work :(

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby RandolphCarter » Sun Mar 31, 2013 8:58 pm

But CardDav still refuses to work

With such little information we unfortunately can't help you. Please provide any error messages you might get, if not, webserver access/error log and/or ownCloud log...

gusch5
Newbie
Posts: 5
Joined: Sun Mar 31, 2013 4:07 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby gusch5 » Sun Mar 31, 2013 11:54 pm

Somehow I don't get any log message?!?

When not using "https://" I at least can confirm the SSL certificate.

But here a web page I found:
http://www.ruinelli.ch/synchronize-the- ... h-owncloud
Which basically points to
http://www.progweb.com/en/2012/05/playb ... -le-cloud/
And there a some modifications for owncloud used there (I didn't test them yet)
http://www.progweb.com/gitweb/?p=owncloud.git;a=summary

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby RandolphCarter » Mon Apr 01, 2013 10:55 am

Somehow I don't get any log message?!?

Have you checked the acess log of your webserver? If you don't get anything in there, then your Blackberry isn't even talking to ownCloud 8-)

When not using "https://" I at least can confirm the SSL certificate.

I don't understand that. How you you verify anything SSL-related via not using https?

gusch5
Newbie
Posts: 5
Joined: Sun Mar 31, 2013 4:07 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: MySQL
OS: Linux

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby gusch5 » Mon Apr 01, 2013 12:10 pm

For the "https://"-thing - that's a Z10 behaviour. It uses https on it's own (described in in the first link I added).

I now found a log entry in the access log (non in the owncloud.log or errors log):
IP_ADDRESS - USER [01/Apr/2013:11:51:18 +0200] "PROPFIND / HTTP/1.1" 200 1807
IP_ADDRESS - USER [01/Apr/2013:11:51:19 +0200] "PROPFIND / HTTP/1.1" 200 1807
IP_ADDRESS - USER [01/Apr/2013:11:51:20 +0200] "PROPFIND / HTTP/1.1" 200 1807
IP_ADDRESS - USER [01/Apr/2013:11:51:20 +0200] "PROPFIND / HTTP/1.1" 200 1807

And maybe you should take a quick look at the changes to OwnCloud, that were done in the links I posted.

ds-106
Newbie
Posts: 3
Joined: Wed Apr 03, 2013 10:21 pm
ownCloud version: 5.0.0
Webserver: Apache
Database: SQLite
OS: Linux

Re: CardDAV & CalDAV not working on Blackberry Z10

Postby ds-106 » Wed Apr 03, 2013 10:51 pm

Hi,
I can only talk about BB Playbook but it seams to be the same implementation as BB Z10.
OwnCloud 5.0 is running on Synology DS411+II NAS. For CardDAV I've short url enabled (.htaccess)

Code: Select all

RewriteCond %{HTTP_HOST} ^carddav
RewriteCond %{REQUEST_URI} !^/apps
RewriteRule .* /apps/contacts/carddav.php/$1 [L]


CalDAV
up and running with long and short url

CardDAV
long url

Code: Select all

192.168.1.40/owncloud/remote.php/carddav/addressbooks/<USERNAME>/contacts

no authentication and Playbook says
Account XXXX failed testing with current settings
httpd-ssl-user.log:

Code: Select all

[03/Apr/2013:22:35:33 +0200] 192.168.1.2 TLSv1 DHE-RSA-AES256-SHA "PROPFIND /.well-known/carddav HTTP/1.1" 368
[03/Apr/2013:22:35:33 +0200] 192.168.1.2 TLSv1 DHE-RSA-AES256-SHA "PROPFIND / HTTP/1.1" 349


short url

Code: Select all

carddav.mydomain.net

Playbook can authenticate and is connected BUT only oneway sync Playbook->OwnCloud, no sync OwnCloud ->Playbook.
owncloud.log:

Code: Select all

{"app":"PHP","message":"Undefined variable: baseuri at \/volume1\/web\/owncloud\/apps\/contacts\/appinfo\/remote.php#55","level":2,"time":1365021342}


Regards Goetz


  • Similar Topics
    Replies
    Views
    Last post

Return to “Discuss possible bugs & feature requests”

Who is online

Users browsing this forum: No registered users and 1 guest