Configure xcache administration access

Tutorials on ownCloud administration
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
leonbruner
Newbie
Posts: 9
Joined: Sat Aug 17, 2013 6:55 pm
ownCloud version: 5.0.10
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.4.4

Configure xcache administration access

Postby leonbruner » Fri Oct 04, 2013 3:05 am

I hope the following information is helpful to newbies like me who need to set up the xcache administration access necessary to complete a manual installation of OwnCloud. The dialog related to this problem is found elsewhere in this forum: viewtopic.php?f=23&t=14446

The problem occurred as follows: After installing the OwnCloud files onto my server I navigated to the login/setup page and entered the admin user password. I then chose the advanced option and MySQL which opened up fields to enter database username, database name and database password. After clicking on set up I received the following messages:

The website encountered an error while retrieving http://myurl.com/index.php. It may be down for maintenance or configured incorrectly. Reload this webpage. Press the reload button to resubmit the data needed to load the page. Error code: 500.

On checking the error logs I found the following messages:

[Sat Sep 07 08:40:29 2013] [error] [client xxx.xxx.xxx.xxx] client denied by server configuration: /var/www/myurl/web/data/htaccesstest.txt

[Sat Sep 07 08:40:29 2013] [warn] [client xxx.xxx.xxx.xxx] mod_fcgid: stderr: PHP Fatal error: xcache_clear_cache(): xcache.admin.user and/or xcache.admin.pass settings is not configured. Make sure you've modified the correct php ini file for your php used in webserver. in /var/www/clients/client2/web11/web/lib/util.php on line 854

I was advised in the forum that a potential solution was to configure the administration access to xcache as described in the following website:

http://xcache.lighttpd.net/wiki/InstallAdministration

Given that I am a very new Linux user and server administrator (an advanced appliance operator in reality...) when I read the xcache website it was like reading a foreign language. With some additional research and the help of a friend we managed to figure it out. I'm therefore posting the steps we followed to setup the xcache admin with the hope helps other users who may encounter the same problem.

The setup sequence is as follows:

1) Setup xcache
a. For purposes of this discussion you need to define several user names and passwords:
i. The domain name used in this example is yourdomain.com
ii. The xcache administrative user for this example will be: oranges
iii. The xcache administrative password for this example will be: flowinglake

2) Generate md5 password:
a. In order for xcache to work you need to generate md5 password that will be entered into the xcache.ini and php.ini
b. Using a text editor, create a file named, hashcreator.php, that contains the following lines:
<?php
echo md5("flowinglake");
?>
c. FTP the file, hashcreator.php into the /web subdirectory of your website.
d. Enter the following url into the command line of your browser:
http://yourdomain.com/hashcreator.php
e. The md5 hashtag associated with flowinglake will be shown: 2a17d4d66e78da9c48e8e124acb91d63

3) Modify /etc/php5/mods-available/xcache.ini
a. From the command line prompt execute the following commands:
i. cd /etc/php5/mods-available/
ii. cp xcache.ini xcache-backup (this makes a backup of xcache.ini before you change it!)
iii. Edit the file xcache.ini:
1. nano /etc/php5/mods-available/xcache.ini
a. Edit as shown below:

[xcache.admin]
xcache.admin.enable_auth = On
; Configure this to use admin pages
xcache.admin.user = "oranges"
; xcache.admin.pass = md5($your_password)
xcache.admin.pass = "2a17d4d66e78da9c48e8e124acb91d63"

b. ^x and follow directions to save edited file

4) Enter the md5 hash tag and administrator name into /etc/php5/apache2/php.ini
a. cp /etc/php5/apache2/php-backup.ini to backup the file
b. nano /etc/php5/apache2/php.ini
i. Scroll to the bottom of the file and enter the indicated lines:

[dba]
;dba.default_handler=

[xcache.admin]
xcache.admin.user = "oranges"
xcache.admin.pass = “2a17d4d66e78da9c48e8e124acb91d63"

; Local Variables:
; tab-width: 4
; End:

ii. ^x and follow directions to save edited file

5) Copy xcache admin page to one of the domains stored on the webserver
a. cp -a /usr/share/xcache/admin /var/www/yourdomain.com/web/xcache_admin

6) Restart apache2 with the following command: /etc/init.d/apache2 restart

7) Change group and user associated with files in /web
a. chown -R yourdomain.com/web
b. chgrp -R yourdomain.com/web

8) If using ISPConfig change PHP setting on website page from fastCGI to suPHP

9) Install OwnCloud using your normal procedure

10) Go to the domain where owncloud was installed: http://yourdomain.com
a. You should see a set-up page
b. Enter user name and password for your OwnCloud site
c. If using mysql database click on advanced and fill in the following fields:
i. Database name
ii. Database password
iii. Database user
iv. Localhost
d. Click on the icon and setup will start
e. When prompted for authentication enter the following:
i. User: oranges
ii. Password: flowinglake

11) If it’s working setup will proceed and you will soon see your first login page for OwnCloud.

rasos
Newbie
Posts: 8
Joined: Tue Dec 25, 2012 11:37 pm

Re: Configure xcache administration access

Postby rasos » Sun Oct 20, 2013 8:36 am

Thanks, this was very helpful, as the standard owncloud server Ubuntu package does not cover the xcache setup.
There are more simple ways to generate an md5 password (point 2), e.g. use http://www.md5generator.de/

RealRancor
ownCloud master
Posts: 17381
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.2
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Configure xcache administration access

Postby RealRancor » Sun Oct 20, 2013 10:45 am

Hi,

even it is simpler i wouldn't put in a "real" password which i'm using at my server in a 3rd party website. :D
*gone*

denizea
Newbie
Posts: 1
Joined: Fri Nov 29, 2013 12:31 pm

Re: Configure xcache administration access

Postby denizea » Fri Nov 29, 2013 12:32 pm

Thank you so much for the tips. It worked on me.

Ubuntu 13.04 Server with Apache installed machine.


  • Similar Topics
    Replies
    Views
    Last post

Return to “Tutorials”

Who is online

Users browsing this forum: No registered users and 2 guests