OwnCloud Webdav on GoDaddy shared Linux hosting

Tutorials on ownCloud administration
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
steveyoung82
Newbie
Posts: 3
Joined: Wed Jan 09, 2013 8:15 pm
ownCloud version: 4.5.5

OwnCloud Webdav on GoDaddy shared Linux hosting

Postby steveyoung82 » Wed Jan 09, 2013 8:27 pm

So after countless weeks of searching and trying to get OwnCloud working on Godaddy's shared linux hosting with webdav, I have found that there wasn't anything in these forums that would help someone out. I run OwnCloud in-house but needed to utilize a hosting provider for a second instance. (Bandwidth limitations) So to all of the frustrated GoDaddy users out there here it is:

Login to your account and create a new mysql database for your owncloud instance.

Download OwnCloud decompress and upload to the server via ftp. (Here's where things get tricky.)

Godaddy even though they use php5, doesn't come with a php5.ini file by default. Create one and add the following code to it and save it to the root directory:

Code: Select all

cgi.fix_pathinfo = 1


Then there are some changes that need to be made in the .htaccess file.
The below code is my entire /htaccess file. Just copy and paste:

Code: Select all

ErrorDocument 403 /core/templates/403.php
ErrorDocument 404 /core/templates/404.php
<IfModule mod_php5.c>
php_value upload_max_filesize 513M
php_value post_max_size 513M
php_value memory_limit 512M
<IfModule env_module>
  SetEnv htaccessWorking true
</IfModule>
</IfModule>
<IfModule mod_rewrite.c>
#Fix Rewrite
Options -Multiviews
RewriteEngine on
RewriteBase /
RewriteCond $1 !^(index\.php|css|gfx|js|swf|robots\.txt|favicon\.ico)
#RewriteRule ^(.*)$ /index.php/$1 [L]
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/carddav /remote.php/carddav/ [R]
RewriteRule ^.well-known/caldav /remote.php/caldav/ [R]   
RewriteRule ^apps/calendar/caldav.php remote.php/caldav/ [QSA,L]
RewriteRule ^apps/contacts/carddav.php remote.php/carddav/ [QSA,L]
RewriteRule ^apps/([^/]*)/(.*\.(css|php))$ index.php?app=$1&getfile=$2 [QSA,L]
RewriteRule ^remote/(.*) remote.php [QSA,L]
RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} !-f
</IfModule>
<IfModule mod_mime.c>
AddType image/svg+xml svg svgz
AddEncoding gzip svgz
</IfModule>
Options -Indexes


If you notice the 1st rewrite rule
RewriteRule ^(.*)$ /index.php/$1 [L]
. what this does is when navigating to yoursite.com/remote.php/webdav/ the rule returns yoursite.com/index.php/remote.php/webdav/
This results in the dreaded 404 error when connecting, or the No Input File Specified message. By commenting out the string it allowed all of my systems to connect via webdav, and it works in the browser as well.

Good Luck!! Reply if you have any more questions and I'll try to answer them often.

Happy Clouds!!
Steve

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby RandolphCarter » Thu Jan 10, 2013 12:36 pm

I have found that there wasn't anything in these forums that would help someone out.

Hm, this sounds quite like a generic accusation... however this seems to be your first post here, so you haven't even tried asking a question here before ... ?

steveyoung82
Newbie
Posts: 3
Joined: Wed Jan 09, 2013 8:15 pm
ownCloud version: 4.5.5

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby steveyoung82 » Thu Jan 10, 2013 11:45 pm

This wasn't meant to be a bash on anyone.

And yes there was a lack of information.

Also, now it's here and no one will have to ask!!

Thanks for the awesome comment!!

User avatar
RandolphCarter
ownCloud master
Posts: 5134
Joined: Wed May 30, 2012 8:42 am
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.x

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby RandolphCarter » Fri Jan 11, 2013 10:02 am

Actually I didn't mean to belittle your post, I was just wondering a little about the formulation. The very first should have actually been to thank you very much for sharing :)

steveyoung82
Newbie
Posts: 3
Joined: Wed Jan 09, 2013 8:15 pm
ownCloud version: 4.5.5

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby steveyoung82 » Sat Jan 12, 2013 9:44 pm

Thank you. I was just trying to help others out like myself who had searched the forums and come up empty.
I'm not usually the type to ask questions, I just wanted to help others who may have had simallar difficulties.

I hope everyone here can appreciate this if you use godaddy.

Thanks again for the reply.

kennedy32
Newbie
Posts: 4
Joined: Wed Feb 27, 2013 8:01 pm
ownCloud version: 4.5.7
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby kennedy32 » Fri Mar 01, 2013 7:55 pm

I tried it on godaddy, but the problem still exists

newone
Newbie
Posts: 1
Joined: Fri Mar 15, 2013 7:40 am

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby newone » Fri Mar 15, 2013 7:51 am

"OwnCloud Webdav on GoDaddy shared Linux hosting" but how you convert from here to there?? i also change my hosting tell me what process??
http://www.gotapparel.com/m-44-van-heusen.aspx

unamike
Newbie
Posts: 1
Joined: Sun Apr 21, 2013 1:15 am
ownCloud version: 5.0.5
Webserver: Apache
Database: SQLite
OS: Linux Hosting Package
PHP version: 5.3fastcgi

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby unamike » Sun Apr 21, 2013 1:27 am

This didn't work for me either. However changing the privileges on my tmp directory did. I added execute access for the owner group.

You can try this:

ssh into your account. Make sure that you're in the top level of your file tree.
Type "chmod 700 tmp".

Everything magically worked after that.

Good luck.

joeblow
Newbie
Posts: 1
Joined: Sun Apr 28, 2013 8:43 pm
ownCloud version: 5.0.5
Webserver: Apache
Database: MySQL
OS: Linux Hosting Package
PHP version: 5.3

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby joeblow » Mon Apr 29, 2013 3:20 am

The issue with Go Daddy is really testing my will! NONE of the actions suggested, work on the shared Linux hosting at Go Daddy!

To those whom have made the magic happen... how about a little more detail how you made this occur!

Because what is post here is not working... and will not work no matter how you attempt the process... The .htaccess file trashes the server with a 500 Error! So I am up for some DETAILED thoughts!

pdrayton
Newbie
Posts: 2
Joined: Fri May 10, 2013 8:28 pm
ownCloud version: 5.0.5
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.3.2

Re: OwnCloud Webdav on GoDaddy shared Linux hosting

Postby pdrayton » Fri May 10, 2013 8:37 pm

First of all, big thanks to the OP for taking the time to share what worked for him.

Doesn't work for me either. Perhaps I've made an error, and these questions below will find them, here's what I did.

I've installed in /cloud folder on my shared server.
Created a mysql db and used it in the advanced settings of creating an admin account
Created .htaccess using the code OP supplied, and put in /cloud folder. Didn't change my htaccess in the / root folder.
Created php5.ini with the code from OP
Gave /data /admin /config folders all the permissions I could (just to see if it worked)


I get the 'input file' error when logging in.
Perhaps I need to edit my htaccess to account for not being in the root foldeR?

UPDATE: I copied the php5.ini file to the root folder and logged in. Got a 'page isn't redirecting properly' error. URL it is trying to open is

Code: Select all

http://www.mysite.com/cloud/index.php?redirect_url=%2Fcloud%2Findex.php%2Fapps%2Ffiles


Could this be from the htaccess in my root folder looking like this:

Code: Select all

order allow,deny
   deny from 208.109.138.40
allow from all

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


  • Similar Topics
    Replies
    Views
    Last post

Return to “Tutorials”

Who is online

Users browsing this forum: No registered users and 2 guests