Adding external local storage doesn't save

Ask all your questions regarding OC 5.x Please read the Support Forum Rules
Forum rules
ownCloud 5.x reached end of life and is officially unsupported. For details see Wiki page.

Please upgrade your ownCloud.
jasonthibeault
Newbie
Posts: 3
Joined: Tue Sep 24, 2013 7:27 pm
ownCloud version: 5.0.10
Webserver: IIS
Database: MySQL
OS: Windows Server
PHP version: 5.4

Adding external local storage doesn't save

Postby jasonthibeault » Tue Sep 24, 2013 7:40 pm

I'm using OC 5.0.11 on Windows Home Server with IIS 6. Everything is working great except adding local external storage.

I've enabled the external storage app and see the option in the Admin GUI.

When I add my local mount using the GUI, I get a little green circle next to it after assigning a group. This was after I changed the permissions on the mount to include full access for IUSR. But I don't know how to commit what I have entered so the actual share shows up in the Files. I've clicked on the only save button in the Admin settings page but when I do that, the page refreshes and my mount is gone. I've clicked on Files and then returned to the Admin page but the mount is gone as well.

Not sure what I am doing wrong. Seems that my mount is not saving.

Thanks,

Jason

RealRancor
ownCloud master
Posts: 16416
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.1
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Adding external local storage doesn't save

Postby RealRancor » Tue Sep 24, 2013 8:17 pm

Hi,

having a look at your data/owncloud.log, at the javascript console of your browser or at your servers logfiles like described here:

viewtopic.php?f=17&t=7330

could give you some hints whats wrong here.
Report a bug? / Request a feature? / Developers contact/feedback? See: https://forum.owncloud.org/viewtopic.php?f=17&t=23696

jasonthibeault
Newbie
Posts: 3
Joined: Tue Sep 24, 2013 7:27 pm
ownCloud version: 5.0.10
Webserver: IIS
Database: MySQL
OS: Windows Server
PHP version: 5.4

Re: Adding external local storage doesn't save

Postby jasonthibeault » Tue Sep 24, 2013 9:27 pm

This is the only line in my OC logfile:

{"app":"PHP","message":"opendir(C:\\WINDOWS\\temp\/owncloud-5241420be4bab\/,C:\\WINDOWS\\temp\/owncloud-5241420be4bab\/): Access is denied. (code: 5) at C:\\Inetpub\\owncloud\\lib\\cache\\fileglobal.php#92","level":2,"time":"2013-09-24T16:47:32+00:00"}

would that have anything to do with it?

What's interesting is in my data directory, there is a mount.json which, when opened, shows the external mount that I keep adding. Seems maybe to be a javascript error.

i would say it's a permission error but before I changed the permission on the folder, I got that red square. Once I changed it, I got the green circle.

RealRancor
ownCloud master
Posts: 16416
Joined: Sat May 26, 2012 3:00 pm
ownCloud version: 9.0.1
Webserver: nginx
Database: MySQL
OS: Linux
PHP version: 7.0.x

Re: Adding external local storage doesn't save

Postby RealRancor » Wed Sep 25, 2013 9:31 am

Hi,

i don't think this message has something to do with your original problem but it should be fixed by setting the proper permissions for your webserver user to the tmp folder (IIRC there are some threads available on this forums about this)

If the mount.json gets created properly it really looks like some problem in either the javascript / display code or a browser issue. Did you had a look at the javascript console of your browser?
Report a bug? / Request a feature? / Developers contact/feedback? See: https://forum.owncloud.org/viewtopic.php?f=17&t=23696

jasonthibeault
Newbie
Posts: 3
Joined: Tue Sep 24, 2013 7:27 pm
ownCloud version: 5.0.10
Webserver: IIS
Database: MySQL
OS: Windows Server
PHP version: 5.4

Re: Adding external local storage doesn't save

Postby jasonthibeault » Wed Sep 25, 2013 4:37 pm

I have not had a chance to look at my javascript console. I will do that today. I did fix the temp folder permissions.


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 5.x and older”

Who is online

Users browsing this forum: No registered users and 4 guests