how to enable webdav access [SOLVED]

Ask all your questions regarding OC 7.x Please read the Support Forum Rules
Forum rules
ownCloud 7.x will be end of life soon. See maintenance and release schedule for more details.

Time to upgrade!

Before you post; make sure you are using at least PHP Version 5.3.x - Also read Support Forum - Read this before posting
lk2014
Newbie
Posts: 8
Joined: Thu Dec 11, 2014 5:40 pm
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Linux

how to enable webdav access [SOLVED]

Postby lk2014 » Thu Dec 11, 2014 5:51 pm

Hi,

I have just succesfully installed owncloud 7.0.4 on an Ubuntu 14.04 docker container.

The problem is that I have no idea how to access the server via Webdav.

I tried this link with no success:
davs://www.eidosoft.com:10443/owncloud/ ... php/webdav

Here is the configuration for apache web server (001-owncloud.conf):

Code: Select all

<Directory /var/www/owncloud>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Require all granted
    Dav Off
    Satisfy Any
</Directory>
<VirtualHost *:443>
  DocumentRoot /var/www/owncloud
  <Directory /var/www/owncloud>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Require all granted
    Dav Off
    Satisfy Any
  </Directory>
  SSLEngine on
  SSLCertificateFile /etc/apache2/ssl/server.crt
  SSLCertificateKeyFile /etc/apache2/ssl/server.key
</VirtualHost>


Any ideas about how to activate the WebDav support?

Thanks

LK
Last edited by lk2014 on Sat Dec 13, 2014 5:59 pm, edited 1 time in total.

starkruzr
Beginner
Posts: 26
Joined: Wed Mar 19, 2014 10:41 pm
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.12

Re: how to enable webdav access

Postby starkruzr » Thu Dec 11, 2014 6:21 pm

Why do you have "dav off" in your configuration?

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: how to enable webdav access

Postby tflidd » Thu Dec 11, 2014 6:29 pm

That's ok, owncloud doesn't use the webserver's webdav support, it brings it owns (see example-config in the docs).

Can you try to access webdav via your browser:
https://www.eidosoft.com:10443/owncloud/ ... php/webdav

Check your logfiles, if there are any suspicious entries.

starkruzr
Beginner
Posts: 26
Joined: Wed Mar 19, 2014 10:41 pm
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.12

Re: how to enable webdav access

Postby starkruzr » Thu Dec 11, 2014 6:44 pm

tflidd wrote:That's ok, owncloud doesn't use the webserver's webdav support, it brings it owns (see example-config in the docs).

Can you try to access webdav via your browser:
https://www.eidosoft.com:10443/owncloud/ ... php/webdav

Check your logfiles, if there are any suspicious entries.

I think something strange is going on with your links. Hang on, lemme take a look at this.

Also, when I try to connect to https://www.eidosoft.com:10443/owncloud ... php/webdav, it sees the DAV share correctly and tries to authenticate me.

lk2014
Newbie
Posts: 8
Joined: Thu Dec 11, 2014 5:40 pm
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: how to enable webdav access

Postby lk2014 » Thu Dec 11, 2014 8:44 pm

tflidd wrote:That's ok, owncloud doesn't use the webserver's webdav support, it brings it owns (see example-config in the docs).

Can you try to access webdav via your browser:
https://www.eidosoft.com:10443/owncloud/ ... php/webdav

Check your logfiles, if there are any suspicious entries.


An owncloud page appears with the message: "File not found - The specified document has not been found on the server. You can click here to return to ownCloud."

On the log there is nothing. I noticed that on the log I can see the attempt to access from Krusader using webdav protocol.

LK

lk2014
Newbie
Posts: 8
Joined: Thu Dec 11, 2014 5:40 pm
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: how to enable webdav access

Postby lk2014 » Thu Dec 11, 2014 8:47 pm


Also, when I try to connect to https://www.eidosoft.com:10443/owncloud ... php/webdav, it sees the DAV share correctly and tries to authenticate me.


??? If I try that url I get an owncloud page telling "File not found".

Are you sure you can try to authenticate?

LK

tflidd
Forum Moderator
Posts: 7159
Joined: Sat Dec 07, 2013 7:27 pm
ownCloud version: 8.2.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: how to enable webdav access

Postby tflidd » Fri Dec 12, 2014 9:28 am

Can you try this link:
https://www.eidosoft.com:10443/remote.php/webdav

Your installation seems not to be in a subfolder owncloud (if you prefer it with owncloud in the URL, you have to change the DocumentRoot to /var/www)

lk2014
Newbie
Posts: 8
Joined: Thu Dec 11, 2014 5:40 pm
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: how to enable webdav access

Postby lk2014 » Fri Dec 12, 2014 6:38 pm

tflidd wrote:Can you try this link:
https://www.eidosoft.com:10443/remote.php/webdav

Your installation seems not to be in a subfolder owncloud (if you prefer it with owncloud in the URL, you have to change the DocumentRoot to /var/www)


You are right. I changed the configuration and now it works.

Just a thing: the root of apache now is accessible to everyone (everyone can list the content of that direcotry). Is it possible to disable the access to that directory?

LK

starkruzr
Beginner
Posts: 26
Joined: Wed Mar 19, 2014 10:41 pm
ownCloud version: 8.1.1
Webserver: Apache
Database: MySQL
OS: Linux
PHP version: 5.5.12

Re: how to enable webdav access

Postby starkruzr » Fri Dec 12, 2014 8:40 pm

lk2014 wrote:
tflidd wrote:Can you try this link:
https://www.eidosoft.com:10443/remote.php/webdav

Your installation seems not to be in a subfolder owncloud (if you prefer it with owncloud in the URL, you have to change the DocumentRoot to /var/www)


You are right. I changed the configuration and now it works.

Just a thing: the root of apache now is accessible to everyone (everyone can list the content of that direcotry). Is it possible to disable the access to that directory?

LK

You could turn off Apache directory browsing. Google that and you'll almost certainly get it immediately.

lk2014
Newbie
Posts: 8
Joined: Thu Dec 11, 2014 5:40 pm
ownCloud version: 7.0.3
Webserver: Apache
Database: MySQL
OS: Linux

Re: how to enable webdav access

Postby lk2014 » Sat Dec 13, 2014 1:46 pm

You could turn off Apache directory browsing. Google that and you'll almost certainly get it immediately.

I googled a lot but I'm still not able to disable web server to browse the root directory.
I tried -Index option and the web server didn't start, with the None option the server starts but the root directory is still available.
I'm starting to think that I cannot do this configuration inside a sites-available/mysite.conf file.

LK


  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Community Edition 7.x”

Who is online

Users browsing this forum: No registered users and 4 guests