Trusted Domains with Docker and reverse proxy

Ask all your questions regarding OC 8.2 Please read the Support Forum Rules
Forum rules
The forums were migrated over to https://central.owncloud.org which is based on the forum software Discourse. The forums here is put into read-only mode starting from today.

More background information about this move and the reasoning behind it is available in this blogpost:

https://daniel.molkentin.net/2016/07/20 ... d-central/
r2doesinc
Newbie
Posts: 1
Joined: Wed Mar 09, 2016 3:23 am
ownCloud version: 8.2.3
Webserver: Apache
Database: SQLite
OS: Linux

Trusted Domains with Docker and reverse proxy

Postby r2doesinc » Wed Mar 09, 2016 3:35 am

Environment:Ubuntu 14

Server: Apache

Database: SQLite

Client:

OC-Version:8.2

PHP-Version:


I have an owncloud instance running in a docker container. I have port 801 mapped to port 80. I have an apache reverse proxy setup to reach oc @ cloud.domain.com. I have cloud.domain.com, localhost, and the local ip of the box in the trusted domains array. When i go to the local ip - http://192.168.1.134:801 -, everything works. When i go to cloud.domain.com I log in, then am sent to the trusted domains error page. The link then points me to "http://192.168.1.134:801/index.php/settings/admin?trustDomain=localhost" telling me to add localhost to the domains list, which i already have.

I have tried restarting apache and the docker container, as well as deleting and creating the container again, but nothing is working. Any ideas?


Code: Select all

 'trusted_domains' => array (
    0 => '192.168.1.134:801',
    1 => 'cloud.futurehax.org',
    2 => 'localhost',
    3 => '127.0.0.1',
  ),
  'datadirectory' => '/var/www/html/data',
  'overwrite.cli.url' => 'http://192.168.1.134:801/owncloud',
  'dbtype' => 'sqlite3',
  'version' => '8.2.2.2',
  'logtimezone' => 'UTC',
  'installed' => true,
);

  • Similar Topics
    Replies
    Views
    Last post

Return to “ownCloud Server 8.2”

Who is online

Users browsing this forum: No registered users and 0 guests